Side stage hides after rotating

Bug #1637258 reported by Michal Predotka
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Fix Released
High
Michał Sawicz
unity8 (Ubuntu)
Fix Released
High
Michael Zanetti

Bug Description

bq M10 rc-proposed r219

Steps to reproduce:
1. Open an app
2. Put it in the side stage
3. Rotate the tablet to portrait
At this point you should see the app which was in the side stage on the whole screen
4. Rotate the tablet back to landscape

Expected result:
The app is visible in the side stage

What happens instead:
The side stage is closed but the app still has focus as its name is visible in the top bar (screenshot attached)

Related branches

Revision history for this message
Michal Predotka (mpredotka) wrote :
Michał Sawicz (saviq)
Changed in unity8 (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Michael Zanetti (mzanetti)
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
Michał Sawicz (saviq)
Changed in canonical-devices-system-image:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Michał Sawicz (saviq)
milestone: none → 14
Revision history for this message
Michal Predotka (mpredotka) wrote :

Thanks for the quick fix! I've installed silo #2177 with this and other bug fixes. I have one question regarding this issue though. When using silo #2177, I noticed the app is visible in the side stage after rotation only if that app is focused. But if an app is in the side stage and the main app is focused, after rotating to portrait and back to landscape, the side stage is hidden. I'm not sure if that's by design or not?

Revision history for this message
Michał Sawicz (saviq) wrote :

@Michał:

I think this is slightly subjective, i.e. one person might expect one, another something else.

I myself agree that the sidestage should be persistent through rotations, until you actively move it away.

Can you file a new bug against unity8 and ubuntu-ux? Thanks!

Revision history for this message
Michal Predotka (mpredotka) wrote :

I agree, it is a bit subjective. I spoke with @mzanetti yesterday and we both have the same opinion as you. Reported bug #1641072

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.14+17.04.20161109-0ubuntu1

---------------
unity8 (8.14+17.04.20161109-0ubuntu1) zesty; urgency=medium

  [ Albert Astals Cid ]
  * Make more CardTool properties readonly
  * Make the > in Dash Section Header be after text (LP: #1508905)
  * Rework Dash Preview column margins
  * Improve LVWPH <-> GenericScopeView interaction (LP: #1508905,
    #1622423)
  * Make the PreviewButtons be of the width of the button and not half
    the total width
  * Fix first column of the preview table to be 25%

  [ Andrea Cimitan ]
  * Remove background under header pagination dots, update dots assets,
    remove dash paper background, update bottom edge asset
  * Few styling changes for cards
  * various tweaks to fonts inside previews
  * More visual tweaks

  [ Brian Douglass ]
  * Add a new setting to enable/disable the launcher

  [ Lukáš Tinkl ]
  * Stabilize test_doubleTapToMaximizeWindow()
  * Enable loading the main Qt catalog which in turn allows for using
    RTL languages
  * Fix the pixelated notification icon by setting sourceSize (LP:
    #1637712)

  [ Michael Terry ]
  * More path lookup fixes for running inside of a snap. (LP: #1629009)

  [ Michael Zanetti ]
  * Added blur and darkening to wallpaper while in spread
  * Fixes in the spread after design review (LP: #1637502, #1638848)
  * More fixes to the unified stages code (LP: #1637205, #1637249,
    #1637258)
  * Delay alt tab for tiny bit in order to avoid flickering on quick alt-
    tabs

  [ Tomás Tormo ]
  * Reload Infographics userdata when the day changes (LP: #1378814)

 -- Michał Sawicz <email address hidden> Wed, 09 Nov 2016 15:10:32 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers