unity8-dash crashed with SIGSEGV in QQmlData::isSignalConnected from QObjectPrivate::isSignalConnected from QMetaObject::activate from QMetaObject::activate from QAbstractItemModel::modelAboutToBeReset

Bug #1627795 reported by errors.ubuntu.com bug bridge on 2016-09-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
unity-scopes-shell (Ubuntu)
High
Marcus Tomlinson
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding unity8. This problem was most recently seen with version 8.14+15.04.20160831.3-0ubuntu1, the problem page at https://errors.ubuntu.com/problem/0168de360a9e17b6337e0304609320555b011747 contains more details.

Related branches

summary: - /usr/bin/unity8-dash:11:QQmlData::isSignalConnected:QObjectPrivate::isSignalConnected:QMetaObject::activate:QMetaObject::activate:QAbstractItemModel::modelAboutToBeReset
+ unity8-dash crashed with SIGSEGV in QQmlData::isSignalConnected from
+ QObjectPrivate::isSignalConnected from QMetaObject::activate from
+ QMetaObject::activate from QAbstractItemModel::modelAboutToBeReset
Paweł Stołowski (stolowski) wrote :

Looks like it's related to the changes to settings model made from a separate thread (QtConcurrent is used to update child scopes).

Changed in unity-scopes-shell (Ubuntu):
status: New → Confirmed
assignee: nobody → Marcus Tomlinson (marcustomlinson)
Changed in unity-scopes-shell (Ubuntu):
status: Confirmed → In Progress
Changed in unity8 (Ubuntu):
status: New → Invalid
Changed in unity-scopes-shell (Ubuntu):
importance: Undecided → High
Changed in canonical-devices-system-image:
importance: Undecided → High
status: New → In Progress
Changed in unity-scopes-shell (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers