[regression] Starting in Mesa 12.0.2, Mir EGL clients crash with SIGSEGV in dri2_destroy_context() (from eglDestroyContext or eglTerminate)

Bug #1620994 reported by dinamic on 2016-09-07
90
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
Mir
Invalid
Undecided
Unassigned
mesa (Ubuntu)
High
Chris Halse Rogers
unity8 (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu 16.10 + proposed x86, nvidia 8600gt nouveau

unity8-dash crashed with SIGSEGV in eglDestroyContext()

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: unity8 8.14+16.10.20160831.3-0ubuntu1
ProcVersionSignature: Ubuntu 4.6.0-10.12-generic 4.6.5
Uname: Linux 4.6.0-10-generic x86_64
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CrashCounter: 1
Date: Wed Sep 7 13:04:53 2016
ExecutablePath: /usr/bin/unity8-dash
InstallationDate: Installed on 2016-06-05 (93 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
ProcCmdline: unity8-dash --desktop_file_hint=/usr/share/applications/unity8-dash.desktop
SegvAnalysis:
 Segfault happened at: 0x7fcab45aea3e: mov 0x30(%rbp),%rax
 PC (0x7fcab45aea3e) ok
 source "0x30(%rbp)" (0x00000030) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity8
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so.1
 eglDestroyContext () from /usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so.1
 ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqpa-ubuntumirclient.so
 ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqpa-ubuntumirclient.so
 QOpenGLContext::destroy() () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
Title: unity8-dash crashed with SIGSEGV in eglDestroyContext()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
upstart.unity8-dash.log: [2016-09-07:13:04:52.767] QEGLPlatformContext: eglMakeCurrent failed: 3001

dinamic (dinamic6661) wrote :

StacktraceTop:
 dri2_destroy_context (drv=<optimized out>, disp=<optimized out>, ctx=0x555f62dd2c70) at ../../../src/egl/drivers/dri2/egl_dri2.c:1233
 eglDestroyContext (dpy=0x555f62936b40, ctx=<optimized out>) at ../../../src/egl/main/eglapi.c:653
 QEGLPlatformContext::~QEGLPlatformContext() () from /tmp/apport_sandbox_qJ2Nti/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqpa-ubuntumirclient.so
 ~UbuntuOpenGLContext (this=0x555f62d29460, __in_chrg=<optimized out>) at ../../../src/ubuntumirclient/glcontext.h:25
 UbuntuOpenGLContext::~UbuntuOpenGLContext (this=0x555f62d29460, __in_chrg=<optimized out>) at ../../../src/ubuntumirclient/glcontext.h:25

Changed in unity8 (Ubuntu):
importance: Undecided → Medium
summary: - unity8-dash crashed with SIGSEGV in eglDestroyContext()
+ unity8-dash crashed with SIGSEGV in dri2_destroy_context()
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2016-09-14
information type: Private → Public
summary: - unity8-dash crashed with SIGSEGV in dri2_destroy_context()
+ Mir clients crash on exit with SIGSEGV in dri2_destroy_context()
summary: - Mir clients crash on exit with SIGSEGV in dri2_destroy_context()
+ unity8-dash crashed with SIGSEGV in dri2_destroy_context()
summary: - unity8-dash crashed with SIGSEGV in dri2_destroy_context()
+ Mir clients with SIGSEGV in dri2_destroy_context() (from
+ eglDestroyContext or eglTerminate)

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
affects: mir (Ubuntu) → mesa (Ubuntu)
summary: - Mir clients with SIGSEGV in dri2_destroy_context() (from
+ EGL clients with SIGSEGV in dri2_destroy_context() (from
eglDestroyContext or eglTerminate)
Changed in mir:
status: New → Invalid
Changed in unity8 (Ubuntu):
status: Confirmed → Invalid

Reverting back to Mesa 12.0.1 seems to solve the problem (tested using the test case of bug 1623484)

summary: - EGL clients with SIGSEGV in dri2_destroy_context() (from
- eglDestroyContext or eglTerminate)
+ [regression] Starting in Mesa 12.0.2, EGL clients crash with SIGSEGV in
+ dri2_destroy_context() (from eglDestroyContext or eglTerminate)

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
tags: added: regression-release
tags: added: regression
removed: regression-release
Changed in canonical-devices-system-image:
milestone: none → 13
Changed in mesa (Ubuntu):
importance: Undecided → High
Changed in canonical-devices-system-image:
importance: Undecided → High
status: New → Confirmed
tags: added: unity8-desktop
Daniel van Vugt (vanvugt) wrote :

See also bug 1620934 which happened in the upgrade to 12.0.2

Timo Aaltonen (tjaalton) wrote :

could someone file this upstream?

Chris Halse Rogers (raof) wrote :

Not an upstream bug; this is a semantic merge error when updating the Mir EGL platform patch.

Changed in mesa (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Chris Halse Rogers (raof)
tags: added: egl-platform-mir
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 12.0.3-1ubuntu1

---------------
mesa (12.0.3-1ubuntu1) yakkety; urgency=medium

  * Merge from Debian.

  [ Christopher James Halse Rogers ]
  * egl-platform-mir.patch: Updated for upstream changes to dri2_initialize
    in egl_dri2.c. (LP: #1620934, #1620994)

mesa (12.0.3-1) unstable; urgency=medium

  * New upstream release.
  * Enable vc4 on arm64.

 -- Timo Aaltonen <email address hidden> Fri, 16 Sep 2016 10:07:05 +0300

Changed in mesa (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
summary: - [regression] Starting in Mesa 12.0.2, EGL clients crash with SIGSEGV in
- dri2_destroy_context() (from eglDestroyContext or eglTerminate)
+ [regression] Starting in Mesa 12.0.2, Mir EGL clients crash with SIGSEGV
+ in dri2_destroy_context() (from eglDestroyContext or eglTerminate)
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
milestone: 13 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers