Dash freezes after U1 login

Bug #1607799 reported by Víctor R. Ruiz
44
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Fix Released
Critical
David Barth
libsignon-glib (Ubuntu)
Fix Released
Critical
Alberto Mardegan
unity-scopes-api (Ubuntu)
Invalid
Undecided
Unassigned
unity-scopes-shell (Ubuntu)
Invalid
Undecided
Unassigned
unity8 (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Test case.
- Without U1 account, go to Ubuntu Store.
- Tap on an app.
- Tap on the install button.
- Introduce credentials.

Expected result.
- After credentials, the app is installed.

Actual result.
- Dash is frozen. Cannot go back to the scopes. Launcher and indicators do work, though. There is no crash.

current build number: 389
device name: arale
channel: ubuntu-touch/rc-proposed/meizu.en

Related branches

Revision history for this message
Víctor R. Ruiz (vrruiz) wrote :
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

confirmed on desktop too.

Changed in canonical-devices-system-image:
importance: Undecided → Critical
milestone: none → 13
status: New → Confirmed
tags: added: regression-proposed
Changed in canonical-devices-system-image:
assignee: nobody → Michał Sawicz (saviq)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Revision history for this message
Lukáš Tinkl (lukas-kde) wrote :
Revision history for this message
Víctor R. Ruiz (vrruiz) wrote :
Revision history for this message
Albert Astals Cid (aacid) wrote :
Revision history for this message
Albert Astals Cid (aacid) wrote :

Seems to be libsignon-glib landing

I can confirm Victor's that image 385-arale works and image 386-arale fails.

Image 385-arale + libsignon-glib1 1.14+15.04.20160718-0ubuntu1 also fails for me.

Changed in unity8 (Ubuntu):
status: Confirmed → Incomplete
Changed in unity-scopes-shell (Ubuntu):
status: New → Incomplete
Changed in unity-scopes-api (Ubuntu):
status: New → Incomplete
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: New → Incomplete
Changed in libsignon-glib (Ubuntu):
status: New → Confirmed
Alberto Mardegan (mardy)
no longer affects: ubuntu-system-settings-online-accounts (Ubuntu)
Changed in libsignon-glib (Ubuntu):
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → Critical
status: Confirmed → In Progress
Michał Sawicz (saviq)
Changed in canonical-devices-system-image:
assignee: Michał Sawicz (saviq) → David Barth (dbarth)
status: Confirmed → In Progress
Revision history for this message
Selene ToyKeeper (toykeeper) wrote :

As far as I can tell, this is when the bug started:
https://requests.ci-train.ubuntu.com/#/ticket/1582
https://code.launchpad.net/~mardy/libsignon-glib/unregistered-lp1593805/+merge/298096

I ran into the issue today and tracked it down to that specific image (and that landing seems the most likely candidate), which led me to this bug.

Revision history for this message
Alberto Mardegan (mardy) wrote :

Fix is here, waiting for QA since several days: https://requests.ci-train.ubuntu.com/#/ticket/1743

Revision history for this message
Alejandro J. Cura (alecu) wrote :

I can confirm that the silo mentioned in #9 fixes the issue for me (frieza, rc-proposed r161).

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsignon-glib - 1.14+16.10.20160802.2-0ubuntu1

---------------
libsignon-glib (1.14+16.10.20160802.2-0ubuntu1) yakkety; urgency=medium

  * Merge from upstream.
    - Lib: don't use g_idle_add, respect thread affinity (LP: #1607799)

 -- Alberto Mardegan <email address hidden> Tue, 02 Aug 2016 14:11:17 +0000

Changed in libsignon-glib (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Michał Sawicz (saviq)
Changed in unity-scopes-api (Ubuntu):
status: Incomplete → Invalid
Changed in unity-scopes-shell (Ubuntu):
status: Incomplete → Invalid
Changed in unity8 (Ubuntu):
status: Incomplete → Invalid
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments