Accented dead characters (áéíóú) not working on external keyboards

Bug #1607237 reported by Sergi Quiles Pérez
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Fix Released
Critical
Cemil Azizoglu
Mir
Invalid
Critical
Unassigned
maliit-framework (Ubuntu)
Fix Released
Undecided
Andreas Pokorny
mir (Ubuntu)
Invalid
Critical
Unassigned
unity8 (Ubuntu)
Invalid
Critical
Unassigned

Bug Description

Accented dead characters (áéíóú) not working on external keyboards

Using my keyboard with Spanish layout:

 - PC: Everything works perfect.
 - Ubuntu Touch: I can't write accented characters (dead acute, áéíóú).

Extra info:

- Keyboard: https://goo.gl/photos/xZUE8kRsReW1VKPA6 (http://www.logitech.com/en-hk/product/wireless-touch-keyboard-k400r2)
- Ubuntu Desktop: 12.04
- Ubuntu Touch: bq Aquaris E4.5 15.04 (OTA-12)

Revision history for this message
Michał Sawicz (saviq) wrote :

What layout do you have selected in "Text & Language" > "External keyboard"?

Changed in canonical-devices-system-image:
status: New → Incomplete
Changed in unity8 (Ubuntu):
status: New → Incomplete
Revision history for this message
Lukáš Tinkl (lukas-kde) wrote :

Note this works on u8 but only on a laptop, so I suspect something lower in the stack.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mir (Ubuntu):
status: New → Confirmed
summary: - Accented characters (áéíóú) not working on external keyboards
+ Accented dead characters (áéíóú) not working on external keyboards
Revision history for this message
jordibardaji (jordibardaji) wrote :

Using my keyboard with Spanish layout:

 - PC: Everything works perfect.
 - Ubuntu Touch: I can't write nor accented characters (dead acute, áéíóú) neither altGr characters (@, in default web navigator)

***** in "Text & Language" > "External keyboard" = spanish

Extra info:

- Keyboard: silverht https://www.amazon.es/Silver-HT-Teclado-SilverHT-Trackpad/dp/B018EMSZXY
- Ubuntu Touch: bq Aquaris E4.5 15.04 (OTA-12)
- Ubuntu Touch: M10 ubuntu tablet 15.04 (OTA-12)

Revision history for this message
Michał Sawicz (saviq) wrote :

Hmm AltGr works for me on a Logitech K480 bluetooth keyboard at least, I don't have dead acute chars in my layout, will try and change it to Spanish to check later today.

Changed in canonical-devices-system-image:
status: Incomplete → Confirmed
Revision history for this message
Michał Sawicz (saviq) wrote :

Ah OK, now I get it - dead acute not working will be this bug, AltGr is bug #1590515.

Revision history for this message
Rüdiger Kupper (ruediger.kupper) wrote :

Confirming that typing accented characters does not work. This is with OTA-12, keyboard layout "German (Macintosh)".

Revision history for this message
Michael Zanetti (mzanetti) wrote :

FWIW, dead acute characters work for me on the M10 in XMir applications. But indeed they don't seem to work on native unity8 applications there.

Revision history for this message
Sergi Quiles Pérez (sergiqp) wrote :

@mzanettti Your're right it works i xapps but not in native apps.

Revision history for this message
Sergi Quiles Pérez (sergiqp) wrote :

@saviq I have selected Spanish layout. In OTA-11 there are a lot of comments confirming the same in many language layouts (see bug #156523).

Revision history for this message
Sergi Quiles Pérez (sergiqp) wrote :

Sorry bug #1565236. :-/

Revision history for this message
Sergi Quiles Pérez (sergiqp) wrote :

@saviq bug #1590515 it's related only to the default browser, bug #1565236 is related to navite apps and xapps.

Revision history for this message
Daniel Rodríguez Güell (pachugeek) wrote :

The problem persist in OTA-12 and bqm10. In xapps it works perfect but in native apps. In addiction, the 'arroba' character and the "altgr characters" works in all native apps except default navigator.

Revision history for this message
JyotiGomes (jyotigomes) wrote :

I am a Ubuntu supporter and was one of the first to buy the Ubuntu BQ M10 tablet. We, the Portuguese speaking supporters were surprised that was not possible to write in PORTUGUESE with the EXTERNAL KEYBOARD. We were assured that this issue would be resolved soon. But… it's been months and several OTAs and we still can not write Â, Ã, Á, À, Õ, etc…This problem makes it impossible at all to use the tablet that we bought in desktop mode.

Me, and all the people in Portugal who bought the Ubuntu tablet are very tired of all this situation, we are on the edge. Many of us are thinking about returning the tablet due to this fatal problem that has never been solved, despite promises. Canonical is not interested in the Portuguese users, this is the conclusion for many of us...

Changed in mir:
status: New → Confirmed
importance: Undecided → Critical
Changed in mir (Ubuntu):
importance: Undecided → Critical
Changed in unity8 (Ubuntu):
importance: Undecided → Critical
Revision history for this message
Einar Mostad (einarmostad) wrote :

The accented characters work on Xapps on Ubuntu touch (Firefox, LibreOffice) for me, but not in Ubuntu Touch apps. I'm using OTA 12 on BQ M10 with Norwegian keyboard layout.

Revision history for this message
Sergi Quiles Pérez (sergiqp) wrote :

I have done some tests (spanish layout, catalan language):

- In bq Aquaris E4.5 (OTA 12):
     Accented dead characters doesn't work in any app nor webapp.

- In bq Aquaris M10 (OTA 12):
     Accented dead characters doesn't work in any app nor webapp.
     Accented dead characters works in all Xapps.

Revision history for this message
Sergi Quiles Pérez (sergiqp) wrote :

In summary: accented dead characters only works in Xapps.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Sorry for the confusion. It appears bug 1565236 was closed prematurely before the implemented fix was ever even released. Now tracking in bug 1565236 again, at least until the apparent fix in Mir 0.24.0 actually gets released. If it's still broken after that we can un-duplicate this bug and continue here.

Revision history for this message
Michael Zanetti (mzanetti) wrote :

This is not a dupe of the other.

Theo ther is about AltGr, this is about dead keys

Michał Sawicz (saviq)
Changed in canonical-devices-system-image:
milestone: none → 13
importance: Undecided → Critical
assignee: nobody → Stephen M. Webb (bregma)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Well someone should reword the bug description here, because it's identical to that of bug 1565236 and that bug is still open. So presently this is an automatic duplicate of bug 1565236 while that one is still open.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Also, shouldn't we wait for the fix for bug 1565236 to get released in Mir 0.24.0 ?

Michał Sawicz (saviq)
Changed in canonical-devices-system-image:
assignee: Stephen M. Webb (bregma) → Cemil Azizoglu (cemil-azizoglu)
Revision history for this message
Sergi Quiles Pérez (sergiqp) wrote :

@vanvugt

You can see my original summary here: https://bugs.launchpad.net/ubuntu/+source/ubuntu-system-settings/+bug/1565236/comments/6

When it was changed the bug had a new sense more fitted to ALTGR only.

Changed in mir:
assignee: nobody → Andreas Pokorny (andreas-pokorny)
Revision history for this message
Andreas Pokorny (andreas-pokorny) wrote :

I do not think this is affected by mir. When a keymap with dead keys is selected clients like unity8-dash receive the respective dead key codes the qts compose key filter would interpret.

description: updated
Revision history for this message
Andreas Pokorny (andreas-pokorny) wrote :

Ok it works on desktop because desktop qt loads the qcomposeplatforminputcontext plugin. On Ubuntu Touch qt loads qmaliitphabletplatforminputcontext plugin. So no code is available to handle dead keys.

Revision history for this message
Andreas Pokorny (andreas-pokorny) wrote :

The simplest solution seems to be to load the compose input context from the maliitphablet input context..

Changed in mir:
status: Confirmed → Invalid
Changed in unity8 (Ubuntu):
status: Incomplete → Invalid
Changed in mir (Ubuntu):
status: Confirmed → Invalid
Changed in maliit-framework (Ubuntu):
status: New → In Progress
assignee: nobody → Andreas Pokorny (andreas-pokorny)
Changed in mir:
assignee: Andreas Pokorny (andreas-pokorny) → nobody
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Changed in maliit-framework (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Minor correction: The fix is committed in yakkety proposed right now:

maliit-framework (0.99.1+git20151118+62bd54b-0ubuntu11) yakkety; urgency=medium

But not 'released' anywhere.

Changed in maliit-framework (Ubuntu):
status: Fix Released → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maliit-framework - 0.99.1+git20151118+62bd54b-0ubuntu11

---------------
maliit-framework (0.99.1+git20151118+62bd54b-0ubuntu11) yakkety; urgency=medium

  [ Andreas Pokorny ]
  * Add compose-input-platform-in-maliit.patch to load qts compose key input
    context plugin
    (LP: #1607237)

 -- Timo Jyrinki <email address hidden> Thu, 04 Aug 2016 14:40:45 +0300

Changed in maliit-framework (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Revision history for this message
JyotiGomes (jyotigomes) wrote : Re: [Bug 1607237] Re: Accented dead characters (áéíóú) not working on external keyboards

Thanks a lot for your huge and wonderful work at canonical!

2016-09-20 22:06 GMT+01:00 Pat McGowan <email address hidden>:

> ** Changed in: canonical-devices-system-image
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1607237
>
> Title:
> Accented dead characters (áéíóú) not working on external keyboards
>
> Status in Canonical System Image:
> Fix Released
> Status in Mir:
> Invalid
> Status in maliit-framework package in Ubuntu:
> Fix Released
> Status in mir package in Ubuntu:
> Invalid
> Status in unity8 package in Ubuntu:
> Invalid
>
> Bug description:
> Accented dead characters (áéíóú) not working on external keyboards
>
> Using my keyboard with Spanish layout:
>
> - PC: Everything works perfect.
> - Ubuntu Touch: I can't write accented characters (dead acute, áéíóú).
>
> Extra info:
>
> - Keyboard: https://goo.gl/photos/xZUE8kRsReW1VKPA6 (
> http://www.logitech.com/en-hk/product/wireless-touch-keyboard-k400r2)
> - Ubuntu Desktop: 12.04
> - Ubuntu Touch: bq Aquaris E4.5 15.04 (OTA-12)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1607237/+
> subscriptions
>

Revision history for this message
Evandro P. Alves (evandro-pa) wrote :

Fantastic. Thanks to everyone. I can use my M10 now :)

Revision history for this message
Sergi Quiles Pérez (sergiqp) wrote :

Thanks, it is full fixed now. :-)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers