implement zoom in/zoom out [desktop]

Bug #1598805 reported by dinamic on 2016-07-04
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
Mir
Fix Released
Undecided
Daniel van Vugt
Ubuntu UX
Undecided
Unassigned
mir (Ubuntu)
Undecided
Daniel van Vugt
qtmir (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

implement zoom in/zoom out [desktop]

i need to zoom in/out when recording videos and since compiz is gone i can't do that anymore in unity8.

Related branches

kevin gunn (kgunn72) on 2016-07-05
tags: added: unity8-desktop
Daniel van Vugt (vanvugt) wrote :

If Mir is part of this bug at all, then it was implemented a few years ago in mir_proving_server (Super+mousewheel) and still works today. It's fun and super-smooth.

If Unity8 would like to reuse that implementation instead of doing its own then I'm open to the idea of moving the code into a location where USC can trigger it.

On that note, I've been thinking there may be some full-screen effects (zoom/contrast/negative) that are better implemented in the system compositor than Unity8. So they work seemlessly between sessions. Also as an added bonus: They already exist in mir_proving_server (Super+wheel/C/N). So again, I'm open to the idea of moving these existing effects to a location where USC can use them...

Changed in mir:
status: New → Fix Released
Changed in mir (Ubuntu):
status: New → Fix Released
dinamic (dinamic6661) wrote :

nice :D i'm using CTRL + ALT + wheel in compiz

Changed in mir:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in mir (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
tags: added: a11y
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtmir (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers