Have to log in to Unity8 twice (screen is locked after login from lightdm)

Bug #1582987 reported by Daniel van Vugt on 2016-05-18
22
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Michał Sawicz
unity8 (Ubuntu)
High
Michael Terry

Bug Description

You have to log in to Unity8 twice on desktop. Once in lightdm and again after Unity8 starts.

The second time is seemingly just the lock screen. But the screen should not be locked by default on desktop.

Related branches

Changed in unity8 (Ubuntu):
importance: Undecided → Medium
Changed in unity8-desktop-session (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in unity8-desktop-session (Ubuntu):
status: New → Confirmed
description: updated
Changed in unity8 (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Michael Terry (mterry) wrote :

This is blocked on Josh's split greeter branch (it allows us to launch unity8 without a greeter loaded). I'll link it.

Changed in unity8-desktop-session (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Changed in unity8 (Ubuntu):
assignee: Michael Terry (mterry) → Josh Arenson (josharenson)
kevin gunn (kgunn72) on 2016-06-06
Changed in canonical-devices-system-image:
status: New → Confirmed
assignee: nobody → Michał Sawicz (saviq)
importance: Undecided → High
Changed in unity8 (Ubuntu):
importance: Medium → High
Changed in unity8-desktop-session (Ubuntu):
importance: Medium → High
Michał Sawicz (saviq) on 2016-06-06
Changed in canonical-devices-system-image:
status: Confirmed → Triaged
Changed in unity8 (Ubuntu):
status: Confirmed → Triaged
Changed in unity8-desktop-session (Ubuntu):
status: Confirmed → Triaged
Michael Terry (mterry) wrote :

OK, I had forgotten we have the --mode argument already in trunk. Which means we can solve this today without blocking on the slim_greeter branch.

I've linked an independent unity8 branch that should fix this.

no longer affects: unity8-desktop-session (Ubuntu)
Changed in unity8 (Ubuntu):
assignee: Josh Arenson (josharenson) → Michael Terry (mterry)
status: Triaged → In Progress
Michał Sawicz (saviq) on 2016-06-17
Changed in canonical-devices-system-image:
status: Triaged → In Progress
milestone: none → 12
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.12+16.10.20160617-0ubuntu1

---------------
unity8 (8.12+16.10.20160617-0ubuntu1) yakkety; urgency=medium

  [ Michael Terry ]
  * Do not create Label/Icon if we don't need it
  * Fix Z-ordering of prompt surfaces (LP: #1586219)
  * Drop bottom edge tutorials completely and small fixes for other
    edges. (LP: #1565103)
  * Redo visuals for greeter prompt box. (LP: #1435923)
  * Make tutorial qmltests more robust. (LP: #1590810)
  * Stop showing an extra lockscreen in desktop unity8 sessions. (LP:
    #1582987)

  [ Albert Astals Cid ]
  * Improve dash plugin mock
  * Stabilize PreviewExpandableTest::test_all_widgets_height
  * Workaround QTBUG-53460
  * Split artShape code for cardTool card and regular card
  * Simplify the code since fixedArtSize code is mandatory for regular
    cards
  * Desktop stage: Support rotatesWindowContents (LP: #1547481)
  * Turn if if else into if elseif else
  * Fix leaks in QInputDeviceManagerPrivate::addDevice
  * Do not call |= on uninitialized sigterm.sa_flags
  * initialize udevMonitor
  * Make notifier and notifierFd function local variables
  * Fix crash if a component that is not an Item is given to
    sectionDelegate
  * Tests: Do not use dynamic_cast if we're not going to test it anyway
  * Minor coverity fixes
  * Fix warning about anchors.fill in ProportionalShape (LP: #1590963)
  * Make wait in cleanup() wait for snapTo animation to have finished

  [ Alexandros Frantzis ]
  * Improve the way notifications interact with power management (LP:
    #1570922)

  [ Andrea Cimitan ]
  * Correctly refresh cardcreator cache on artshapestyle changes (LP:
    #1588335)
  * Same tweaks we have for click scope now for libertine
  * add a timer to pull to refresh to work on small windows (LP:
    #1589060)

  [ Daniel d'Andrada ]
  * Clean up debug leftovers
  * Ensure mouse and window movement are pixel-aligned (LP: #1510382)
  * Fix SpreadDelegate rotation animations
  * No point in version-controlling files that are automatically
    generated
  * Center cursor on screen when it's first shown
  * Custom cursor name just have to start with "custom"
  * Work around AnimatedSprite infinite loop bug (LP: #1588929)

  [ Josh Arenson ]
  * Disable showDash when it is already shown. (LP: #1506708)
  * Add a timestamp to the dash log (LP: #1580074)
  * Add timestamp to unity8 log (LP: #1498169)

  [ Lukáš Tinkl ]
  * Implement keyboard shortcuts info panel
  * Implement window controls overlay activatable with 3 fingers tap
    (LP: #1489020)
  * Select correct Chinese input method for OSK in the wizard (LP:
    #1588633)

  [ Michael Zanetti ]
  * Add support for the launcher surface pips displaying the correct
    number of surfaces
  * Add support for the persistent alert state. (LP: #1575147, #1584348,
    #1586621)
  * send a Alt-release event on alt+tab instead of delaying it
    completely and invoking it later (LP: #1565236)

  [ Stephen M. Webb ]
  * added a new upstart $SESSION for unity8-desktop-session (LP:
    #1376715)

 -- Michael Terry <email address hidden> Fri, 17 Jun 2016 01:22:57 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2016-06-18
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers