A PhoneStage gets loaded and unloaded during desktop start up

Bug #1519779 reported by Daniel d'Andrada on 2015-11-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity8 (Ubuntu)
Medium
Michael Terry

Bug Description

Steps to reproduce the issue:
- Launch a unity8-mir session on a desktop/laptop

Expected outcome:
No PhoneStage gets loaded

Actual outcome:
A PhoneStage, along with a bunch of (fake) applications and surfaces are loaded and destroyed.

Comments:
Commenting out the Tutorial component in Shell.qml solves the problem.

Related branches

Changed in unity8 (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Michał Sawicz (saviq) on 2015-11-25
Changed in unity8 (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Michael Terry (mterry) wrote :

This will be fixed by the tutorial redesign. But currently, the Tutorial does use a PhoneStage to show its mock apps during the right-edge tutorial.

Daniel d'Andrada (dandrader) wrote :

The problem is not whether the Tutorial uses a PhoneStage or not. The problem is that it's unnecessarily loading it (just to trow it away immediately) during start up in a desktop environment. Which is a waste of CPU/Memory and negatively affects system start up time.

Changed in unity8 (Ubuntu):
status: Triaged → In Progress
Michael Terry (mterry) wrote :

Yup, agreed. Like I said, a rewrite is in the works anyway.

Michael Terry (mterry) on 2016-06-09
Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers