Bluetooth keyboard use doesn't prevent screen blanking

Bug #1516272 reported by James Lewis on 2015-11-14
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical Pocket Desktop
Critical
kevin gunn
Canonical System Image
Critical
kevin gunn
Unity System Compositor
Critical
Andreas Pokorny
unity-system-compositor (Ubuntu)
Undecided
Unassigned
unity-system-compositor (Ubuntu RTM)
Undecided
Unassigned
unity8 (Ubuntu)
Critical
Unassigned

Bug Description

Bluetooth mouse movement clears "idle" flag, but Bluetooth keyboard does not... so if you use a bluetooth keyboard to type for more than a few minutes the screen will blank....

Tested in r162 14/11/15

Related branches

kevin gunn (kgunn72) on 2015-11-16
Changed in canonical-pocket-desktop:
importance: Undecided → High
Changed in unity8 (Ubuntu):
importance: Undecided → High
Changed in unity-system-compositor:
importance: Undecided → High
Changed in canonical-pocket-desktop:
assignee: nobody → kevin gunn (kgunn72)
summary: - Bluetooth keyboard doesn't count as activity, screen locks while typing!
+ Bluetooth keyboard use doesn't prevent screen blanking
kevin gunn (kgunn72) wrote :

request to be a top priority bug from product management

Changed in unity8 (Ubuntu):
importance: High → Critical
Changed in canonical-pocket-desktop:
importance: High → Critical
Changed in unity-system-compositor:
importance: High → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in unity-system-compositor:
status: New → Fix Committed
assignee: nobody → Andreas Pokorny (andreas-pokorny)
Timo Jyrinki (timo-jyrinki) wrote :

unity-system-compositor (0.2.0+15.04.20151222.1-0ubuntu1) vivid; urgency=medium

  [ Alexandros Frantzis ]
  * tests: Fix build failure with gcc-4.9

  [ Andrea Cimitan ]
  * Updated wallpaper for spinner from unity8.

  [ Andreas Pokorny ]
  * Add clone method to StubdisplayConfigurations
  * Change keyboard handling to scan codes. (LP: #1514059, #1520422)
  * do not premultiply RGB images
  * follow the deprecation warning and use tobytes instead of tostring.

  [ Kevin DuBois ]
  * Accommodate RGB images (LP: #1528279)
  * Accommodate RGB images (LP: #1528279)

 -- Kevin DuBois <email address hidden> Tue, 22 Dec 2015 19:09:40 +0000

Changed in unity-system-compositor (Ubuntu RTM):
status: New → Fix Released
Changed in canonical-devices-system-image:
assignee: nobody → kevin gunn (kgunn72)
milestone: none → ww02-2016
Timo Jyrinki (timo-jyrinki) wrote :

The fixed bug #1520422 was a duplicate of this bug. Not sure about the overall status of this bug.

Changed in unity-system-compositor (Ubuntu):
status: New → Fix Committed
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → Critical
Changed in unity8 (Ubuntu):
status: Confirmed → Invalid
Changed in canonical-pocket-desktop:
status: New → Fix Committed
kevin gunn (kgunn72) on 2016-01-04
Changed in unity-system-compositor (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-system-compositor:
status: Fix Committed → Fix Released
Changed in canonical-pocket-desktop:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers