RGBX windows become discoloured (more white or translucent) and corrupt in the Unity8 window switcher

Bug #1510386 reported by Daniel van Vugt on 2015-10-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
qtmir (Ubuntu)
High
Unassigned
unity8 (Ubuntu)
High
Unassigned

Bug Description

RGBX windows become discoloured (more white or translucent) and corrupt in the Unity8 window switcher (Alt+Tab)

This is most noticeable in Xmir, but also with: mir_demo_client_multiwin -p2 -a--desktop_file_hint=unity8
(ignoring the fact that Unity8 also doesn't show the correct colours)

This might help: I fixed the same bug in Mir's demo shells yesterday:
https://code.launchpad.net/~vanvugt/mir/fix-1423462/+merge/275661

Daniel van Vugt (vanvugt) wrote :

Also, in a stroke of fragment shader weirdness, the offending windows appear clear through the Alt+Tab switcher's otherwise blurred background.

Changed in qtmir (Ubuntu):
importance: Undecided → High
Changed in unity8 (Ubuntu):
importance: Undecided → High
tags: added: xmir
Daniel van Vugt (vanvugt) wrote :

In case it's not yet obvious - the issue with RGBX windows is the X byte is uninitialized so needs to be ignored, rather than interpreting it as A for alpha.

summary: - RGBX windows become discoloured (more white or completely transparent)
- and corrupt in the Unity8 window switcher
+ RGBX windows become discoloured (more white or translucent) and corrupt
+ in the Unity8 window switcher
description: updated
Gerry Boland (gerboland) wrote :

How do I reproduce this Daniel?

Changed in qtmir:
status: New → Incomplete
Changed in qtmir (Ubuntu):
status: New → Incomplete
Changed in unity8 (Ubuntu):
status: New → Invalid
Daniel van Vugt (vanvugt) wrote :

Any window with a non-1.0 (less than 0xff) alpha or X channel gets discoloured when alt+tabbing:
  mir_demo_client_egltriangle -b 0.2 -- --desktop_file_hint=unity8

And you have to keep in mind that the 'X' byte might be uninitialized, so another good test case is:
  Xmir :0 -rootless -flatten -sw --desktop_file_hint=unity8
  env DISPLAY=:0 gedit
and then Alt+Tab.

Observed: Parts of the window in the switcher are discoloured/whiter. This is Unity8 treating the uninitialized X byte as an alpha byte. Although even RGBA windows get discoloured with low values of A.
Observed: In the background the fullscreen blur is also faulty -- it's clearer and not blurred in the same regions as are affected by the first issue.

Changed in qtmir:
status: Incomplete → New
Changed in qtmir (Ubuntu):
status: Incomplete → New
Changed in unity8 (Ubuntu):
status: Invalid → New
tags: added: visual-quality
tags: added: unity8-desktop
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtmir (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
status: New → Confirmed
Changed in qtmir:
status: New → Confirmed
Michał Sawicz (saviq) on 2017-03-13
no longer affects: qtmir
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers