Unify code that turns screen on when a notification happens

Bug #1482317 reported by Michael Terry
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
powerd (Ubuntu)
Undecided
Unassigned
telephony-service (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Undecided
Michael Terry

Bug Description

Right now, there are several places we ask USC to turn the screen on when a notification happens:

- powerd for SMS, USSD, and incoming calls
- telephony-service for MMS and telephony messages

And we don't seem to be turning them on for ubuntu-push notifications, but we should, right? Following the pattern above, we'd have ubuntu-push itself turn the screen on, for a third location.

We don't turn the screen on at all for notifications that don't come via those sources. For example, the following command line doesn't turn the screen on, but I think it should:

gdbus call --session --dest org.freedesktop.Notifications --object-path /org/freedesktop/Notifications --method org.freedesktop.Notifications.Notify '' 0 '' 'Hello' 'World' '[]' '{}' 0

It feels weird to have telephony-service turning the screen on. Logically, it is just emitting a notification. The presentation of that notification is up to a higher layer (maybe we're on a raspberry pi2 and we present notifications as LED morse code or whatever). It just makes sense that unity8, which is drawing the notification, is the one that knows that the screen needs to be on. It also knows what form factor we are in (I assume we only want to turn screen on for phones/tablets, not desktops).

So I'm proposing that we unify all those places into one code path in unity8 that can turn the screen on when a notification is received.

(This is a breakout bug from bug 1426115.)

Related branches

Michael Terry (mterry)
description: updated
Revision history for this message
Michael Terry (mterry) wrote :

Humph... Unity8 is not running when the device is suspended, is it? That might put a damper on this plan.

Revision history for this message
Michael Terry (mterry) wrote :

Nevermind, I was confused by ubuntu-push not actually emitting a displayable notification (one with popup=true on its card) when the greeter is up. Which obscured my testing. It's an odd decision (to me), but is a separate issue.

An MR is coming for this.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Michael Terry (mterry)
Changed in unity8 (Ubuntu):
status: Confirmed → Fix Released
Changed in telephony-service (Ubuntu):
assignee: nobody → Michael Terry (mterry)
status: New → In Progress
Changed in powerd (Ubuntu):
assignee: nobody → Michael Terry (mterry)
status: New → In Progress
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

See also bug #1562923

Michael Terry (mterry)
Changed in telephony-service (Ubuntu):
assignee: Michael Terry (mterry) → nobody
Changed in powerd (Ubuntu):
assignee: Michael Terry (mterry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers