Screenshots do not properly use the current date

Bug #1436006 reported by Pat McGowan on 2015-03-24
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
unity8 (Ubuntu)
Medium
Unassigned

Bug Description

It seems we try to name the screenshots using a suffix similar to the camera like yyyymmdd-secsorsomething but the month portion is incorrect. For example on 3/24 I got
screenshot20150124_120119280.png
screenshot20153124_123111200.png
screenshot20153124_123154122.png

so the year and day are correct but not the month which seems random.

Related branches

description: updated
Daniel van Vugt (vanvugt) wrote :

Looks like the offending code is in Unity8: plugins/ScreenGrabber/screengrabber.cpp

affects: unity-system-compositor → unity8
Michał Sawicz (saviq) on 2015-03-25
no longer affects: unity8
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) on 2015-03-30
Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.02+15.04.20150409.1-0ubuntu1

---------------
unity8 (8.02+15.04.20150409.1-0ubuntu1) vivid; urgency=medium

  [ Albert Astals Cid ]
  * Focus the shutdown dialog (LP: #1417991)
  * Make url-dispatching scope activation when the dash is not on the
    main scopes (LP: #1364306)
  * We use autopilot3 now

  [ CI Train Bot ]
  * New rebuild forced.
  * Resync trunk. added: po/or.po

  [ Daniel d'Andrada ]
  * Make tst_PreviewListView and tst_GenericScopeView work in out-of-
    source builds
  * MouseArea that shows the indicators panel should cover the
    indicators bar only (LP: #1439318)
  * Surface gets active focus also with mouse clicks

  [ Josh Arenson ]
  * Add a mode option to unity8 for selecting greeter mode in the future
  * Remove PkgConfig include from Launcher plugin to fix cross-compile
    (LP: #1437702)

  [ Leo Arias ]
  * Fixed the check for string in the lock screen test. (LP: #1434518)

  [ Michael Terry ]
  * Make sure the edge tutorial is destroyed when we receive a call
    during the wizard. (LP: #1436349)
  * Skip parts of the edge tutorial that require a touch device (like
    spread and bottom edge). (LP: #1434712)

  [ Michael Zanetti ]
  * Don't hide stages just because they're empty (LP: #1439615)
  * [Launcher] fix bug where an item would disappear even though the app
    is running (LP: #1438172)

  [ Nick Dedekind ]
  * Fixed autopilot test failures related to udev input failure for
    power button.
  * Made improvements for laggy indicator backends (lp#1390136). (LP:
    #1390136)

  [ Pete Woods ]
  * GPS only goes active when the Dash is in the foreground (LP:
    #1434379)

  [ handsome_feng<email address hidden> ]
  * Modified the wrong time format in ScreenGrabber (LP: #1436006)
 -- CI Train Bot <email address hidden> Thu, 09 Apr 2015 14:01:11 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers