Can't swipe from the right in the setup at first launch

Bug #1434712 reported by Linus on 2015-03-20
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
unity8 (Ubuntu)
High
Michael Terry

Bug Description

Ubuntu 15.04 on a desktop pc with a mouse. Version 8.02+15.04.20150318-0ubuntu1 of the unity8 package.

The initial setup when first launching is stuck. Swiping the app launcher from the left works fine, but swiping the app switcher from the right won't work. It's stuck at the screen that says "To view open apps Long swipe from the right edge." with an unresponsive wobbly switcher to the right.

Related branches

I have exactly the same issue. I don't have a touch screen on my PC and clicking and dragging the mouse only works from the left but not the right. I am now stuck with the training page and no way to cancel and test the OS. Please and a "skip intro" button for those of us who can't swipe with our mice.
Thanks

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) on 2015-03-22
Changed in unity8 (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Michael Terry (mterry)
GizmoChicken (gizmochicken) wrote :

I encountered the exact same bug (can't swipe from the right in the setup at first launch) after installing Ubuntu Next to my non-touchscreen laptop (CPU: Intel Core i3-2310M) using the 24-Mar-2015 daily build from http://cdimage.ubuntu.com/ubuntu-desktop-next/daily-live/current/

I second the suggestion made by Edward Oakeley (comment #1) to add "a 'skip intro' button for those of us who can't swipe with our mice."

aggelalex (aggelalex-ppa) wrote :

I have the same bug too, it's a very important bug because this way wou won't be able to get in your desktop. I found it after installing Ubuntu NEXT 24-Mar-2015, as @gizmochicken, My pc is a little 10' netbook with 2core Intel atom cpu, Intel graffics card with 3d acceleration and 1GB ram memory. It's necessary I thing to make a 'skip intro' button .

I have noticed the same bug indeed :-(
I've tried to modify .cfg files from /cdrom/syslinux with no success at all :-(

themusicgod1 (themusicgod1) wrote :

My hardware:
intel i5 3230M
GPU: NVIDIA GeForce 710M
Xorg module: nouveau

Christopher Townsend (townsend) wrote :

Hey All,

As a way around this for now, use this command from a VT to get rid of the tutorial:

dbus-send --system --print-reply --dest=org.freedesktop.Accounts /org/freedesktop/Accounts/User$UID org.freedesktop.DBus.Properties.Set string:com.canonical.unity.AccountsService string:demo-edges variant:boolean:false

If you are running this command from a different user than the one used to log into Unity8, then replace $UID with the UID of the user you care about.

Christopher Townsend (townsend) wrote :

Oh, you will need to run the above dbus-send command with sudo, so it's most likely you will need to replace $UID with the UID of the user you want.

kulibin (maximka) wrote :

I have the same problem. Please make the "skip training"

Michał Sawicz (saviq) on 2015-04-03
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
Masoud Abkenar (mabkenar) wrote :

@townsend
After typing the entire dbus-send command in the terminal of the live session, it says: invalid value (org.freedesktop.Acco...) of "--dest"
I know nothing about DBus. I am just curious to test the latest Unity8 desktop. But I can't, because I can't go past the demo-edge thing.

Oh, that's very tedious indeed, typiing the entire dbus send command :-(.
The earliest version used to work quite well.
With the latest one psmouse drive doesn't work, the usb drive either.
The skip intro right edge swipe doesn't work :-(

handsome_feng (feng-kylin) wrote :

I created an empty file named wizard-has-run in .config/ubuntu-system-settings/ to get rid of the tutorial.

GizmoChicken (gizmochicken) wrote :

At least for me, under the circumstances described below, the presence of an empty file named "wizard-has-run" in .config/ubuntu-system-settings/ does NOT prevent the tutorial from starting.

I installed Ubuntu Next fresh from the 08-Apr-2015 daily build from http://cdimage.ubuntu.com/ubuntu-desktop-next/daily-live/current/ Upon first boot into the freshly installed system, I got the tutorial. Upon rebooting using the installation disk, and selecting the "try ubuntu" option, I can find that that an empty file named "wizard-has-run" is already present in .config/ubuntu-system-settings/ on the system disk. But even though the empty file named "wizard-has-run" is already present on the system disk, upon booting again into the freshly installed system, I still get the tutorial.

Perhaps the situation would be different if I had added the empty file named "wizard-has-run" immediately after installation of, but before first boot into, the system. I don't know. I haven't tried that. But again, I can confirm that, at least for me, under the circumstances described above, the presence of an empty file named "wizard-has-run" in .config/ubuntu-system-settings/ does NOT prevent the tutorial from starting.

Michał Sawicz (saviq) wrote :

The wizard-has-run file only impacts the first-setup wizard, not the edge tutorial.

Michael Terry (mterry) wrote :

Indeed, wizard-has-run will not stop the tutorial. That's only for the welcome wizard on first boot.

The correct workaround for the tutorial is the dbus-send line above.

But we have a real fix waiting to land in vivid that will skip the troublesome pages of the tutorial in desktop mode.

handsome_feng (feng-kylin) wrote :

sorry, i confused wizard with turorial. :-P

Mateo Salta (mateo-salta) wrote :

just tried, this is a show stopper on testing.

What if there were just keyboard equivalents like meta and alt+tab assigned to these actions so we can perform the actions, or at least esc to exit the tutorial.

GizmoChicken (gizmochicken) wrote :

I agree with Mateo Salta: This is a show stopper for testing.

@Michael Terry: Can you please provide an estimate regarding when your fix will get merged into Vivid?

Michael Terry (mterry) wrote :

I agree that this blocks using the desktop and is a very bad bug. As for an estimate, I don't have one. I'm not the one that usually bundles up new releases of unity8. But this fix will be in the next release.

GizmoChicken (gizmochicken) wrote :

@Michael Terry: Thanks so much for the clarification. I would guess that whoever usually bundles up new releases of unity8 is waiting until many other fixes are ready before releasing the next version. Sorry if I'm being a pest, but given the severity of this bug (which effectively prevents testing the desktop on many devices), I hope that you might consider proposing to whomever bundles up new releases the possibility of issuing, as soon as possible, a release that only adds those fixes that are currently ready for merger, including, of course, your fix for this bug.

> @Michael Terry: Thanks so much for the clarification. I would guess
> that whoever usually bundles up new releases of unity8 is waiting until
> many other fixes are ready before releasing the next version.

So this is not exactly true, the release is already in progress, we're
just waiting for QA to verify it.

In the mean time, you can use packages from the PPA below (which, when
QA passes, will be the ones uploaded to vivid).

https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/landing-025

GizmoChicken (gizmochicken) wrote :

Great! Thanks so much!!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.02+15.04.20150409.1-0ubuntu1

---------------
unity8 (8.02+15.04.20150409.1-0ubuntu1) vivid; urgency=medium

  [ Albert Astals Cid ]
  * Focus the shutdown dialog (LP: #1417991)
  * Make url-dispatching scope activation when the dash is not on the
    main scopes (LP: #1364306)
  * We use autopilot3 now

  [ CI Train Bot ]
  * New rebuild forced.
  * Resync trunk. added: po/or.po

  [ Daniel d'Andrada ]
  * Make tst_PreviewListView and tst_GenericScopeView work in out-of-
    source builds
  * MouseArea that shows the indicators panel should cover the
    indicators bar only (LP: #1439318)
  * Surface gets active focus also with mouse clicks

  [ Josh Arenson ]
  * Add a mode option to unity8 for selecting greeter mode in the future
  * Remove PkgConfig include from Launcher plugin to fix cross-compile
    (LP: #1437702)

  [ Leo Arias ]
  * Fixed the check for string in the lock screen test. (LP: #1434518)

  [ Michael Terry ]
  * Make sure the edge tutorial is destroyed when we receive a call
    during the wizard. (LP: #1436349)
  * Skip parts of the edge tutorial that require a touch device (like
    spread and bottom edge). (LP: #1434712)

  [ Michael Zanetti ]
  * Don't hide stages just because they're empty (LP: #1439615)
  * [Launcher] fix bug where an item would disappear even though the app
    is running (LP: #1438172)

  [ Nick Dedekind ]
  * Fixed autopilot test failures related to udev input failure for
    power button.
  * Made improvements for laggy indicator backends (lp#1390136). (LP:
    #1390136)

  [ Pete Woods ]
  * GPS only goes active when the Dash is in the foreground (LP:
    #1434379)

  [ handsome_feng<email address hidden> ]
  * Modified the wrong time format in ScreenGrabber (LP: #1436006)
 -- CI Train Bot <email address hidden> Thu, 09 Apr 2015 14:01:11 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released

the latest try/install version one is working pretty well indeed.
many thanks.
my students and i developping some engineering apps on desktop next in order to pkcon on n4 phablet one.
i'll see you on next bug.

Jan (ya-me) wrote :

Is this patch already available in the vivid next daily build? If not, how could one apply it for the 'Try it' mode?

Michael Terry (mterry) wrote :

Yes, it should be available in the daily build by now.

themusicgod1 (themusicgod1) wrote :

This seems to still be broken? Did this fix actually get included in that list of changes?

Albert Astals Cid (aacid) wrote :

As said, this is included in unity8 >= 8.02+15.04.20150409.1-0ubuntu1 which version are you running?

themusicgod1 (themusicgod1) wrote :

unity8:
  Installed: 8.02+15.04.20150409.1-0ubuntu1
  Candidate: 8.02+15.04.20150409.1-0ubuntu1
  Version table:
 *** 8.02+15.04.20150409.1-0ubuntu1 0
        500 http://ca.archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
        100 /var/lib/dpkg/status

Albert Astals Cid (aacid) wrote :

Then it should be working for you, is it not? Can you attach a recording of what you get?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers