unity8-dash crashed with signal 7 in QMutex::lock() when switching scopes

Bug #1431798 reported by Michał Sawicz
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Pat McGowan
qtdeclarative-opensource-src (Ubuntu)
Medium
Albert Astals Cid
qtdeclarative-opensource-src (Ubuntu RTM)
Medium
Timo Jyrinki
unity8 (Ubuntu)
Medium
Unassigned

Bug Description

Original is bug #1431440:

I was simply paging through the scopes ad got this crash.
I swiped in in the open dialer app and then I see the scopes restarting
Reproduced three times in a row,and after a reboot.

mako running 213 rtm

ProblemType: Crash
DistroRelease: Ubuntu RTM 14.09
Package: unity8 8.02+15.04.20150226~rtm-0ubuntu1
Uname: Linux 3.4.0-5-mako armv7l
ApportVersion: 2.14.7-0ubuntu8
Architecture: armhf
CurrentDesktop: Unity
Date: Thu Mar 12 12:05:54 2015
ExecutablePath: /usr/bin/unity8-dash
ExecutableTimestamp: 1424989859
InstallationDate: Installed on 2015-03-12 (1 days ago)
InstallationMedia: Ubuntu Utopic Unicorn (development branch) - armhf (20150312-002053)
LocalLibraries: /android/system/lib/libadreno_utils.so /android/system/lib/egl/eglsubAndroid.so /android/system/lib/libcorkscrew.so /android/system/lib/libGLESv1_CM.so /android/system/lib/libGLES_trace.so /android/system/lib/hw/gralloc.msm8960.so /android/system/lib/libmemalloc.so /android/system/lib/libui.so /android/system/lib/libGLESv2.so /android/system/lib/libhardware.so /android/system/lib/libc.so /android/system/lib/libstdc++.so /android/system/lib/libstlport.so /android/system/lib/libdsyscalls.so /android/system/lib/libm.so /android/system/lib/libsync.so /android/system/lib/libsc-a3xx.so /android/system/lib/libz.so /android/system/lib/libcutils.so /android/system/lib/egl/libGLESv1_CM_adreno.so /android/system/lib/libqdutils.so /android/system/lib/libgccdemangle.so /android/system/lib/libgsl.so /android/system/lib/libutils.so /android/system/lib/egl/libEGL_adreno.so /android/system/lib/egl/libGLESv2_adreno.so /android/system/lib/liblog.so /android/system/lib/libEGL.so
ProcCmdline: unity8-dash --desktop_file_hint=/usr/share/applications/unity8-dash.desktop
ProcCwd: /home/phablet
Signal: 7
SourcePackage: unity8
StacktraceTop:
 QMutex::lock() () from /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5
 QCoreApplication::postEvent(QObject*, QEvent*, int) () from /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5
 ?? () from /usr/lib/arm-linux-gnueabihf/libQt5Quick.so.5
Title: unity8-dash crashed with signal 7 in QMutex::lock()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dialout dip plugdev sudo tty video

Revision history for this message
Michał Sawicz (saviq) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 testAndSetRelaxed<QMutexData*> (currentValue=<synthetic pointer>, newValue=0x1, expectedValue=0x0, _q_value=@0x2ba8b45: 0x5002b30e) at ../../include/QtCore/../../src/corelib/arch/qatomic_armv6.h:189
 testAndSetAcquire<QMutexData*, QMutexData*> (currentValue=<synthetic pointer>, newValue=0x1, expectedValue=0x0, _q_value=@0x2ba8b45: 0x5002b30e) at ../../include/QtCore/../../src/corelib/thread/qgenericatomic.h:174
 testAndSetAcquire (currentValue=<synthetic pointer>, newValue=0x1, expectedValue=0x0, this=0x2ba8b45, this@entry=0x1) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:284
 fastTryLock (current=<synthetic pointer>, this=0x2ba8b45, this@entry=0x1) at thread/qmutex.h:90
 QMutex::lock (this=this@entry=0x2ba8b45) at thread/qmutex.cpp:220

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in unity8 (Ubuntu):
importance: Undecided → Medium
tags: removed: need-armhf-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq)
information type: Private → Public
description: updated
Revision history for this message
Michał Sawicz (saviq) wrote :

Unfortunately there's nothing suggesting what's gone wrong (or even why it crashed) in the traces. The trace does look corrupted, as thread order is impossible - the main thread is reported to be that of the pixmap reader...

Pat, if you can reproduce, can you please clear your /var/crash and trigger the crash again and upload it here.

Changed in unity8 (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :
Michał Sawicz (saviq)
Changed in unity8 (Ubuntu):
status: Incomplete → Triaged
status: Triaged → In Progress
assignee: nobody → Albert Astals Cid (aacid)
Revision history for this message
Albert Astals Cid (aacid) wrote :

I can't prove it since i can not reproduce it but after staring at the backtrace a lot and reading the code even more lots i came up with
https://codereview.qt-project.org/#/c/108700/

That seems like it should be a proper patch for fixing this crash.

Let's see what upstream thinks

Revision history for this message
Albert Astals Cid (aacid) wrote :

 https://codereview.qt-project.org/#/c/108700/ has been accepted upstream and is now in the process of merging.

Changed in unity8 (Ubuntu):
status: In Progress → Invalid
Changed in qtdeclarative-opensource-src (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Albert Astals Cid (aacid)
Changed in unity8 (Ubuntu):
assignee: Albert Astals Cid (aacid) → nobody
Changed in qtdeclarative-opensource-src (Ubuntu):
status: New → In Progress
Revision history for this message
Albert Astals Cid (aacid) wrote :

Pat, should we land this bugfix in qtdeclarative for the ww13-ota milestone or just for vivid?

Changed in qtdeclarative-opensource-src (Ubuntu RTM):
importance: Undecided → Medium
assignee: nobody → Timo Jyrinki (timo-jyrinki)
status: New → In Progress
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

(the answer was yes)

The rtm fix is testable at rtm-003 https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu-rtm/landing-003

Vivid fix in vivid-021 although together with bug #1421009 (possible) fix.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtdeclarative-opensource-src - 5.3.0-3ubuntu15~rtm1

---------------
qtdeclarative-opensource-src (5.3.0-3ubuntu15~rtm1) 14.09; urgency=medium

  * debian/patches/Always-remove-reply-from-replies-when-processing-can.patch:
    - Fix crasher (LP: #1431798)
 -- Timo Jyrinki <email address hidden> Thu, 19 Mar 2015 10:46:58 +0000

Changed in qtdeclarative-opensource-src (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: New → Fix Released
importance: Undecided → High
milestone: none → ww13-ota
assignee: nobody → Pat McGowan (pat-mcgowan)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtdeclarative-opensource-src - 5.4.1-1ubuntu4

---------------
qtdeclarative-opensource-src (5.4.1-1ubuntu4) vivid; urgency=medium

  * debian/patches/Always-remove-reply-from-replies-when-processing-can.patch:
    - Fix a crash when switching scopes (LP: #1431798)
 -- Timo Jyrinki <email address hidden> Fri, 20 Mar 2015 13:26:18 +0000

Changed in qtdeclarative-opensource-src (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers