Shutdown dialog appears on resume, after a long delay in screen turning on

Bug #1410830 reported by Michael Terry on 2015-01-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Unassigned
unity8 (Ubuntu)
Undecided
Michael Terry
unity8 (Ubuntu RTM)
Undecided
Michael Zanetti

Bug Description

Sometimes, if you press the power button to resume your device, the screen will stay black for a long time. When it does come on again, the shutdown dialog is likely showing instead of the greeter.

You might press the power button again while the screen is black, thinking you didn't actually press it the first time. This will immediately turn the screen on and then off again. At which point a third power button press will turn the screen on for good.

This bug is very similar to bug 1383277 (fixed), which involves a shutdown dialog appearing on resume, but for a different reason. This is also very similar to (and may be a dup of) bug 1409003. But since bug 1409003 currently involves an incoming text and this bug does not, I'm treating them as separate for now.

This bug is hard to reproduce. It seems to involve leaving and entering wifi/3G zones (or maybe simply toggling the wifi indicator button). But no reliable steps have been recorded yet.

I'm guessing that like bug 1383277, it involves some resume-event handler blocking the input stack so that Qt doesn't notice the power-button-release event. And since it takes so long to resume, Qt thinks the user held down the power button long enough to trigger the shutdown dialog.

A trivial band-aid for this is to not start the shutdown-dialog timer if the screen is off. But that wouldn't address the source cause of a blocking event handler. So I think this still merits investigation. But if this is a critical/time-sensitive bug, we could slap a band-aid on it.

Related branches

Michael Terry (mterry) on 2015-01-14
Changed in unity8 (Ubuntu):
assignee: nobody → Michael Terry (mterry)
status: New → In Progress
kevin gunn (kgunn72) wrote :

jibel's method for repro'ing
 1) connect to wifi
 2) toggle wifi from network indicator
 3) suspend
 4) wait until the phone really suspends
 5) resume

Michael Terry (mterry) wrote :

Well, that's jibel's repro steps for bug 1383277, right?

I was testing image 20150114.1 (the one with the fix for bug 1383277, and *without* the attached "band-aid" MP) and got the long delay described by this bug. And the shutdown dialog did not appear. Which makes me think that this is a straight dup of bug 1383277 after all.

I had originally assumed that the delay and the shutdown dialog were both symptoms of the same cause. But maybe not.

Changed in canonical-devices-system-image:
importance: Undecided → Critical
milestone: none → ww05-2015
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.02+15.04.20150121.2-0ubuntu1

---------------
unity8 (8.02+15.04.20150121.2-0ubuntu1) vivid; urgency=low

  [ Michael Terry ]
  * Don't show any power dialogs while the screen is off. This is a
    band-aid to avoid the symptom, while we still investigate the source
    of why the screen doesn't turn on (and why we seem to not handle the
    power-button-release event). (LP: #1409003, #1410830)
  * Don't refocus the dialer-app when a call is started by the user.
    Because of how qtmir works, this would cause the dialer-app to
    unfocus momentarily, causing interface oddities for the user. (LP:
    #1413065)

  [ CI Train Bot ]
  * Resync trunk

  [ Albert Astals Cid ]
  * Build with ninja
  * Fixes for Table Preview Widget (LP: #1410420)

  [ Michael Zanetti ]
  * Add support for earpiece media buttons (LP: #1398427)
  * Add a WindowMoveResizeArea and tests for it
 -- Ubuntu daily release <email address hidden> Wed, 21 Jan 2015 18:33:18 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Changed in unity8 (Ubuntu RTM):
status: New → In Progress
assignee: nobody → Michael Zanetti (mzanetti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.02+15.04.20150122.2~rtm-0ubuntu1

---------------
unity8 (8.02+15.04.20150122.2~rtm-0ubuntu1) 14.09; urgency=medium

  [ Michael Terry ]
  * Don't show any power dialogs while the screen is off. (LP: #1409003,
    #1410830)
  * Don't refocus the dialer-app when a call is started by the user. (LP:
    #1413065)

  [ Michael Zanetti ]
  * Add support for earpiece media buttons (LP: #1398427)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Thu, 22 Jan 2015 20:47:05 +0000

Changed in unity8 (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers