Left-edge / home does not close Manage Dash

Bug #1403464 reported by Albert Astals Cid on 2014-12-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
unity8 (Ubuntu)
High
Albert Astals Cid
unity8 (Ubuntu RTM)
Undecided
Michał Sawicz

Bug Description

The Manage Dash should be closed on Left-edge / home press

Related branches

Changed in unity8 (Ubuntu):
assignee: nobody → Albert Astals Cid (aacid)
status: New → In Progress
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.02+15.04.20150109.2-0ubuntu1

---------------
unity8 (8.02+15.04.20150109.2-0ubuntu1) vivid; urgency=low

  [ Michał Sawicz ]
  * We don't need the SIGSTOP in main() any more.
  * Add a test to make sure the shell always starts disabled until it is
    enabled by a complete PAM interaction.

  [ Leo Arias ]
  * Added an autopilot test for the edges demo.

  [ Nick Dedekind ]
  * Unhook Lights interface from indicator widgets (LP: #1385331)

  [ Albert Astals ]
  * Fix going to scopes when the Manage Dash is open (LP: #1403464)
  * QSortFilterProxyModelQML -> UnitySortFilterProxyModelQML
  * Clip the Scopes List header
  * Fix ScopesList not being under finger
  * Make waitForRendering with no item fail instead of crash
  * Disable Dash horizontal scroll while Navigation InverseMouseArea is
    pressed (LP: #1403048)
  * Test: Make sure the mouse area is enabled before clicking into it
  * Test: We actually need to click on the customBackButton and not on
    backButton
  * Test: By default mouseX act on the middle

  [ Michael Terry ]
  * Don't block handling power events on loading the greeter's qml and
    the background image.
  * Show OSK above the wizard. (LP: #1401213)
  * Unify the name of the Greeter DBus test, make it use our standard
    binary test macro (which also nicely exports xml results), and make
    the test a little more robust against timing issues.
  * Add a test to make sure the shell always starts disabled until it is
    enabled by a complete PAM interaction.

  [ Martin Pitt ]
  * tests: Fix Notify.Notification.add_action invocation to work also
    with unpatched libnotify API. (LP: #1223401)

  [ Rodney Dawes ]
  * Depend on :native version of g++ to allow cross-compiling to work.
    (LP: #1353855)
 -- Ubuntu daily release <email address hidden> Fri, 09 Jan 2015 10:43:06 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww03-2015
status: New → Confirmed
Michał Sawicz (saviq) on 2015-01-13
Changed in unity8 (Ubuntu RTM):
status: New → In Progress
assignee: nobody → Michał Sawicz (saviq)
milestone: none → 14.09-ota-2
Changed in canonical-devices-system-image:
milestone: ww03-2015 → ww05-2015
Selene ToyKeeper (toykeeper) wrote :

This fix does what it says, but it isn't reversible. As soon as the first commit point is reached, the scope management screen goes away and cannot be retrieved by sliding back the other direction.

Selene ToyKeeper (toykeeper) wrote :

The left-edge behavior has another issue, but it turns out not to be related to this fix.

Swiping from the left edge will cause the current scope to be switched to "Today" as soon as the first commit point is reached, even if the user only swiped far enough to bring up the quick launcher. This action isn't reversible; swiping back the other way does not return it to the scope they were using. It makes much more sense to me to only switch back to the default scope if the user explicitly presses the Ubuntu icon in the launcher.

Albert Astals Cid (aacid) wrote :

Selene, i agree that what you suggest may be a better behaviour but please report that as a new bug and not as part as this one since the left-edge has never behaved like that and thus is not a consequence of this bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.02+15.04.20150120~rtm-0ubuntu1

---------------
unity8 (8.02+15.04.20150120~rtm-0ubuntu1) 14.09; urgency=medium

  [ Albert Astals ]
  * Fix going to scopes when the Manage Dash is open (LP: #1403464)

  [ Josh Arenson ]
  * Create a PhysicalKeyMapper to handle all physical/hardware keys (LP:
    #1390393)

  [ Michael Zanetti ]
  * make spread reversible (LP: #1368668, #1355284, #1368677)

  [ Nick Dedekind ]
  * Unhook Lights interface from indicator widgets
 -- Ubuntu daily release <email address hidden> Tue, 20 Jan 2015 11:18:21 +0000

Changed in unity8 (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers