Notification LED stays on when no messages in notification center

Bug #1385331 reported by John Lenton on 2014-10-24
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Thomas Strehl
indicator-messages (Ubuntu)
High
Ted Gould
qmenumodel (Ubuntu)
High
Nick Dedekind
qmenumodel (Ubuntu RTM)
Undecided
Michał Sawicz
unity8 (Ubuntu)
High
Nick Dedekind
unity8 (Ubuntu RTM)
High
Nick Dedekind

Bug Description

Observed the notification LED staying on even though there were no notifications in the indicators and the notification icon was greyed out.

Related branches

summary: - if u8 crashes while you had a notification and the screen was off, then
- the led can stay on.
+ Notification LED stays on when no messages in notification center
description: updated
Nick Dedekind (nick-dedekind) wrote :

There is a possibility that if unity8 crashes while the light state is set, then it can keep that state if u8 comes back up with no notifications.

We need to decouple the usage from the lights plugin from the messaging indicator widget so that it will keep the lights state up to date.

Changed in unity8 (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
Michał Sawicz (saviq) on 2015-01-08
Changed in unity8 (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.02+15.04.20150109.2-0ubuntu1

---------------
unity8 (8.02+15.04.20150109.2-0ubuntu1) vivid; urgency=low

  [ Michał Sawicz ]
  * We don't need the SIGSTOP in main() any more.
  * Add a test to make sure the shell always starts disabled until it is
    enabled by a complete PAM interaction.

  [ Leo Arias ]
  * Added an autopilot test for the edges demo.

  [ Nick Dedekind ]
  * Unhook Lights interface from indicator widgets (LP: #1385331)

  [ Albert Astals ]
  * Fix going to scopes when the Manage Dash is open (LP: #1403464)
  * QSortFilterProxyModelQML -> UnitySortFilterProxyModelQML
  * Clip the Scopes List header
  * Fix ScopesList not being under finger
  * Make waitForRendering with no item fail instead of crash
  * Disable Dash horizontal scroll while Navigation InverseMouseArea is
    pressed (LP: #1403048)
  * Test: Make sure the mouse area is enabled before clicking into it
  * Test: We actually need to click on the customBackButton and not on
    backButton
  * Test: By default mouseX act on the middle

  [ Michael Terry ]
  * Don't block handling power events on loading the greeter's qml and
    the background image.
  * Show OSK above the wizard. (LP: #1401213)
  * Unify the name of the Greeter DBus test, make it use our standard
    binary test macro (which also nicely exports xml results), and make
    the test a little more robust against timing issues.
  * Add a test to make sure the shell always starts disabled until it is
    enabled by a complete PAM interaction.

  [ Martin Pitt ]
  * tests: Fix Notify.Notification.add_action invocation to work also
    with unpatched libnotify API. (LP: #1223401)

  [ Rodney Dawes ]
  * Depend on :native version of g++ to allow cross-compiling to work.
    (LP: #1353855)
 -- Ubuntu daily release <email address hidden> Fri, 09 Jan 2015 10:43:06 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww03-2015
status: New → Confirmed
Michał Sawicz (saviq) on 2015-01-13
Changed in unity8 (Ubuntu RTM):
status: New → Triaged
importance: Undecided → Critical
milestone: none → 14.09-ota-2
importance: Critical → High
Changed in unity8 (Ubuntu):
importance: Undecided → High
Michał Sawicz (saviq) on 2015-01-13
Changed in unity8 (Ubuntu RTM):
status: Triaged → In Progress
assignee: nobody → Michał Sawicz (saviq)
Changed in qmenumodel (Ubuntu):
status: New → Fix Released
importance: Undecided → High
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in qmenumodel (Ubuntu RTM):
status: New → In Progress
assignee: nobody → Michał Sawicz (saviq)
milestone: none → 14.09-ota-2
Changed in unity8 (Ubuntu RTM):
status: In Progress → Triaged
Changed in qmenumodel (Ubuntu RTM):
status: In Progress → Triaged
assignee: Michał Sawicz (saviq) → Nick Dedekind (nick-dedekind)
Changed in unity8 (Ubuntu RTM):
assignee: Michał Sawicz (saviq) → Nick Dedekind (nick-dedekind)
Michał Sawicz (saviq) on 2015-01-14
Changed in qmenumodel (Ubuntu RTM):
assignee: Nick Dedekind (nick-dedekind) → Michał Sawicz (saviq)
status: Triaged → In Progress
Changed in unity8 (Ubuntu RTM):
status: Triaged → In Progress
Changed in canonical-devices-system-image:
milestone: ww03-2015 → ww05-2015
Changed in unity8 (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Released → Confirmed
status: Confirmed → In Progress
Ken VanDine (ken-vandine) wrote :

This is marked as fixed for vivid, but I'm still seeing this on vivid-proposed image 77 mako.

Michał Sawicz (saviq) wrote :

Ken, can you post steps to reproduce if you find them? Potentially as a different bug?

Ken VanDine (ken-vandine) wrote :

Not sure really, with the screen off and no notifications in the indicator the light blinks.

Ken VanDine (ken-vandine) wrote :

An observation, what I'm seeing on vivid isn't just the LED, the messaging indicator icon actually isn't being changed after clearing the notifications. This is what's keeping the LED lit, it just follows the status of the icon. So the bug I'm seeing is actually the notification icon not changing when the indicator is cleared.

Changed in canonical-devices-system-image:
milestone: ww05-2015 → ww07-2015
Michał Sawicz (saviq) wrote :

That would be the messaging indicator then. Or! If you wait for a second or two, I've seen the items coming back into view after all, maybe you're seeing the same?

Niklas Wenzel (nikwen) wrote :

Ken, I guess you're talking about the following bug: https://bugs.launchpad.net/ubuntu/+source/indicator-messages/+bug/1412779
Would be nice if you confirm it. :)

Michał Sawicz (saviq) wrote :

This is now on the indicator-messages side, IIUC it should hide from the panel if there are no unread messages? Whether it should change the icon (grey vs. white-ish, on which the LED state is based on) I'm not sure?

Changed in qmenumodel (Ubuntu RTM):
status: In Progress → Fix Released
Niklas Wenzel (nikwen) wrote :

@saviq: It currently doesn't seem to recognize when messages are cleared. Therefore, the icon stays white (=> unread messages) and the LED stays on.

That's what https://bugs.launchpad.net/ubuntu/+source/indicator-messages/+bug/1412779 is about.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-messages (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
assignee: nobody → Thomas Strehl (strehl-t)
milestone: ww07-2015 → ww09-2015
Ted Gould (ted) wrote :
Download full text (3.9 KiB)

Seems to be related to the push-client, were I think this might be an i-messages bug is that we're not showing the offending tweet (in this case). The push-client doesn't seem to be responding to the clearing if items.

== Two messages show, blue icon ==

$ gdbus call --session --dest com.canonical.indicator.messages --object-path /com/canonical/indicator/messages --method org.gtk.Actions.DescribeAll
({'remove-all': (true, signature '', @av []), 'status': (true, 's', [<'offline'>]), 'messages': (true, '', [<{'icon': <('themed', <['indicator-messages-new-offline', 'indicator-messages-new', 'indicator-messages', 'indicator']>)>, 'title': <'Notifications'>, 'accessible-desc': <'New Messages'>, 'visible': <true>}>]), 'ubuntu-system-settings.launch': (true, '', [<false>]), 'com_ubuntu_developer_webapps_webapp-twitter_webapp-twitter_1_0_21.launch': (true, '', [<true>]), 'com_ubuntu_developer_webapps_webapp-twitter_webapp-twitter_1_0_21.msg.3f372b89-2d643a-2d41e8-2d9297-2d497a646a35be': (true, 'b', []), 'telephony-service-sms.launch': (true, '', [<true>]), 'telephony-service-sms.msg.323031352d30322d31365432303a31363a33342d303630302d31': (true, 'b', []), 'telephony-service-sms.msg.323031352d30322d31365432303a31373a34392d303630302d31': (true, 'b', []), 'telephony-service-sms.src.telephony-2dservice-2dindicator': (true, 'b', [<(uint32 7, int64 1424028294206396, '', false)>]), 'telephony-service-sms.msg-actions.323031352d30322d31365432303a31363a33342d303630302d31.quickReply': (true, 's', []), 'telephony-service-sms.msg-actions.323031352d30322d31365432303a31373a34392d303630302d31.quickReply': (true, 's', []), 'telephony-service-call.launch': (true, '', [<true>]), 'telephony-service-call.src.telephony-2dservice-2dindicator': (true, 'b', [<(uint32 0, int64 1424028294207800, '', false)>])},)

== Clear All, blue icon ==

$ gdbus call --session --dest com.canonical.indicator.messages --object-path /com/canonical/indicator/messages --method org.gtk.Actions.DescribeAll
({'remove-all': (true, signature '', @av []), 'status': (true, 's', [<'offline'>]), 'messages': (true, '', [<{'icon': <('themed', <['indicator-messages-new-offline', 'indicator-messages-new', 'indicator-messages', 'indicator']>)>, 'title': <'Notifications'>, 'accessible-desc': <'New Messages'>, 'visible': <true>}>]), 'ubuntu-system-settings.launch': (true, '', [<false>]), 'com_ubuntu_developer_webapps_webapp-twitter_webapp-twitter_1_0_21.launch': (true, '', [<true>]), 'com_ubuntu_developer_webapps_webapp-twitter_webapp-twitter_1_0_21.msg.3f372b89-2d643a-2d41e8-2d9297-2d497a646a35be': (true, 'b', []), 'telephony-service-sms.launch': (true, '', [<true>]), 'telephony-service-sms.src.telephony-2dservice-2dindicator': (true, 'b', [<(uint32 7, int64 1424028294206396, '', false)>]), 'telephony-service-call.launch': (true, '', [<true>]), 'telephony-service-call.src.telephony-2dservice-2dindicator': (true, 'b', [<(uint32 0, int64 1424028294207800, '', false)>])},)

== Restart Push Client, icon is removed ==

$ restart ubuntu-push-client
ubuntu-push-client start/running, process 24811
$ gdbus call --session --dest com.canonical.indicator.messages --object-path /com/canonical/indicator/messages --method org...

Read more...

Niklas Wenzel (nikwen) wrote :

I also noticed SMS notifications are cleared fine, with the LED turning off.

Ted Gould (ted) wrote :

Okay, to recreate. Start up the device. Send this from ADB shell:

gdbus call --session --dest com.ubuntu.Postal --object-path /com/ubuntu/Postal/com_2eubuntu_2edeveloper_2ewebapps_2ewebapp_2dtwitter --method com.ubuntu.Postal.Post com.ubuntu.developer.webapps.webapp-twitter_webapp-twitter '"{\"message\": \"foobar\", \"notification\":{\"card\": {\"summary\": \"yes\", \"body\": \"hello\", \"popup\": true, \"persist\": true}}}"'

Then on the messaging menu select "Clear All". Notice the tweet is removed from the list but the envelope remains signaling new messages.

Ted Gould (ted) on 2015-02-19
Changed in indicator-messages (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Ted Gould (ted)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-messages - 13.10.1+15.04.20150219-0ubuntu1

---------------
indicator-messages (13.10.1+15.04.20150219-0ubuntu1) vivid; urgency=medium

  [ Ted Gould ]
  * Provide functions that allow for action names directly (LP:
    #1385331)
 -- CI Train Bot <email address hidden> Thu, 19 Feb 2015 15:55:54 +0000

Changed in indicator-messages (Ubuntu):
status: In Progress → Fix Released
Niklas Wenzel (nikwen) wrote :

Thank you for the fix. :)

Changed in canonical-devices-system-image:
milestone: ww09-2015 → ww11-2015
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers