Icon clipping in notification-renderer

Bug #1378417 reported by Charles Kerr on 2014-10-07
44
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Canonical Devices Products
unity8 (Ubuntu)
High
Mirco Müller
unity8 (Ubuntu RTM)
High
Michał Sawicz

Bug Description

Discussed with MacSlow in #unity-touch earlier today.

When indicator-power requests a "low battery" notification, the low battery icon gets clipped.

Here's what it looks like:

http://i.imgur.com/69hqWlL.jpg

Here's what is sent to unity-notifications:

method call sender=:1.104 -> dest=:1.55 serial=18 path=/org/freedesktop/Notifications; interface=org.freedesktop.Notifications; member=Notify
   string "indicator-power-service"
   uint32 0
   string "battery-020"
   string "Battery Low"
   string "10% charge remaining"
   array [
      string "dismiss"
      string "OK"
      string "settings"
      string "Battery settings"
   ]
   array [
      dict entry(
         string "x-canonical-non-shaped-icon"
         variant string "true"
      )
      dict entry(
         string "x-canonical-snap-decisions"
         variant string "true"
      )
      dict entry(
         string "x-canonical-snap-decisions-timeout"
         variant int32 2147483647
      )
   ]
   int32 0

Related branches

kevin gunn (kgunn72) on 2014-10-07
Changed in unity8 (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Charles Kerr (charlesk) wrote :

FWIW, now that the QA mock battery code's been merged, this bug's precondition (have a low battery) can be mocked from phablet-shell using the steps laid out in https://wiki.ubuntu.com/Process/Merges/TestPlan/indicator-power to (1) enable the mock battery and then (2) setting its charge level to 5%.

Matthieu James (tiheum) wrote :

The battery icon is clipped because it's not a square but a rectangle: the source file canvas is 105x90 px. The icon should be downsized while maintaining its aspect ratio.
I am not sure if at the moment, the SDK allows to display an image which is not squared but I know that Sebastien Bacher wrote a hack to display the same icon in the indicator bar (and the system settings menu).

W dniu 29.10.2014 o 14:37, Matthieu James pisze:
> The battery icon is clipped because it's not a square but a rectangle: the source file canvas is 105x90 px. The icon should be downsized while maintaining its aspect ratio.
> I am not sure if at the moment, the SDK allows to display an image which is not squared but I know that Sebastien Bacher wrote a hack to display the same icon in the indicator bar (and the system settings menu).

Non-square icons are indeed supported in the SDK now, but it is assumed
that the icon will be square, as per the notification spec. This should
be an easy fix in unity8 then (fillMode: Image.PreserveAspectFit).

Changed in unity8 (Ubuntu):
status: Confirmed → Triaged
Mirco Müller (macslow) on 2014-11-07
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
kevin gunn (kgunn72) on 2014-11-12
tags: added: ota-1 rtm14
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.01+15.04.20141117-0ubuntu1

---------------
unity8 (8.01+15.04.20141117-0ubuntu1) vivid; urgency=low

  [ josharenson ]
  * Return focus to the application after a tusted session overlay is
    closing. (LP: #1381292)

  [ Josh Arenson ]
  * Return focus to the application after a tusted session overlay is
    closing. (LP: #1381292)

  [ Albert Astals ]
  * Remove unused ResponsiveFlowView
  * Fix a few cmake warnings when running ./build.sh in a clean checkout

  [ Mirco Müller ]
  * Make sure non-square icons are not cropped. (LP: #1378417)

  [ Michael Terry ]
  * Drop the "EARLY ALPHA" scare label when running in testing mode.

  [ Michael Zanetti ]
  * unify Greeter and Lockscreen wallpaper again
  * hide quicklist when launcher hides (LP: #1387088)
  * Keep applications suspended while lockscreen is shown (LP: #1378126)
  * change spread background color to 111111

  [ Omer Akram ]
  * show password when tapped on the 'Show password' label, not just the
    checkbox. (LP: #1389832)
 -- Ubuntu daily release <email address hidden> Mon, 17 Nov 2014 13:48:33 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Olli Ries (ories) on 2014-11-26
Changed in canonical-devices-system-image:
assignee: nobody → Canonical Devices Products (canonical-devices-products-team)
importance: Undecided → High
milestone: none → r1
status: New → Confirmed
Michał Sawicz (saviq) on 2014-12-01
Changed in unity8 (Ubuntu RTM):
milestone: none → 14.09-ota-1
Michał Sawicz (saviq) on 2014-12-02
Changed in unity8 (Ubuntu RTM):
status: New → Triaged
importance: Undecided → High
Michał Sawicz (saviq) on 2014-12-05
Changed in unity8 (Ubuntu RTM):
status: Triaged → In Progress
assignee: nobody → Michał Sawicz (saviq)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.01.1+15.04.20141208~rtm-0ubuntu1

---------------
unity8 (8.01.1+15.04.20141208~rtm-0ubuntu1) 14.09; urgency=medium

  [ Michael Terry ]
  * Make sure that there is no window of opportunity for swiping away
    greeter before the lockscreen appears. (LP: #1395075)

  [ Michael Zanetti ]
  * Keep applications suspended while lockscreen is shown (LP: #1378126)

  [ Mirco Müller ]
  * Make sure non-square icons are not cropped. (LP: #1378417)
 -- Ubuntu daily release <email address hidden> Mon, 08 Dec 2014 09:31:49 +0000

Changed in unity8 (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers