Passcode screen misses keypresses

Bug #1378126 reported by Alan Pope 🍺🐧🐱 🦄 on 2014-10-06
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Canonical Devices Products
ubuntu-keyboard
Invalid
Undecided
Unassigned
unity8 (Ubuntu)
High
Michael Zanetti
unity8 (Ubuntu RTM)
High
Michał Sawicz

Bug Description

For some reason the passcode entry screen / lock screen feels very laggy when entering my passcode.

It frequently misses my keypresses, so i end up typing insufficient characters. I don't know if the hit area for the numbers is too small and I'm mis-hitting or if there is a lag/delay. I'm not typing stupendously fast, but pretty quick. Any slower and it feels very deliberate, like I'm typing a PIN into an ATM.

====

To test:
- start an app
- lock the phone
- resume
- swipe the greeter away
- verify that the app is suspended ("T" in ps x | grep) until you type the correct passcode

Related branches

Michał Sawicz (saviq) wrote :

I can confirm this, and I don't think this has anything to do with the keyboard.

Changed in unity8 (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Michael Zanetti (mzanetti)
Changed in ubuntu-keyboard:
status: New → Incomplete
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
Michał Sawicz (saviq) on 2014-11-17
Changed in ubuntu-keyboard:
status: Incomplete → Invalid
Bill Filler (bfiller) wrote :

I'd like to propose we land this for an ota update and bumped it's priority to High. I hit the issue all the time and so will our users and it's quite frustrating. Seeing that it's a one-liner we should definitely get this in.

tags: added: ota-1 rtm14
Changed in unity8 (Ubuntu):
importance: Medium → High
Changed in unity8 (Ubuntu RTM):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.01+15.04.20141117-0ubuntu1

---------------
unity8 (8.01+15.04.20141117-0ubuntu1) vivid; urgency=low

  [ josharenson ]
  * Return focus to the application after a tusted session overlay is
    closing. (LP: #1381292)

  [ Josh Arenson ]
  * Return focus to the application after a tusted session overlay is
    closing. (LP: #1381292)

  [ Albert Astals ]
  * Remove unused ResponsiveFlowView
  * Fix a few cmake warnings when running ./build.sh in a clean checkout

  [ Mirco Müller ]
  * Make sure non-square icons are not cropped. (LP: #1378417)

  [ Michael Terry ]
  * Drop the "EARLY ALPHA" scare label when running in testing mode.

  [ Michael Zanetti ]
  * unify Greeter and Lockscreen wallpaper again
  * hide quicklist when launcher hides (LP: #1387088)
  * Keep applications suspended while lockscreen is shown (LP: #1378126)
  * change spread background color to 111111

  [ Omer Akram ]
  * show password when tapped on the 'Show password' label, not just the
    checkbox. (LP: #1389832)
 -- Ubuntu daily release <email address hidden> Mon, 17 Nov 2014 13:48:33 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Olli Ries (ories) on 2014-11-26
Changed in canonical-devices-system-image:
assignee: nobody → Canonical Devices Products (canonical-devices-products-team)
importance: Undecided → High
milestone: none → r1
status: New → Confirmed
Michał Sawicz (saviq) on 2014-12-01
Changed in unity8 (Ubuntu RTM):
milestone: none → 14.09-ota-1
Michał Sawicz (saviq) on 2014-12-02
Changed in unity8 (Ubuntu RTM):
status: New → Triaged
Michał Sawicz (saviq) on 2014-12-05
Changed in unity8 (Ubuntu RTM):
status: Triaged → In Progress
assignee: nobody → Michał Sawicz (saviq)
Michał Sawicz (saviq) on 2014-12-08
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.01.1+15.04.20141208~rtm-0ubuntu1

---------------
unity8 (8.01.1+15.04.20141208~rtm-0ubuntu1) 14.09; urgency=medium

  [ Michael Terry ]
  * Make sure that there is no window of opportunity for swiping away
    greeter before the lockscreen appears. (LP: #1395075)

  [ Michael Zanetti ]
  * Keep applications suspended while lockscreen is shown (LP: #1378126)

  [ Mirco Müller ]
  * Make sure non-square icons are not cropped. (LP: #1378417)
 -- Ubuntu daily release <email address hidden> Mon, 08 Dec 2014 09:31:49 +0000

Changed in unity8 (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
jtd (jtdjtdjtd-business) wrote :

Ubuntu Phone 15.04 (r23) [mako]

I jumped from ~r15 to r23 and lately have a vague constellation of symptoms that seem to relate to slow processor, memory, or display. Unfortunately, I have not discovered where to correctly file this bug.

 - Password to unlock phone often fails due to missed key or confirms keys pressed ~3 seconds after I touch screen
 - Scrolling web page on Browser suddenly locks, after two or three swipes with no response, screen then shows bottom of page
 - Rotating phone from landscape to portrait and back, often a stretched screen or fuzzy screen appears
 - In Contacts, looking for name toward middle or end of alphabet, I swipe down and touch "M" and it goes to first name with "M" and then a second later reloads Contacts to first name with "A" and I have to swipe down and touch "M" again before I am able to select name
 - When I touch button to wake up a locked phone, nothing happens, I then touch again and the password screen appears momentarily and then returns to black, and I have to touch third time to finally load password screen and enter password

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers