Launcher needs to dynamically respond to reset

Bug #1376707 reported by Pat McGowan on 2014-10-02
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-system-settings (Ubuntu)
Critical
Michael Zanetti
Vivid
Critical
Michael Zanetti
unity8 (Ubuntu)
Critical
Michael Zanetti
Vivid
Critical
Michael Zanetti
unity8 (Ubuntu RTM)
Critical
Michael Zanetti

Bug Description

Currently the reset launcher action initiated from the system settings app requires the user to reboot the device. The intended design is for the launcher to dynamically reset to the initial state and briefly reveal itself.

Related branches

Pat McGowan (pat-mcgowan) wrote :

System settings will need to remove the text instructing the user that a reboot is required

Changed in unity8 (Ubuntu):
assignee: nobody → Michael Zanetti (mzanetti)
status: New → In Progress
Michael Zanetti (mzanetti) wrote :

The attached branches make the launcher update live upon changes in the settings, thus making it update when resetting the settings too.

Note: It does not yet make the launcher show itself briefly as the launcher currently doesn't have any "show itself" animations specced out by design yet. I'm working together with Vesa on such animations for the various situations but not before RTM any more.

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Michael Zanetti (mzanetti)
status: New → In Progress
Changed in unity8 (Ubuntu):
importance: Undecided → Critical
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Critical
tags: added: rtm14 touch-2014-10-16
Olli Ries (ories) wrote :

not a target for the 10/16 image, moving to 10/23

tags: added: touch-2014-10-23
removed: touch-2014-10-16
Michał Sawicz (saviq) on 2014-10-20
Changed in unity8 (Ubuntu RTM):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Michael Zanetti (mzanetti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+14.10.20141022-0ubuntu1

---------------
ubuntu-system-settings (0.3+14.10.20141022-0ubuntu1) utopic; urgency=low

  [ CI bot ]
  * Resync trunk

  [ Michael Zanetti ]
  * update code to reset launcher after launcher backend implementation
    was reworked (LP: #1376707)
 -- Ubuntu daily release <email address hidden> Wed, 22 Oct 2014 21:34:27 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
kevin gunn (kgunn72) on 2014-10-27
tags: added: touch-2014-10-30
removed: touch-2014-10-23
Olli Ries (ories) wrote :

this bug needs to be targeted after RTM, via ota

tags: added: ota-1
removed: touch-2014-10-30
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.01+15.04.20141030~rtm-0ubuntu1

---------------
unity8 (8.01+15.04.20141030~rtm-0ubuntu1) 14.09; urgency=medium

  [ Michael Terry ]
  * Provide 'passphrase' as a field of Components.Lockscreen
  * Fix a race between Qml loading and DBus registration that caused
    problems when jenkins tried to unlock the phone.
  * Set domain explicitly for the Dialogs component because the welcome
    wizard wants to import it. (LP: #1381731)
  * When greeter or lockscreen has focus, show active call panel. (LP:
    #1378872)

  [ Ted Gould ]
  * Set the default OOM score for the dash (LP: #1379786)

  [ Michał Sawicz ]
  * Revert lp:~unity-team/unity8/flickables-speed-workaround to avoid
    risk in RTM.
  * Updated behaviour for zoomable image, workaround for sourcesize (LP:
    #1333187)

  [ Michael Frey ]
  * Added a check for Proximity to determine if we show the lock screen.
    (LP: #1378012)

  [ Ying-Chun Liu ]
  * Add non-interactive code into GenericScopeView. (LP: #1384441)

  [ Mirco Müller ]
  * Also use modal nature of snap-decision notifications when
    greeter/lockscreen is shown. This fixes LP: #1378827. (LP: #1378827)

  [ Michael Zanetti ]
  * Make the launcher update on dconf changes (LP: #1376707)
  * exit spread on background tap (LP: #1368261)
  * Use an index instead of a scope id in DashCommunicator (LP:
    #1376044)

  [ Andrea Cimitan ]
  * Updated behaviour for zoomable image, workaround for sourcesize (LP:
    #1333187)

  [ Daniel d'Andrada ]
  * Make TouchGate synthesize QMouseEvents for mouse-based target items
  * Don't specify a distanceThreshold as it conflicts with
    hintDisplacment
 -- Ubuntu daily release <email address hidden> Thu, 30 Oct 2014 21:43:42 +0000

Changed in unity8 (Ubuntu RTM):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.01+15.04.20141030-0ubuntu1

---------------
unity8 (8.01+15.04.20141030-0ubuntu1) vivid; urgency=medium

  [ Michael Terry ]
  * Provide 'passphrase' as a field of Components.Lockscreen
  * Fix a race between Qml loading and DBus registration that caused
    problems when jenkins tried to unlock the phone.
  * Set domain explicitly for the Dialogs component because the welcome
    wizard wants to import it. (LP: #1381731)
  * When greeter or lockscreen has focus, show active call panel. (LP:
    #1378872)

  [ Ted Gould ]
  * Set the default OOM score for the dash (LP: #1379786)

  [ Michał Sawicz ]
  * Revert lp:~unity-team/unity8/flickables-speed-workaround to avoid
    risk in RTM.
  * Updated behaviour for zoomable image, workaround for sourcesize (LP:
    #1333187)

  [ Michael Frey ]
  * Added a check for Proximity to determine if we show the lock screen.
    (LP: #1378012)

  [ Ying-Chun Liu ]
  * Add non-interactive code into GenericScopeView. (LP: #1384441)

  [ Mirco Müller ]
  * Also use modal nature of snap-decision notifications when
    greeter/lockscreen is shown. This fixes LP: #1378827. (LP: #1378827)

  [ Michael Zanetti ]
  * Make the launcher update on dconf changes (LP: #1376707)
  * exit spread on background tap (LP: #1368261)
  * Use an index instead of a scope id in DashCommunicator (LP:
    #1376044)

  [ Andrea Cimitan ]
  * Updated behaviour for zoomable image, workaround for sourcesize (LP:
    #1333187)

  [ Daniel d'Andrada ]
  * Make TouchGate synthesize QMouseEvents for mouse-based target items
  * Don't specify a distanceThreshold as it conflicts with
    hintDisplacment
 -- Ubuntu daily release <email address hidden> Thu, 30 Oct 2014 21:43:42 +0000

Changed in unity8 (Ubuntu Vivid):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers