[Dash] Simplify 'Manage Dash' area

Bug #1368670 reported by James Mulholland on 2014-09-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Canonical Devices Products
Ubuntu UX
Undecided
James Mulholland
unity-scope-mediascanner (Ubuntu)
Undecided
Unassigned
Utopic
Undecided
Unassigned
unity-scope-mediascanner (Ubuntu RTM)
Undecided
Unassigned
unity-scopes-shell (Ubuntu)
Critical
Paweł Stołowski
Utopic
Undecided
Unassigned
unity-scopes-shell (Ubuntu RTM)
Critical
Paweł Stołowski
unity8 (Ubuntu)
Critical
Albert Astals Cid
unity8 (Ubuntu RTM)
High
Michał Sawicz

Bug Description

UX Testing Report: "Replace the current bottom edge screens with the simpler "Complete list of Scopes" design."

New Manage Dash design can be found here:
https://sites.google.com/a/canonical.com/unity-8-dash-rtm-1/scope-structure-navigation/my-feeds-structure

Additional UX Testing Report findings addressed by the redesign:

"Poor discoverability and comprehension of scopes - The use of labelings that do not include the word 'scope'/'scopes'"

"Lack of visual distinctions between apps and scopes in the 'manage dash' screen"

"Undefined relationship between apps and scopes"

"Search function does not help the discovery of scopes"

"No dedicated place for adding scopes on the dash"

"Poor memorability in locating the' manage dash' screen again"

"The impact of making a scope favourite is unclear"

"Lack of indication of the nature of the scopes under 'all' tab on 'manage dash'"

"Navigation between manage dash and apps scope was difficult"

"Expect to see categorises instead of content"

---
[UX Comment]
Please refer to the "Dash & Feeds RTM usability fix" for this bug:
https://docs.google.com/a/canonical.com/document/d/1dCXXIzPuS7yoiKJklmIwNpWxFkbLnXgr_agCPAMxJuw/edit?usp=sharing

---
[UX Comment]
Work on 'manage dash' has been deprioritised and may cease entirely.

See this document from design management for more info:
https://docs.google.com/a/canonical.com/document/d/1kpRKGSzwjC0YH3oPuLR8zXtfoq5NGCNilNxTAXhFKHU/edit#

Related branches

description: updated
Michał Sawicz (saviq) on 2014-09-12
Changed in ubuntu-ux:
status: New → Fix Committed
Michał Sawicz (saviq) on 2014-09-12
Changed in unity8 (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in ubuntu-ux:
assignee: nobody → James Mulholland (jamesjosephmulholland)
summary: - Simplify 'Manage Dash' area
+ [Dash] Simplify 'Manage Dash' area
Victor Tuson Palau (vtuson) wrote :

this should be critical for rtm

tags: added: rtm-14
Olli Ries (ories) on 2014-09-16
Changed in unity8 (Ubuntu):
importance: Medium → Critical
kevin gunn (kgunn72) on 2014-09-16
Changed in unity8 (Ubuntu):
assignee: nobody → Albert Astals Cid (aacid)
tags: added: touch-2014-10-16
Albert Astals Cid (aacid) wrote :

Note that this "simplification" brings over at least two new features, a badge count for new feeds, and the possibility to remove feeds from the list, so thus is not a "simplification", this is a total redesign and is not something that is going to happen in a few hours.

Albert Astals Cid (aacid) wrote :

Another one, now we have a "Child feed names" list that was nowhere previously.

Benjamin Keyser (bjkeyser) wrote :

This bug was meant to be critical, just adding the tag to make sure we're in sync with engineering

Changed in ubuntu-ux:
importance: Undecided → Critical
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
description: updated
tags: added: rtm14
removed: rtm-14
Joe Odukoya (jodukoya) wrote :

After review and discussion this is being moved to OTA-1.

It is imperative that this is available for OTA1 so I propose that we still aim for the two staged approach as outlined in the document Unity8 Design update estimates doc.

With Option2 targeted for OTA1 and Option1 targeted for later (potentially OTA-2).

Joe Odukoya (jodukoya) on 2014-09-23
tags: added: ota-1
tags: removed: touch-2014-10-16
kevin gunn (kgunn72) on 2014-10-20
tags: added: touch-2014-10-23
Changed in unity-scopes-shell (Ubuntu):
assignee: nobody → Pawel Stolowski (stolowski)
importance: Undecided → Critical
Michał Sawicz (saviq) on 2014-10-20
Changed in unity-scopes-shell (Ubuntu):
status: New → In Progress
Changed in unity-scopes-shell (Ubuntu RTM):
status: New → In Progress
assignee: nobody → Pawel Stolowski (stolowski)
importance: Undecided → Critical
Changed in unity8 (Ubuntu RTM):
status: New → In Progress
assignee: nobody → Albert Astals Cid (aacid)
Michał Sawicz (saviq) on 2014-10-20
Changed in unity8 (Ubuntu RTM):
importance: Undecided → Critical
Changed in unity-scopes-shell (Ubuntu RTM):
status: In Progress → Triaged
status: Triaged → In Progress
Olli Ries (ories) on 2014-10-22
tags: removed: touch-2014-10-23
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-scope-mediascanner (Ubuntu Utopic):
status: New → Confirmed
Changed in unity-scope-mediascanner (Ubuntu):
status: New → Confirmed
Changed in unity-scopes-shell (Ubuntu Utopic):
status: New → Confirmed
Changed in unity8 (Ubuntu Utopic):
status: New → Confirmed
kevin gunn (kgunn72) wrote :

note, the branches attached to this bug are under user testing as a solution

no longer affects: unity-scopes-api (Ubuntu)
Olli Ries (ories) on 2014-11-26
Changed in canonical-devices-system-image:
assignee: nobody → Canonical Devices Products (canonical-devices-products-team)
importance: Undecided → High
milestone: none → r1
status: New → Confirmed
Michał Sawicz (saviq) on 2014-12-01
Changed in unity8 (Ubuntu RTM):
assignee: Albert Astals Cid (aacid) → nobody
importance: Critical → High
milestone: none → 14.09-ota-1
status: In Progress → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-mediascanner - 0.2+15.04.20141205-0ubuntu1

---------------
unity-scope-mediascanner (0.2+15.04.20141205-0ubuntu1) vivid; urgency=low

  [ Pawel Stolowski ]
  * Set ids of aggreated scopes via ChildScopes ini option. (LP:
    #1368670)
 -- Ubuntu daily release <email address hidden> Fri, 05 Dec 2014 11:05:21 +0000

Changed in unity-scope-mediascanner (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scopes-shell - 0.5.4+15.04.20141205-0ubuntu1

---------------
unity-scopes-shell (0.5.4+15.04.20141205-0ubuntu1) vivid; urgency=low

  [ Pawel Stolowski ]
  * Support for Manage Dash as per latest designs. (LP: #1368670)
 -- Ubuntu daily release <email address hidden> Fri, 05 Dec 2014 11:02:19 +0000

Changed in unity-scopes-shell (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.01+15.04.20141205-0ubuntu1

---------------
unity8 (8.01+15.04.20141205-0ubuntu1) vivid; urgency=low

  [ CI Train Bot ]
  * Resync trunk

  [ Albert Astals ]
  * Replace Scopes Overview by the new Manage Dash (LP: #1386698,
    #1368670)
 -- Ubuntu daily release <email address hidden> Fri, 05 Dec 2014 10:55:50 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2014-12-12
Changed in unity8 (Ubuntu RTM):
assignee: nobody → Michał Sawicz (saviq)
status: Triaged → In Progress
Changed in canonical-devices-system-image:
importance: High → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-mediascanner - 0.2+15.04.20141216~rtm-0ubuntu1

---------------
unity-scope-mediascanner (0.2+15.04.20141216~rtm-0ubuntu1) 14.09; urgency=low

  [ Pawel Stolowski ]
  * Set ids of aggreated scopes via ChildScopes ini option (cherry
    picked rev. 219 of trunk) (LP: #1368670)
 -- Ubuntu daily release <email address hidden> Tue, 16 Dec 2014 16:19:39 +0000

Changed in unity-scope-mediascanner (Ubuntu RTM):
status: New → Fix Released
Changed in unity8 (Ubuntu RTM):
status: In Progress → Fix Released
no longer affects: unity8 (Ubuntu Utopic)
Bill Filler (bfiller) on 2014-12-17
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Changed in unity-scopes-shell (Ubuntu RTM):
status: In Progress → Fix Released
description: updated
Changed in ubuntu-ux:
importance: Critical → Wishlist
Changed in ubuntu-ux:
importance: Wishlist → Undecided
status: Fix Committed → Won't Fix
description: updated
description: updated
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers