Powerdown Dialog appear on waking the phone

Bug #1349362 reported by Dave Morley on 2014-07-28
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
unity8 (Ubuntu)
Critical
Unassigned

Bug Description

STEPS: (That seems to reproduce it for me)
1. With the device awake let it sleep on it's own
2. Once asleep wait for a minute
3. Tap the power button and leave it on the welcome screen

9/10 times this will trigger the issue here.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: unity8 7.90+14.10.20140725-0ubuntu1
Uname: Linux 3.4.0-5-mako armv7l
ApportVersion: 2.14.4-0ubuntu2
Architecture: armhf
Date: Mon Jul 28 11:26:25 2014
InstallationDate: Installed on 2014-07-28 (0 days ago)
InstallationMedia: Ubuntu Utopic Unicorn (development branch) - armhf (20140728-020205)
SourcePackage: unity8
UpgradeStatus: No upgrade log present (probably fresh install)

Dave Morley (davmor2) wrote :
Changed in unity8 (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed

Had this a lot last week when waking up my phone.

kevin gunn (kgunn72) wrote :

first when you tag something "blocker" I would request that we change its priority to critical.

second, i have asked, and according to witnesses of this bug, you can simply press cancel on the dialog to dismiss. wondering if this is related to spurious power key event that alberta was chasing.

Dave Morley (davmor2) wrote :

This seems to be fixed with the work that is in silo 006, which I have tested at Saviq's request

Michał Sawicz (saviq) on 2014-07-28
Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
Dave Morley (davmor2) on 2014-07-28
Changed in unity8 (Ubuntu):
importance: High → Critical
tags: added: lt-blocker lt-category-visible lt-prio-medium lt-whitelisted
tags: removed: lt-whitelisted
Selene ToyKeeper (toykeeper) wrote :

I thought the fix for this landed in Utopic 158, but I just ran into it twice in a row in Utopic 159 on a mako.

I'm not sure what conditions trigger it (race condition?), but it appears to be happening only a small percentage of the time.

Michał Sawicz (saviq) wrote :

I was worried it would creep back up. It's probably just more difficult to trigger with QtComp, we need to investigate what happens... some key events must wander off or materialize when power state changes.

Changed in unity8 (Ubuntu):
status: In Progress → Confirmed
Dave Morley (davmor2) on 2014-07-30
tags: added: 7utopic qa-daily-testing rtm14
removed: utopic
Michał Sawicz (saviq) wrote :

Has anyone else seen this recently again? I haven't seen it for quite a while now.

Dave Morley (davmor2) wrote :

I haven't

Michał Sawicz (saviq) wrote :

OK, please reopen if you see this again, marking the image number and all info you can give.

Changed in unity8 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers