[sdk] Clicking on checkbox label should toggle the checkbox

Bug #1333228 reported by Michał Karnicki on 2014-06-23
36
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Medium
Olga Kemmet
ubuntu-ui-toolkit (Ubuntu)
Undecided
Adnane Belmadiaf
unity8 (Ubuntu)
Medium
Omer Akram
unity8 (Ubuntu RTM)
Undecided
Unassigned

Bug Description

For instance, take the "Connec to <wifi network>" pop-up dialog. When I touch the:
[ ] Show password
checkbox *label*, I'd expect the checkbox to toggle. I shouldn't need to have to exactly touch the checkbox box, which is a small area.

<https://goo.gl/rKtjAI> (currently Canonical-only link): “As with a switch or radio button, when a checkbox has a label, it should be clickable/tappable together with the checkbox itself.”

Related branches

Michał Sawicz (saviq) wrote :

This could probably be amended in the UITK as well, to be able to mark the label corresponding to a checkbox as one active for it aas well.

affects: unity8 → ubuntu-ui-toolkit
Michał Sawicz (saviq) on 2014-08-20
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
Michał Sawicz (saviq) on 2014-09-09
no longer affects: unity8
kevin gunn (kgunn72) wrote :

almost marked opinion for unity8 as it makes sense to just do it in toolkit, so are you thinking this is something we'd actually do in unity8 ?

Changed in unity8 (Ubuntu):
status: New → Opinion
status: Opinion → New
Michał Sawicz (saviq) wrote :

No I actually meant that there will be something u8 has to do to enable this for this use case.

Changed in unity8 (Ubuntu):
status: New → Triaged
importance: Undecided → High
importance: High → Medium
Michał Sawicz (saviq) on 2014-11-17
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Omer Akram (om26er)
Michał Sawicz (saviq) wrote :

This bug was fixed in the package unity8 - 8.01+15.04.20141117-0ubuntu1

---------------
unity8 (8.01+15.04.20141117-0ubuntu1) vivid; urgency=low

  [ josharenson ]
  * Return focus to the application after a tusted session overlay is
    closing. (LP: #1381292)

  [ Josh Arenson ]
  * Return focus to the application after a tusted session overlay is
    closing. (LP: #1381292)

  [ Albert Astals ]
  * Remove unused ResponsiveFlowView
  * Fix a few cmake warnings when running ./build.sh in a clean checkout

  [ Mirco Müller ]
  * Make sure non-square icons are not cropped. (LP: #1378417)

  [ Michael Terry ]
  * Drop the "EARLY ALPHA" scare label when running in testing mode.

  [ Michael Zanetti ]
  * unify Greeter and Lockscreen wallpaper again
  * hide quicklist when launcher hides (LP: #1387088)
  * Keep applications suspended while lockscreen is shown (LP: #1378126)
  * change spread background color to 111111

  [ Omer Akram ]
  * show password when tapped on the 'Show password' label, not just the
    checkbox. (LP: #1389832)
 -- Ubuntu daily release <email address hidden> Mon, 17 Nov 2014 13:48:33 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Zoltan Balogh (bzoltan) on 2014-11-24
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Zoltan Balogh (bzoltan) on 2014-11-24
no longer affects: ubuntu-ui-toolkit
summary: - Clicking on checkbox label should toggle the checkbox
+ [sdk] Clicking on checkbox label should toggle the checkbox
Changed in ubuntu-ux:
assignee: nobody → Giorgio Venturi (giorgio-venturi)
status: New → Triaged
importance: Undecided → Medium

That's not the default behaviour for list item, but it can be set in this way by the app developer if he wishes to do so. For example, you might have more actions in the list item, not just the checkbox

Changed in ubuntu-ux:
status: Triaged → Fix Committed
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-ux:
assignee: Giorgio Venturi (giorgio-venturi) → Olga Kemmet (olga-kemmet)
Matthew Paul Thomas (mpt) wrote :

This is now part of the toolkit specification for checkboxes.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Invalid → Triaged
description: updated
Adnane Belmadiaf (daker) on 2017-02-25
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Adnane Belmadiaf (daker)
Adnane Belmadiaf (daker) wrote :

@mpt can you please share the specification ?

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Triaged → In Progress
tags: added: unity8
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.2184+17.04.20170306

---------------
ubuntu-ui-toolkit (1.3.2184+17.04.20170306) zesty; urgency=medium

  [ Adnane Belmadiaf ]
  * Add support for CheckBox label when set
  * Add more tests for checkbox. Fixes LP: #1333228, LP: #1442851.
  * Make sure we resets partial text input from the input method.
    Fixes LP: #1630872.
  * Fix ListItem title/subtitle alignment & elide in RTL mode.
    Fixes LP: #1665944.
  * Fix PageHeader title alignment & elide in RTL mode. Fixes LP: #1665942.
  * Fix UbuntuListView docs. Fixes LP: #1486940.
  * Add count prop to OptionSelector. Fixes LP: #1341559.
  * Replace the hardcoded color with a theme color. Fixes LP: #1664758.
  * Fix the import statement for Menu, MenuBar and MenuGroup.
    Fixes LP: #1660604.

  [ Albert Astals Cid ]
  * Fix memory leak in UCStyleHints
  * ThinDivider: Anchors can't be null, set to undefined
  * No need to call UCUnits::resolveResource to learn we just need to load it
    normally because the fact that we already loaded it normally means we need
    to load it normally. Fixes LP: #1558663.
  * Fix conditional jump or move depends on uninitialised value(s)

  [ Christian Dywan ]
  * Initialize UCApplication with no side effects. Fixes LP: #1662868.
  * Unit test case insensitive FilterBehavior.pattern. Fixes LP: #1663924.
  * ListItemPopover delegate should (in)visible as per action Bug 1662220:
    [ListItem] Popupmenu shows traces of disabled actions

  [ Olivier Tilloy ]
  * Check that window is not null before accessing its activeFocusItem property.
    Fixes LP: #1664620.

  [ Lukáš Tinkl ]
  * Unbreak the startup race between unity8/qtmir and UITK trying talk to
    content-hub. Fixes LP: #1663106.

 -- Zoltán Balogh <email address hidden> Mon, 06 Mar 2017 16:04:56 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers