SIM unlock UI shifts a half-gridunit when starting and breaks easily

Bug #1308011 reported by Michał Sawicz
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-notifications (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
High
Mirco Müller

Bug Description

Get examples from lp:unity-notifications, and a few different symptoms can be seen:

1. ./sd-example-simunlock.py → SIM unlock UI shifts a little from the top, potentially related to those messages:

file:///usr/share/unity8/Greeter/Lockscreen.qml:71: ReferenceError: backgroundTopMargin is not defined
file:///usr/share/unity8/Notifications/Notification.qml:170:9: QML Column: Cannot specify top, bottom, verticalCen
ter, fill or centerIn anchors for items inside Column. Column will not function.
file:///usr/share/unity8/Notifications/Notification.qml:170:9: QML Column: Cannot specify top, bottom, verticalCen
ter, fill or centerIn anchors for items inside Column. Column will not function.

2. ./sd-example-simunlock.py → Ctrl+C → shell is locked with a grey overlay

3. I also saw some real bad lockup with the SIM UI half down the screen... but can't reproduce - will report back if it happens again

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity8 7.85+14.04.20140410.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: wl nvidia
ApportVersion: 2.14.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Apr 15 13:19:59 2014
SourcePackage: unity8
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Michał Sawicz (saviq) wrote :
Changed in unity8:
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → High
Mirco Müller (macslow)
Changed in unity8:
status: New → In Progress
Revision history for this message
Mirco Müller (macslow) wrote :

regarding 1.) The attached branch addresses the gap-issue. The ReferenceError of LockScreen.qml no longer happens. The anchor-warning concerning Column can't be avoided without breaking the whole layout of notifications.

regarding 2.) This is probably due to the menu-model on DBus going missing upon Ctrl-C. If someone shows me how to catch that inside QML, I should be able to gracefully exit the notification.

regarding 3.) I've never seen that or been able to reproduce such a lockup.

Michał Sawicz (saviq)
Changed in unity8 (Ubuntu):
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-notifications - 0.1.2+14.10.20140717-0ubuntu1

---------------
unity-notifications (0.1.2+14.10.20140717-0ubuntu1) utopic; urgency=low

  [ Mirco Müller ]
  * Added close() q_invokable to allow notifications to be closed from
    the renderer (unity8) side. This facilitates fixing LP:1308011 (LP:
    #1308011)
 -- Ubuntu daily release <email address hidden> Thu, 17 Jul 2014 02:14:19 +0000

Changed in unity-notifications (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.90+14.10.20140717.1-0ubuntu1

---------------
unity8 (7.90+14.10.20140717.1-0ubuntu1) utopic; urgency=low

  [ Michał Sawicz ]
  * Only generate .qmltypes files manually, no need to do it build-time.
    It didn't work when cross-compiling either, and required builders to
    have otherwise unnecessary environment.
  * Fix CardCreator test. It got broken with a merge that got landed
    along side of it.

  [ Ying-Chun Liu ]
  * Add reboot/shutdown (LP: #1234062)

  [ Albert Astals ]
  * Make the departments test more stable

  [ Mirco Müller ]
  * Fixes gap at top of sim-unlock/fullscreen notification (point 1.),
    fixes blocking overlay if underlying UnityMenuModel vanishes from
    DBus (point 2.). The third bullet-point of the bug-report, lockup of
    shell-UI, could not be reproduced. (LP: #1308011)

  [ Michael Terry ]
  * Expose a new greeter DBus property, IsActive, which tells apps and
    indicators when the integrated-greeter screen is active. Useful for
    switching UI modes when the screen is locked.
  * Allow the session to bring up the greeter/lockscreen over DBus. The
    emergency dialer will need this support in order to cancel bringing
    it up.

  [ Michael Zanetti ]
  * Fixes gap at top of sim-unlock/fullscreen notification (point 1.),
    fixes blocking overlay if underlying UnityMenuModel vanishes from
    DBus (point 2.). The third bullet-point of the bug-report, lockup of
    shell-UI, could not be reproduced. (LP: #1308011)
 -- Ubuntu daily release <email address hidden> Thu, 17 Jul 2014 09:38:20 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq)
Changed in unity8:
status: In Progress → Fix Released
Michał Sawicz (saviq)
Changed in unity8 (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → High
no longer affects: unity8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers