5 unity8 AP tests failing with Qt 5.2

Bug #1274484 reported by Timo Jyrinki on 2014-01-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity8 (Ubuntu)
Critical
Unassigned

Bug Description

With bug #1273956 starting to be fixed, I was able to run Unity8 AP tests more properly. Five of the 42 tests are failing, and I'm attaching logs here.

Instructions on upgrading should be always visible at https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta2 page.

'powerd-cli display on bright' in adb shell and phablet-test-run -n unity8 in another terminal tab. Bug #1258064 is related since I need to keep the screen on manually until MTP mount happens so that I can do the other commands.

Timo Jyrinki (timo-jyrinki) wrote :
Timo Jyrinki (timo-jyrinki) wrote :
description: updated
description: updated
description: updated
Leo Arias (elopio) wrote :

I couldn't reproduce the errors of tests:
unity8.shell.tests.test_emulators.DashAppsEmulatorTestCase.test_open_preview
unity8.shell.tests.test_hud.TestHud.test_show_hud_button_appears

The ones I can reproduce are the ones about application lifecycle. They fail on launch_test_application, which might be an autopilot issue. I'll ask autopilot devs.

Changed in unity8:
status: New → Confirmed
Leo Arias (elopio) wrote :

On the tests that fail, we launch the messaging app. It crashes as described in bug #1275835.

Timo Jyrinki (timo-jyrinki) wrote :

Seems to be fixed with Qt 5.2.1! Please reopen if needed.

Changed in unity8:
status: Confirmed → Fix Released
Michał Sawicz (saviq) on 2017-03-13
affects: unity8 → unity8 (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers