Messages in Incoming not always display the correct date and content

Bug #1253810 reported by Ursula Junque on 2013-11-21
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
qmenumodel (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Critical
Nick Dedekind

Bug Description

Sometimes SMSes are displayed with Dec 31 as a date and the content is not displayed. This happens every once in a while, in general the notifications are displayed correctly, but as I exchanged a lot of SMSes with different numbers, this problem happened a few times.

Related branches

Ursula Junque (ursinha) wrote :
Ursula Junque (ursinha) on 2013-11-26
tags: added: r27
Ricardo Salveti (rsalveti) wrote :

Confirming bug with r32.

Changed in indicator-messages (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Ricardo Salveti (rsalveti) wrote :

Probably a regression, as it's the first time I had this issue.

Vincent Ladeuil (vila) wrote :

Not a regression, I've seen it quite a few times but I could never reproduce it at will.

Vincent Ladeuil (vila) wrote :

It's also quite hard to track as it happens only in the notifications area only, not in the messaging app.

I've been tricked by the browser-ish icon into thinking it may be due to some html part (as I've seen some hmtl tags (<br/> IIRC that I can't find back anymore either but that's probably a different bug).

Ricardo Salveti (rsalveti) wrote :

The timestamp is correct from ofono, and the message is also displayed correctly in the messaging app, seems the bug is indeed in the indicator.

And I could easily reproduce the problem today.

Not seen that before, but seeing it on #31

I first had this problem with r27, when I reported the bug.

On Tue, Nov 26, 2013 at 8:38 PM, Alan Pope ㋛ <email address hidden> wrote:

> Not seen that before, but seeing it on #31
>
> --
> You received this bug notification because you are a member of Ubuntu
> Touch seeded packages, which is subscribed to indicator-messages in
> Ubuntu.
> https://bugs.launchpad.net/bugs/1253810
>
> Title:
> Messages in Incoming not always display the correct date and content
>
> Status in The Messaging Menu:
> New
> Status in “indicator-messages” package in Ubuntu:
> Confirmed
>
> Bug description:
> Sometimes SMSes are displayed with Dec 31 as a date and the content is
> not displayed. This happens every once in a while, in general the
> notifications are displayed correctly, but as I exchanged a lot of
> SMSes with different numbers, this problem happened a few times.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/indicator-messages/+bug/1253810/+subscriptions
>

--
Ursinha (Ursula Junque)
<email address hidden>
<email address hidden>
--
Ubuntu - I am because we are
--
Linux user #289453 - Ubuntu user #31144

Didier Roche (didrocks) wrote :

let's add the regression tag (as it's from image 27 at least) so that we can get it in our regression list (and so fixing ASAP)

tags: added: regression
Sebastien Bacher (seb128) wrote :

Weird, the indicator didn't change between 2013-10-29 and 2013-11-25 but the bug started in between ... seems like it was either there but happening less often for some reason, or it might be an issue with another component

Didier Roche (didrocks) wrote :

So, after talking with Saviq, it's a very old bug that was always present. They have a branch proposed to fix it but never decided on the correct resolution of this.

So, targetting Unity8 and attaching the branch to that bug. (and removing both version and regression tags)

tags: removed: r27 regression
affects: indicator-messages → unity8
affects: indicator-messages (Ubuntu) → unity8 (Ubuntu)
Ricardo Salveti (rsalveti) wrote :
Download full text (4.1 KiB)

More debug output:

phablet@ubuntu-phablet:~$ gdbus call --session --dest com.canonical.indicator.messages --object-path /com/canonical/indicator/messages/phone --method org.gtk.Menus.Start [0,1] | grep x-canonical-text
([(uint32 0, uint32 0, [{'action': <'indicator.messages'>, 'action-namespace': <'indicator'>, 'x-canonical-type': <'com.canonical.indicator.root'>, ':submenu': <(uint32 1, uint32 0)>}]), (1, 0, [{':section': <(uint32 1, uint32 1)>}, {':section': <(uint32 1, uint32 2)>}, {':section': <(uint32 1, uint32 3)>}]), (1, 1, [{'x-canonical-message-actions': <<[{'name': <'telephony-service-sms.msg-actions.323031332d31312d32375431333a35303a30302d303230302d33.quickReply'>, 'parameter-type': <'s'>}]>>, 'x-canonical-time': <int64 1385567400000000>, 'x-canonical-type': <'com.canonical.indicator.messages.messageitem'>, 'x-canonical-app-icon': <('themed', <['telephony-service-message-symbolic', 'telephony-service-message']>)>, 'x-canonical-message-id': <'323031332d31312d32375431333a35303a30302d303230302d33'>, 'label': <'27800'>, 'icon': <('file', <'file:///usr/share/telephony-service/assets/avatar-default@18.png'>)>, 'x-canonical-text': <'Alexander Sack has updated "december: the month of testing - phonedations testing standup", which is now @ Weekly from 13:00 to 14:00 on Monday from Mon Dec 2 t'>, 'x-canonical-subtitle': <''>, 'action': <'telephony-service-sms.msg.323031332d31312d32375431333a35303a30302d303230302d33'>}, {'x-canonical-message-actions': <<[{'name': <'telephony-service-sms.msg-actions.323031332d31312d32375431333a34373a31362d303230302d32.quickReply'>, 'parameter-type': <'s'>}]>>, 'x-canonical-time': <int64 1385567236000000>, 'x-canonical-type': <'com.canonical.indicator.messages.messageitem'>, 'x-canonical-app-icon': <('themed', <['telephony-service-message-symbolic', 'telephony-service-message']>)>, 'x-canonical-message-id': <'323031332d31312d32375431333a34373a31362d303230302d32'>, 'label': <'27800'>, 'icon': <('file', <'file:///usr/share/telephony-service/assets/avatar-default@18.png'>)>, 'x-canonical-text': <'Alexander Sack invites you to: december: the month of testing - phonedations testing sta... @ Weekly from 13:00 to 14:00 on Monday (<email address hidden>'>, 'x-canonical-subtitle': <''>, 'action': <'telephony-service-sms.msg.323031332d31312d32375431333a34373a31362d303230302d32'>}, {'x-canonical-message-actions': <<[{'name': <'telephony-service-sms.msg-actions.323031332d31312d32375431333a34343a35362d303230302d31.quickReply'>, 'parameter-type': <'s'>}]>>, 'x-canonical-time': <int64 1385567096000000>, 'x-canonical-type': <'com.canonical.indicator.messages.messageitem'>, 'x-canonical-app-icon': <('themed', <['telephony-service-message-symbolic', 'telephony-service-message']>)>, 'x-canonical-message-id': <'323031332d31312d32375431333a34343a35362d303230302d31'>, 'label': <'27800'>, 'icon': <('file', <'file:///usr/share/telephony-service/assets/avatar-default@18.png'>)>, 'x-canonical-text': <'Reminder: Phonedations Stand-up @ Wed Nov 27, 2013 14:00 - 14:30 in Hangout (<email address hidden>)'>, 'x-canonical-subtitle': <''>, 'action': <'telephony-service-sms.msg.323031332d31312d32375431333a34343a35362d303230302d3...

Read more...

Lars Karlitski (larsu) wrote :

Thanks Ricardo. The timestamps in your log are correct. So this is indeed a display issue in unity8.

Dave Morley (davmor2) wrote :
Changed in unity8:
status: New → Confirmed
Dave Morley (davmor2) wrote :

The above was take from image 42 on maguro.

kevin gunn (kgunn72) wrote :

just a note, as discussed previously, this is an "older" bug and there a branch we hope to land soon.

kevin gunn (kgunn72) on 2013-12-03
Changed in unity8:
importance: Undecided → High
assignee: nobody → Nick Dedekind (nick-dedekind)
Michał Sawicz (saviq) on 2013-12-10
Changed in unity8:
status: Confirmed → In Progress
Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
Michał Sawicz (saviq) wrote :

When I can see this happening, the following is logged:

(process:17651): GLib-GIO-CRITICAL **: g_bus_watch_name: assertion 'g_dbus_is_name (name)' failed
file:///home/phablet/shell/builddir/plugins/Unity/Indicators/MenuItemFactory.qml:205: TypeError: Cannot call method 'loadExtendedAttributes' of null
file:///home/phablet/shell/builddir/plugins/Unity/Indicators/Messaging/MessageMenuItemFactory.qml:46: TypeError: Cannot read property 'xCanonicalText' of undefined
file:///home/phablet/shell/builddir/plugins/Unity/Indicators/Messaging/MessageMenuItemFactory.qml:45: TypeError: Cannot read property 'xCanonicalTime' of undefined
file:///home/phablet/shell/builddir/plugins/Unity/Indicators/Messaging/MessageMenuItemFactory.qml:49: TypeError: Cannot read property 'xCanonicalAppIcon' of undefined
file:///home/phablet/shell/builddir/plugins/Unity/Indicators/Messaging/MessageMenuItemFactory.qml:48: TypeError: Cannot read property 'icon' of undefined
file:///home/phablet/shell/builddir/plugins/Unity/Indicators/Messaging/MessageMenuItemFactory.qml:28: TypeError: Cannot read property 'xCanonicalMessageActions' of undefined
file:///home/phablet/shell/builddir/plugins/Unity/Indicators/MenuItemFactory.qml:76: TypeError: Cannot call method 'loadExtendedAttributes' of undefined
file:///home/phablet/shell/builddir/plugins/Unity/Indicators/MenuItemFactory.qml:187: TypeError: Cannot call method 'loadExtendedAttributes' of undefined
file:///home/phablet/shell/builddir/plugins/Unity/Indicators/MenuItemFactory.qml:187: TypeError: Cannot call method 'loadExtendedAttributes' of undefined
file:///home/phablet/shell/builddir/plugins/Unity/Indicators/MenuItemFactory.qml:187: TypeError: Cannot call method 'loadExtendedAttributes' of undefined
file:///home/phablet/shell/builddir/plugins/Unity/Indicators/MenuItemFactory.qml:187: TypeError: Cannot call method 'loadExtendedAttributes' of undefined
file:///home/phablet/shell/builddir/plugins/Unity/Indicators/MenuItemFactory.qml:187: TypeError: Cannot call method 'loadExtendedAttributes' of undefined

That seems to explain why that data is unavailable - the extended attributes were never loaded correctly. You can't see the icon, the text, the time - that's the metadata that comes via extended attributes - and they can't be loaded.

What I'm seeing is that loadExtendedAttributes is just called too early sometimes - when the model isn't yet available in the context.

Seems what we need to make sure of, then, is to a) not assume the model is there when we want it b) protect against not-yet-loaded extended attributes. The properties (model and modelIndex) should also be made properties of the BaseMenuItem, I'd say, so that they don't reach out of their scope.

The previously attached branch doesn't address this issue, then.

kevin gunn (kgunn72) on 2013-12-12
Changed in unity8:
importance: High → Critical
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision 590, scheduled for release in unity8, milestone phone-v1-freeze

Changed in unity8:
status: In Progress → Fix Committed
kevin gunn (kgunn72) on 2013-12-12
Changed in unity8 (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.84+14.04.20131212-0ubuntu1

---------------
unity8 (7.84+14.04.20131212-0ubuntu1) trusty; urgency=low

  [ Michał Sawicz ]
  * Add PyDev project files for autopilot tests. Also tweak .bzrignore
    to not ignore generic Eclipse project definitions.
  * Retry unlocking the greeter three times.
  * Reduce code duplication and clean up CMakeLists and includes in
    indicator tests.

  [ Nick Dedekind ]
  * Replaced indicator page dynamic menuSelected binding with Connection
    to listview selectedIndex property. (LP: #1243146)
  * Indicators close when menu items are activated. (LP: #1238182)
  * Fixed up connections for changes to model data. (LP: #1253810)

  [ Albert Astals ]
  * dashItemSelected -> showDashHome Because we are not using the index
    at all in the upper layers.
  * Fix filtering colllapsing/expanding again Also the delegate creation
    range stuff flows up->down not down->up so rearrange the bindings.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 590
 -- Ubuntu daily release <email address hidden> Thu, 12 Dec 2013 21:41:19 +0000

Changed in unity8 (Ubuntu):
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2013-12-13
Changed in unity8:
status: Fix Committed → Fix Released
Changed in qmenumodel (Ubuntu):
status: New → Fix Committed
Michael Terry (mterry) on 2016-08-15
Changed in qmenumodel (Ubuntu):
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2017-03-13
Changed in unity8 (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
importance: High → Critical
no longer affects: unity8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers