SIGSEGV when clearing message indicators

Bug #1243146 reported by Nick Dedekind on 2013-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity8 (Ubuntu)
Medium
Nick Dedekind

Bug Description

When clearing the messages in the message indicator, unity8 sometimes crashes.

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff68658a5 in isSignalConnected (signal_index=3, this=0x0) at kernel/qobject_p.h:233
233 kernel/qobject_p.h: No such file or directory.
(gdb) bt
#0 0x00007ffff68658a5 in isSignalConnected (signal_index=3, this=0x0) at kernel/qobject_p.h:233
#1 QMetaObject::activate (sender=0x18d0710, signalOffset=3, local_signal_index=<optimised out>, argv=0x0) at kernel/qobject.cpp:3330
#2 0x00007ffff760e27c in QQuickVisualDataModel::_q_itemsRemoved(int, int) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#3 0x00007ffff76b2125 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4 0x00007ffff76b270f in QQuickVisualDataModel::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5 0x00007ffff686612d in QMetaObject::activate (sender=sender@entry=0x13477d0, signalOffset=<optimised out>, local_signal_index=local_signal_index@entry=12, argv=argv@entry=0x7fffffffcce0)
    at kernel/qobject.cpp:3460
#6 0x00007ffff6866597 in QMetaObject::activate (sender=sender@entry=0x13477d0, m=m@entry=0x7ffff6c4af80 <QAbstractItemModel::staticMetaObject>, local_signal_index=local_signal_index@entry=12,
    argv=argv@entry=0x7fffffffcce0) at kernel/qobject.cpp:3320
#7 0x00007ffff68caa54 in QAbstractItemModel::rowsRemoved (this=this@entry=0x13477d0, _t1=..., _t2=0, _t3=0) at .moc/release-shared/moc_qabstractitemmodel.cpp:427
#8 0x00007ffff67fd9cb in QAbstractItemModel::endRemoveRows (this=0x13477d0) at itemmodels/qabstractitemmodel.cpp:2591
#9 0x00007fffd6fed193 in UnityMenuModel::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libqmenumodel.so.0
#10 0x00007ffff6841e5d in QCoreApplication::notify (this=<optimised out>, receiver=<optimised out>, event=<optimised out>) at kernel/qcoreapplication.cpp:829
#11 0x00007ffff6841b8d in QCoreApplication::notifyInternal (this=0x61d140, receiver=0x13477d0, event=0x7fffffffcf40) at kernel/qcoreapplication.cpp:767
#12 0x00007fffd6fe3d73 in QCoreApplication::sendEvent(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libqmenumodel.so.0
#13 0x00007fffd6fead25 in UnityMenuModelPrivate::menuItemRemoved(int, void*) () from /usr/lib/x86_64-linux-gnu/libqmenumodel.so.0
#14 0x00007fffd6ff36ba in gtk_menu_tracker_remove_items () from /usr/lib/x86_64-linux-gnu/libqmenumodel.so.0
#15 0x00007fffd6ff3984 in gtk_menu_tracker_model_changed () from /usr/lib/x86_64-linux-gnu/libqmenumodel.so.0
#16 0x00007fffde4aaadc in ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
#17 0x00007fffde4aa40c in ffi_call () from /usr/lib/x86_64-linux-gnu/libffi.so.6
#18 0x00007fffdf1129c8 in g_cclosure_marshal_generic () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#19 0x00007fffdf112188 in g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#20 0x00007fffdf123b1d in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#21 0x00007fffdf12b829 in g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#22 0x00007fffdf12bae2 in g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#23 0x00007fffdf3f7312 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#24 0x00007fffdf3f7969 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#25 0x00007fffdf40b275 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#26 0x00007ffff3c213a6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007ffff3c216f8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007ffff3c2179c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007ffff68869dc in QEventDispatcherGlib::processEvents (this=0x621170, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#30 0x00007ffff6840a3b in QEventLoop::exec (this=this@entry=0x7fffffffdaf0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#31 0x00007ffff68461d1 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1020
#32 0x00000000004068a2 in startShell (argc=2, argv=0x7fffffffdf98, server=0x0) at /home/nick/Work/phablet/trunk/main.cpp:178
#33 0x0000000000406f68 in main (argc=2, argv=0x7fffffffdf98) at /home/nick/Work/phablet/trunk/main.cpp:221

Related branches

Changed in unity8:
status: New → Confirmed
Michał Sawicz (saviq) on 2013-10-23
Changed in unity8:
assignee: nobody → Nick Dedekind (nick-dedekind)
status: Confirmed → In Progress
importance: Undecided → Medium
tags: added: needs-ap-test
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision None, scheduled for release in unity8, milestone phone-v1-freeze

Changed in unity8:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.84+14.04.20131212-0ubuntu1

---------------
unity8 (7.84+14.04.20131212-0ubuntu1) trusty; urgency=low

  [ Michał Sawicz ]
  * Add PyDev project files for autopilot tests. Also tweak .bzrignore
    to not ignore generic Eclipse project definitions.
  * Retry unlocking the greeter three times.
  * Reduce code duplication and clean up CMakeLists and includes in
    indicator tests.

  [ Nick Dedekind ]
  * Replaced indicator page dynamic menuSelected binding with Connection
    to listview selectedIndex property. (LP: #1243146)
  * Indicators close when menu items are activated. (LP: #1238182)
  * Fixed up connections for changes to model data. (LP: #1253810)

  [ Albert Astals ]
  * dashItemSelected -> showDashHome Because we are not using the index
    at all in the upper layers.
  * Fix filtering colllapsing/expanding again Also the delegate creation
    range stuff flows up->down not down->up so rearrange the bindings.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 590
 -- Ubuntu daily release <email address hidden> Thu, 12 Dec 2013 21:41:19 +0000

Changed in unity8 (Ubuntu):
status: New → Fix Released
Michał Sawicz (saviq) on 2013-12-13
Changed in unity8:
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2017-03-13
Changed in unity8 (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
importance: Undecided → Medium
no longer affects: unity8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers