unity8 crashed with SIGSEGV in gtk_menu_tracker_item_get_attribute_value()

Bug #1239394 reported by Michał Sawicz on 2013-10-13
40
This bug affects 4 people
Affects Status Importance Assigned to Milestone
qmenumodel (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
High
Nick Dedekind

Bug Description

Crashed when fiddling with the indicators.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: unity8 7.82+13.10.20131011.2-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.5-0ubuntu2
Architecture: armhf
Date: Sun Oct 13 16:31:15 2013
ExecutablePath: /usr/bin/unity8
ExecutableTimestamp: 1381513564
InstallationDate: Installed on 2013-10-13 (0 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20131013)
MarkForUpload: True
ProcCmdline: unity8
ProcCwd: /home/phablet
Signal: 11
SourcePackage: unity8
Title: unity8 crashed with SIGSEGV in gtk_menu_tracker_item_get_attribute_value()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm autopilot cdrom dialout dip nopasswdlogin plugdev sudo tty video

Related branches

Michał Sawicz (saviq) wrote :
information type: Private → Public
Changed in unity8:
assignee: nobody → Nick Dedekind (nick-dedekind)

StacktraceTop:
 gtk_menu_tracker_item_get_attribute_value () from /tmp/apport_sandbox_cIeyiJ/usr/lib/arm-linux-gnueabihf/libqmenumodel.so.0
 UnityMenuModel::loadExtendedAttributes(int, QMap<QString, QVariant> const&) () at /build/buildd/qmenumodel-0.2.7+13.10.20131011/libqmenumodel/src/unitymenumodel.cpp:617
 UnityMenuModel::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () at /build/buildd/qmenumodel-0.2.7+13.10.20131011/obj-arm-linux-gnueabihf/libqmenumodel/src/moc_unitymenumodel.cpp:164
 UnityMenuModel::qt_metacall(QMetaObject::Call, int, void**) () at /build/buildd/qmenumodel-0.2.7+13.10.20131011/obj-arm-linux-gnueabihf/libqmenumodel/src/moc_unitymenumodel.cpp:229
 CallMethod(QObject*, int, int, int, int*, QV8Engine*, (anonymous namespace)::CallArgs&) () at qml/v8/qv8qobjectwrapper.cpp:1587

Changed in unity8 (Ubuntu):
importance: Undecided → Medium
tags: removed: need-armhf-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Thomas Strehl (strehl-t) on 2013-10-14
Changed in unity8 (Ubuntu):
importance: Medium → High
Changed in unity8:
importance: Undecided → High
Antti Kaijanmäki (kaijanmaki) wrote :

This can be reproduced with network indicator.

1. open the network indicator
2. start toggling the Wi-Fi slider on/off repeatedly
3. eventually unity8 crashes

Changed in unity8:
status: New → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qmenumodel (Ubuntu):
status: New → Confirmed
Tony Espy (awe) wrote :

I reproduced this with a freshly flash image #99 on mako by repeatedly trying to connect to a secure Wi-Fi access point and then canceling the password dialog. Eventually the screen froze completely, and I found the .crash file lurking in /var/crash.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qmenumodel - 0.2.7+13.10.20131016-0ubuntu1

---------------
qmenumodel (0.2.7+13.10.20131016-0ubuntu1) saucy; urgency=low

  [ Gustavo Pichorim Boiko ]
  * Use g_file_get_uri instead of g_file_get_path to make sure the URI's
    percent encoding is properly kept.

  [ Nick Dedekind ]
  * Added pointer checks for items/iterators. (lp#1239394). (LP:
    #1239394)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 95
 -- Ubuntu daily release <email address hidden> Wed, 16 Oct 2013 02:33:27 +0000

Changed in qmenumodel (Ubuntu):
status: Confirmed → Fix Released
Lars Karlitski (larsu) on 2013-12-04
Changed in unity8:
status: In Progress → Invalid
Changed in unity8 (Ubuntu):
status: Confirmed → Invalid
Michał Sawicz (saviq) on 2017-03-13
Changed in unity8 (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
no longer affects: unity8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers