In MIR landscape mode keyboard only works on left side

Bug #1236489 reported by Bill Filler on 2013-10-07
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-keyboard (Ubuntu)
Undecided
Daniel d'Andrada
Saucy
Undecided
Unassigned
unity-mir (Ubuntu)
High
Daniel d'Andrada
Saucy
Undecided
Unassigned
unity8 (Ubuntu)
Undecided
Daniel d'Andrada

Bug Description

if rotate to landscape mode the keys on the left side only in the osk work. the keys on the right do not work. probably input trap. works fine in SF

Related branches

Bill Filler (bfiller) on 2013-10-07
Changed in unity-mir (Ubuntu):
assignee: nobody → Ricardo Mendoza (ricmm)
importance: Undecided → High
Michał Sawicz (saviq) on 2013-10-08
Changed in unity-mir (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in unity-mir (Ubuntu):
assignee: Ricardo Mendoza (ricmm) → Daniel d'Andrada (dandrader)
Changed in unity8 (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-keyboard (Ubuntu):
status: New → In Progress
assignee: nobody → Daniel d'Andrada (dandrader)
Changed in unity-mir (Ubuntu):
status: Confirmed → In Progress
Changed in unity8 (Ubuntu):
assignee: nobody → Daniel d'Andrada (dandrader)
status: Invalid → In Progress
Changed in unity8 (Ubuntu):
status: In Progress → Fix Committed
Changed in unity-mir (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-keyboard (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-keyboard (Ubuntu Saucy):
status: New → Confirmed
Changed in unity-mir (Ubuntu Saucy):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+14.04.20131025-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+14.04.20131025-0ubuntu1) trusty; urgency=low

  [ Daniel d'Andrada ]
  * ubuntu-keyboard-info socket now reports the keyboard's scene
    geometry That's enough to cover keyboard rotations and animations.
    (LP: #1236489)

  [ Thomas Moenicke ]
  * adding key to change language.

  [ Leo Arias ]
  * Prepare for the release of autopilot 1.4 adding the dependency on an
    earlier release.

  [ Christopher Lee ]
  * Minor update/fixes for the autopilot emulators.

  [ Guenter Schwann ]
  * Keep url and @ key unchanged in shiftet state. (LP: #1240603)
  * Keep removing text when keeping the backspace key pressed.
  * Disable auto capitalization for any other content type than
    FreeTextContentType Wieth auto capitalizatin start with a capital on
    empty text fields.
  * After holding the backspace for a while, remove whole words. (LP:
    #1201988)
  * Reorganize tests let "make check" pass.
  * Decouple autocaps from predictive text fixes LP: #1214695. (LP:
    #1234685, #1214695)
  * Revert last 2 commit because of language issues.
  * Decouple autocaps from predictive text fixes LP: #1214695. (LP:
    #1214695)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 91
 -- Ubuntu daily release <email address hidden> Fri, 25 Oct 2013 11:04:48 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity8 (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-mir - 0.1+14.04.20131028-0ubuntu1

---------------
unity-mir (0.1+14.04.20131028-0ubuntu1) trusty; urgency=low

  [ Daniel d'Andrada ]
  * UbuntuKeyboardInfo now provides the opaque keybard area in scene
    coordinates So all that's left for OSKController is setting its
    InputArea to match it. No more guesswork anymore. (LP: #1236489)

  [ Alan Griffiths ]
  * Avoid unnecessary use of mir::surfaces::SurfaceStackModel (which
    ought to be internal to Mir).

  [ Albert Astals ]
  * Fix crashes/deadlocks if we sigterm the app while still starting up
    Three changes:  * We need to make sure that the_shell_* return a non
    unique shared pointer (i.e. Mir is also holding it)    otherwise
    once we return from the function it will cease to exist and we'll be
    using    deleted memory  * Move ua_ui_mirserver_finish to after the
    qApp has stopped, otherwise may happen the code    is still trying
    to do a QWindow::showMaximized and uses memory that is also gone  *
    Make the qApp quit call more stubborn, it can happen that sometimes
    we get to that code before the other thread    has done qApp->exec()
    so we wait until we get the aboutToQuit signal to make sure the
    other thread will stop.
  * Add two const & .

  [ thomas-voss ]
  * Ensure that app processes are not assigned an oom score smaller than
    the one of the shell.
  * stop/continue complete process groups instead of individual
    processes.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 136
 -- Ubuntu daily release <email address hidden> Mon, 28 Oct 2013 18:17:52 +0000

Changed in unity-mir (Ubuntu):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in unity-mir (Ubuntu Saucy):
status: Confirmed → Won't Fix
Changed in ubuntu-keyboard (Ubuntu Saucy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers