[search] keyboard doesn't reveal to continue search

Bug #1228155 reported by Jean-Baptiste Lallement on 2013-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-keyboard (Ubuntu)
High
Günter Schwann
Saucy
High
Günter Schwann
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
Saucy
Undecided
Unassigned
unity8 (Ubuntu)
High
Günter Schwann
Saucy
High
Günter Schwann

Bug Description

mako 20130918.1

Test Case
1. Go to the ‘Applications’ lens and open the ‘Search’ box, and start entering ‘ga’
2. Drag the keyboard down to hide it
3. Scroll the list of results
4. Set the focus on the search entry
5. Continue type ‘me’

Expected Result
First search should at least show ‘Gallery’ and ‘Sudoku’ (_ga_mes)
Second search should only show games

Actual result
On second search the keyboard doesn't reveal and user cannot continue his search.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: unity8 7.81.3+13.10.20130916-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.2-0ubuntu1
Architecture: armhf
Date: Fri Sep 20 13:39:37 2013
InstallationDate: Installed on 2013-09-18 (1 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20130918.1)
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SourcePackage: unity8
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
Julien Funk (jaboing) on 2013-09-23
tags: added: jfunk
Nicholas Skaggs (nskaggs) wrote :

confirming ,still present in 020130924

Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
Bill Filler (bfiller) on 2013-09-25
Changed in ubuntu-keyboard (Ubuntu):
importance: Undecided → High
assignee: nobody → Günter Schwann (schwann)
Changed in unity8 (Ubuntu):
importance: Undecided → High
assignee: nobody → Günter Schwann (schwann)
Günter Schwann (schwann) wrote :

so the problem is, that the textfield does not get the focus again (so rather a SDK, not a keyboard issue)

Bill Filler (bfiller) wrote :

@gusch
We should explicitly remove the focus of the text field when the keyboard is hidden. This should cause a new focus event when you click back into the field

Changed in ubuntu-keyboard (Ubuntu Saucy):
status: Confirmed → Fix Committed
Changed in ubuntu-ui-toolkit (Ubuntu Saucy):
status: New → Fix Committed
Changed in unity8 (Ubuntu Saucy):
status: Confirmed → Fix Committed
Michał Sawicz (saviq) on 2013-10-05
Changed in ubuntu-keyboard (Ubuntu Saucy):
status: Fix Committed → Invalid
Changed in ubuntu-ui-toolkit (Ubuntu Saucy):
status: Fix Committed → Invalid
tags: added: testcase
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+13.10.20131007-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+13.10.20131007-0ubuntu1) saucy; urgency=low

  [ Zoltán Balogh ]
  * Add default tools (LP: #1233709). (LP: #1233709)

  [ Loïc Molinari ]
  * Added URI handler support.
  * Fixed UbuntuShape warnings when using a ShaderEffectSource as an
    image.

  [ <email address hidden> ]
  * Added test cases for text field testing.
  * Minor change to make the OptionSelector more testable by adding
    objectName property to uniquely identify the object. (LP: #1234020)

  [ Christian Dywan ]
  * Set offline storage path and add a unit test. (LP: #1231863)
  * Emit domainChanged from bindtextdomain to trigger updates. (LP:
    #1220395)
  * Support TextArea used with an action.
  * Support option selector used with an action.
  * Add haptic feedback to AbstractButton. (LP: #1189537)

  [ Zsombor Egri ]
  * Fix Picker module deployment.
  * index property added to Tab to be able to reference the Tab number.
    Fixes bug #1233402. (LP: #1233402)

  [ Jussi Pakkanen ]
  * Adds thumbnailer image provider.

  [ Christopher Lee ]
  * Preparing autopilot tests for an upcoming update in autopilot 1.3.

  [ Andrea Cimitan ]
  * Export a position value of the toolbar through dbus, setting the
    value of the dbus service created by the shell. (LP: #1224480)

  [ Guenter Schwann ]
  * Better handle the case of dismissing the OSK and focusing the text
    again fixes LP: #1228155. (LP: #1228155)

  [ Renato Araujo Oliveira Filho ]
  * Added "confirmRemoval" in ListItem.Empty This will ask for
    confirmation before remove the item. (LP: #1213046)
  * Disabled confirmation on swipe to delete as default.

  [ Leo Arias ]
  * index property added to Tab to be able to reference the Tab number.
    Fixes bug #1233402. (LP: #1233402)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 786
 -- Ubuntu daily release <email address hidden> Mon, 07 Oct 2013 04:36:33 +0000

Changed in ubuntu-ui-toolkit (Ubuntu Saucy):
status: Invalid → Fix Released
Changed in unity8 (Ubuntu Saucy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers