unity8 and home/etc. scope crashes in automation in build 57

Bug #1228097 reported by Alexander Sack on 2013-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libunity
Fix Released
Undecided
Unassigned
libunity (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Critical
Michael Zanetti

Bug Description

build 57 crashes during unity8 autopilots.... crash files and logs are all in the build artifacts folder of this run:

https://jenkins.qa.ubuntu.com/job/saucy-touch_ro-mako-smoke-unity8-autopilot/103/

Thanks!

Related branches

Alexander Sack (asac) wrote :

currently assessing the impact on dogfoodability.

If this is fixed in trunk or well enough understood that we are willing to block build 58 on it, I will get QA sign off on letting build out to public

Changed in unity8 (Ubuntu):
importance: Undecided → Critical
Alexander Sack (asac) wrote :

mzanetti and thostr confirmed to be on it.

Alexander Sack (asac) wrote :

so it seems the issue is not in the version in build 57, but in the version that we promoted to the archive - which would be in build 58.

We found that you first have to apt-get update before apt-get install unity8-autopilot to trigger this crash.

This means build 57 is clean, just our dashboard reflects in this case what we would see on build 58 .

Please fix so the next build can happen.

Alexander Sack (asac) wrote :

we will release 57 after checking with jfunk. 58 is blocked because of this

Alexander Sack (asac) on 2013-09-20
Changed in unity8 (Ubuntu):
assignee: nobody → Michael Zanetti (mzanetti)
Alexander Sack (asac) on 2013-09-20
summary: - unity8 and home scope crashes in automation in build 57
+ unity8 and home/etc. scope crashes in automation in build 57
Thomas Strehl (strehl-t) wrote :

This only happens under test, meaning this issue does not surface when using the image in the regular/consumer way. Still, fix is under way...

Michael Zanetti (mzanetti) wrote :

We have identified the crashing line of code. Still trying to reproduce in order to properly test the fix.

Michael Zanetti (mzanetti) wrote :

Still haven't managed to reproduce. Using the latest image, with apt-get update and install unity8-autopilot. The version is the same as in the logs (7.81.3+13.10.20130919.3-0ubuntu1).

I've ran the whole test suite now for around 10 times, tried mako and maguro, ran the tests all at once, individually in a loop (as Jenkins does) and manually in random order. Still nothing. I got a bunch of other crashes (ofono, home-scope daemon) but never saw this one.

Alexander, can you please change the job to do a "ls -l /var/crash/" between every test case (and other major setup steps) so I can see in the Jenkins logs when exactly this happens?

Also, please let me know what else this device has been doing already before the test suite is ran. (e.g. which other test suites did it execute already etc)

Thanks.

Changed in unity8 (Ubuntu):
status: New → Incomplete
Alexander Sack (asac) wrote :

mzanetti, we see the crashes everytime you run the tests locally. please do that and you can instrument as much as you want.

Michał Sawicz (saviq) wrote :

Can we please have more elaborate steps to reproduce? As you can see we've tried many ways, to no avail. If you have at least a semi-reliable to reproduce, please post the steps so we can, too.

Alexander Sack (asac) wrote :

Saviq: so first, thostr said that they are able to reproduce and someone (pawel) is trying to fix it. So maybe check with them.

Beyond that I always got it when doing. I will rerun later..

Reproduce:

1. phablet-flash ubuntu-system --channel daily-proposed
2. (boot)
3. adb shell touch /userdata/.writable_image
4. adb shell reboot
5. (reboot)
6. adb shell apt-get install unity8-autopilot
7. phablet-test-run -n unity8

Julien Funk (jaboing) on 2013-09-23
tags: added: jfunk
Julien Funk (jaboing) on 2013-09-23
tags: added: avengers
Michael Zanetti (mzanetti) wrote :

So... we're talking about different crashes here:

* unity-scope-home crashes reliably when exiting the test suite. I think this is the one that Thomas said is reproducible and Pawel fixed this already.

* when this happens, sometimes unity8 crashes too. This is quite hard to reproduce and also does not work reliably with this steps. In all those test runs I did this happened once. The attached branch with the fix for unity8 looks good to me though.

Thomas Strehl (strehl-t) wrote :

We got a nullptr fix: https://code.launchpad.net/~stolowski/unity8/results-nullptr-fix/+merge/187052 but that needs still a minor change. Will get that in tomorrow morning.

Michal Hruby (mhr3) on 2013-09-24
Changed in unity8:
assignee: nobody → Pawel Stolowski (stolowski)
importance: Undecided → Critical
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision 340, scheduled for release in unity8, milestone ubuntu-13.09

Changed in unity8:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.81.3+13.10.20130924.2-0ubuntu1

---------------
unity8 (7.81.3+13.10.20130924.2-0ubuntu1) saucy; urgency=low

  [ Michal Hruby ]
  * Fix the signal prototypes on music grid renderer. (LP: #1228390)

  [ Michael Zanetti ]
  * use less auto variables, align coding style, constify and Qt'ify API
    in AccountsService plugin.

  [ Nick Dedekind ]
  * Re-enable MenuContentActivator in Indicators.

  [ Albert Astals ]
  * LVWPH: Update the section header on list change events.

  [ Pawel Stolowski ]
  * Check results model ptr returned by GetResultsFromCategory method
    from UnityCore. (LP: #1228097, #1211595)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 340
 -- Ubuntu daily release <email address hidden> Tue, 24 Sep 2013 14:40:01 +0000

Changed in unity8 (Ubuntu):
status: Incomplete → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 7.1.1+13.10.20130927-0ubuntu1

---------------
libunity (7.1.1+13.10.20130927-0ubuntu1) saucy; urgency=low

  [ Michal Hruby ]
  * Auto-close channels when their owner disappears from the bus. (LP:
    #1228097, #1199715)
  * Allow metadata=None when creating SearchContext from python. (LP:
    #1231390)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 295
 -- Ubuntu daily release <email address hidden> Fri, 27 Sep 2013 03:10:38 +0000

Changed in libunity (Ubuntu):
status: New → Fix Released
Michał Sawicz (saviq) on 2013-10-05
Changed in unity8:
status: Fix Committed → Fix Released
Changed in libunity:
status: New → Fix Released
Michał Sawicz (saviq) on 2017-03-13
no longer affects: unity8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers