Carousel should only be used when there's enough items

Bug #1226288 reported by Michał Sawicz on 2013-09-16
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
unity8 (Ubuntu)
Medium
Andrea Cimitan

Bug Description

The Carousel renderer should only be used when the item count is enough for the Carousel to behave correctly. That depends on the size of the Carousel and the size of its items, so the calculation needs to be thought through.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: unity8 7.81.3+13.10.20130912-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.1-0ubuntu4
Architecture: armhf
Date: Mon Sep 16 21:31:33 2013
InstallationDate: Installed on 2013-09-16 (0 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20130916.2)
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SourcePackage: unity8
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Michał Sawicz (saviq) wrote :
Changed in unity8:
status: New → Triaged
assignee: nobody → Andrea Cimitan (cimi)
Michał Sawicz (saviq) on 2013-09-19
Changed in unity8:
importance: Undecided → Medium
milestone: none → ubuntu-13.10
Michał Sawicz (saviq) on 2013-09-27
Changed in unity8 (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) on 2013-10-08
Changed in unity8:
milestone: ubuntu-13.10 → phone-v1-freeze
Andrea Cimitan (cimi) on 2013-10-10
Changed in unity8:
status: Triaged → In Progress
tags: added: needs-qml-test
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision None, scheduled for release in unity8, milestone phone-v1-freeze

Changed in unity8:
status: In Progress → Fix Committed
Michał Sawicz (saviq) on 2013-11-21
Changed in unity8 (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (6.6 KiB)

This bug was fixed in the package unity8 - 7.84+14.04.20131128.2-0ubuntu1

---------------
unity8 (7.84+14.04.20131128.2-0ubuntu1) trusty; urgency=low

  [ Michal Hruby ]
  * Depend on the separate scopes plugin
  * Move the BottomBar* DBus communicator to the Utils plugin.

  [ Michał Sawicz ]
  * Wait for DashHome to be available in tst_Shell. (LP: #1254898)
  * Use plugindir from unity-shell-api.pc.
  * Expect stop in upstart job and raise in case of surfaceflinger. (LP:
    #1239876)

  [ Albert Astals ]
  * Fix time test in Qt 5.2 Make factors an array instead of a
    object/dict Objects/dicts are unordered by definition, it happened
    that Qt 5.0 gave them in the orrder we wanted, but with Qt 5.2 is
    failing, and we don't even need the "key", so array works as well
    :).
  * Test that the dash hswipe is disabled while the inner stuff is
    moving .
  * Skip restMaximizeVisibleAreaMoveUpAndShowHeader, it's causing too
    many failed runs And we are confident it's failing because of the
    suboptimal scenegraph run in 5.0.x.
  * Make Dash::test_show_scope_on_load more robust If we are testing
    showScopeOnLoaded make sure we force a scope reload after we set it,
    otherwise it may just happen that the scope has already been loaded
    and the expectaction that we'll change the list to it is just wrong.
  * Dash renderer signals: No need to pass the model up and down Whoever
    is listening to the signal has access to the item that emits the
    signal and has the model right there accessible if needs it.
  * LVWPH: Fix header going bad when setContentHeight ends up moving the
    viewport How to reproduce the bug easily without the patch: * In the
    Dash Home, search for london * Scroll to the bottom * Start moving
    to the apps scope very slowly * At around 3/4 of the move you'll see
    the header in the home scope went to a bad position * Go back to the
    Dash Home. (LP: #1237942, #1246351)
  * Remove unused AppInfo and VideoInfo files .
  * Kill unused ApplicationsFilterGrid.qml .
  * Unify ScopeView and GenericScopeView .
  * Fix header getting lost as per bug 1245824. (LP: #1245824)
  * Remove unused Time.js and its test .
  * Do not include the QtQml megaheader Include only qqml.h which is
    what we need in these files.
  * Don't do stuff if our parent context is gone We'll be gone soon too
    (and crash probably) so don't do anything. This looks a bit like a
    workaround, wait for 5.2 better painting/dispatching loop to see if
    this is not needed anymore, we find a better way to do it, or we
    decide this is fine.

  [ Lars Uebernickel ]
  * Allow setting different indicator positions for different profiles.

  [ Mirco Müller ]
  * Added checkbox for toggling between echo-modes of password-
    entryfields in ext. snap-decisions.
  * Fixes bug #1200569. (LP: #1200569)

  [ Andrea Cimitan ]
  * Switch to application scope when a dash swipe is taking place and an
    app is on foreground. (LP: #1231996)
  * Shifts wallpaper rendering for greeter lockscreen to be inline with
    shell. (LP: #1231731)
  * Dinamically load the Carousel/Filtergrid with more than 6 items.
    (LP: #1226288, #1234105)
  * R...

Read more...

Changed in unity8 (Ubuntu):
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2013-11-29
Changed in unity8:
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2017-03-13
Changed in unity8 (Ubuntu):
assignee: nobody → Andrea Cimitan (cimi)
importance: Undecided → Medium
no longer affects: unity8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers