Launcher icons for click apps not displayed after reboot

Bug #1225186 reported by Michael Hall on 2013-09-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity8 (Ubuntu)
Critical
Michael Zanetti

Bug Description

After updating to the latest ubuntu-system image, I had Click app icons displaying on both the Dash and the Launcher. I was able to pin some of these to the Launcher. After a reboot, the icons are not being displayed on the Launcher, though the app entry is still there. Icons are displayed properly in the Dash.

You can see in the attached screenshot two pinned app entries in the Launcher. The lower one is for Google+, the higher is for Tasks. You can see both apps in the Dash in the background of the screenshot properly displaying their icons.

Related branches

Michael Hall (mhall119) wrote :
description: updated
kevin gunn (kgunn72) wrote :

michael z mind taking a look ? might not be yours i realize

Changed in unity8:
assignee: nobody → Michael Zanetti (mzanetti)
importance: Undecided → Critical
Michael Zanetti (mzanetti) wrote :

@kevin... fixed since last thursday in a branch of mine. Just need someone to review it ;)

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision 321, scheduled for release in unity8, milestone Unknown

Changed in unity8:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: Confirmed → Fix Committed
Michał Sawicz (saviq) on 2013-09-19
Changed in unity8:
milestone: none → ubuntu-13.09
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.81.3+13.10.20130919.3-0ubuntu1

---------------
unity8 (7.81.3+13.10.20130919.3-0ubuntu1) saucy; urgency=low

  [ Michal Hruby ]
  * Add support for music grid renderer to GenericScopeView.

  [ Nick Dedekind ]
  * Fixed the removal of messaging widget due to incompatible action
    state. (LP: #1225017)

  [ Christopher Lee ]
  * Addition of initial autopilot tests for the application lifecycle.

  [ Lars Uebernickel ]
  * VolumeControl: use action of the new indicator indicator-sound
    recently gained an action to increase and decrease the volume. This
    patch makes use of that to get rid of a bus round trip (to get the
    current volume) and a race (when the volume gets set between
    fetching the current volume and setting the new volume). (LP:
    #1219057)

  [ Michael Terry ]
  * When AccountsService.backgroundFile is unset/invalid, have the
    greeter fall back to whatever the shell background is.
  * Add a tiny SessionBroadcast plugin that listens to unity-greeter-
    session-broadcast for the ShowHome signal.

  [ Daniel d'Andrada ]
  * Remove obsolete, unused graphics.
  * Make MouseTouchAdaptor work with multiple QWindows.

  [ Michael Zanetti ]
  * change how icons are searched a) try to find it the Icon as is b)
    prepend with Path if a Path variable is given c) fall back to the
    image://theme/ with just the icon name . (LP: #1225186)
  * fix an issue with removing a running app from the launcher and
    always store pinning to the config.
  * collapse any open preview when programmatically switching current
    dash index. (LP: #1221137)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 333
 -- Ubuntu daily release <email address hidden> Thu, 19 Sep 2013 15:15:07 +0000

Changed in unity8 (Ubuntu):
status: Fix Committed → Fix Released
kevin gunn (kgunn72) on 2013-09-27
Changed in unity8 (Ubuntu):
milestone: none → ubuntu-13.10
Changed in unity8:
milestone: ubuntu-13.09 → phone-v1-freeze
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2017-03-13
Changed in unity8 (Ubuntu):
assignee: nobody → Michael Zanetti (mzanetti)
importance: Undecided → Critical
no longer affects: unity8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers