HUD isn't working

Bug #1205097 reported by Michał Sawicz on 2013-07-25
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity HUD
Fix Released
Critical
Antti Kaijanmäki
hud (Ubuntu)
Undecided
Antti Kaijanmäki
unity8 (Ubuntu)
Critical
Albert Astals Cid

Bug Description

The HUD doesn't seem to be working at all in the current images.

Please investigate whether this is an API break / backend issue / UI issue and reassign as appropriate.

Related branches

Albert Astals Cid (aacid) wrote :

Seems like something's wrong on the hud-service to me, for example, having the browser open i get this

$ ./hud-cli
search token:
        Goto
        Back
        Forward
        Reload
        Bookmark
        New Tab

So the hud-cli returns the correct results

$ dee-tool -m com.canonical.hud.query3.results
('com.canonical.hud.query3.results', ['v', 's', 'a(ii)', 's', 'a(ii)', 's', 'u', 'b'], [[<<uint64 17>>, <'Quit'>, <@a(ii) []>, <'Quit the application.'>, <@a(ii) []>, <''>, <uint32 10>, <false>], [<<uint64 18>>, <'Compose'>, <@a(ii) []>, <'New Message'>, <@a(ii) []>, <''>, <uint32 10>, <false>], [<<uint64 19>>, <'Add'>, <@a(ii) []>, <'New Contact'>, <@a(ii) []>, <''>, <uint32 10>, <false>]], [0, 1, 2], [0x00, 0x00, 0x00], (96, 99), {'column-names': <@as []>, 'fields': <@a(uss) []>})

But the query model is not updated and still returns the old results from the previous app

Changed in hud:
assignee: nobody → Ted Gould (ted)
importance: Undecided → Critical
Pete Woods (pete-woods) on 2013-08-20
Changed in hud:
assignee: Ted Gould (ted) → Pete Woods (pete-woods)
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:hud at revision 311, scheduled for release in hud, milestone Unknown

Changed in hud:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:hud at revision 312, scheduled for release in hud, milestone Unknown

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hud - 13.10.1+13.10.20130822.4-0ubuntu1

---------------
hud (13.10.1+13.10.20130822.4-0ubuntu1) saucy; urgency=low

  [ Pete Woods ]
  * Fix hud client-reconnects on the phone This branch fixes hud-
    clients's ability to seamlessly reconnect to HUD. (LP: #1205097)

  [ Ted Gould ]
  * Migrate from g_simple_action_group_insert to
    g_action_map_add_action. (LP: #1215180)

  [ Antti Kaijanmäki ]
  * Fix Ubuntu UI Session callbacks. On Touch Images where we use Ubuntu
    UI Session API to get notifications when active window changes. The
    callbacks are being invoked from a separate thread. We have to pass
    the callbacks through g_idle_add() to process them in main
    gmaincontext. This also requires to change the type of
    AbstractWindow and AbstractApp as we can't pass on the
    ubuntu_ui_session_properties accross different threads. (LP:
    #1205097, #1203772, #1214996)
  * Fix hud client-reconnects on the phone This branch fixes hud-
    clients's ability to seamlessly reconnect to HUD. (LP: #1205097)
  * g_simple_action_group_lookup() was deprecated. use
    g_action_map_lookup_action() instead.
  * Adjust watchdog test limits to get rid of random timing failures.
    (LP: #1215180)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 315
 -- Ubuntu daily release <email address hidden> Thu, 22 Aug 2013 18:12:30 +0000

Changed in hud (Ubuntu):
status: New → Fix Released
Albert Astals Cid (aacid) wrote :

Seems it was a hud bug only since after fixing it in the HUD side there's no change needed in the unity side to make it work.

Changed in unity8:
status: Triaged → Invalid
Ugo Riboni (uriboni) wrote :

The problem doesn't seem to be fully fixed.
I'm running JENKINS_BUILD saucy-39 on maguro, with hud package version 13.10.1+13.10.20130822.4-0ubuntu1

- boot the phone
- run camera app
- bring up the hud

no actions appear in the hud but they should.
If you type in any search terms, then remove them, all actions are correctly displayed.

Ugo Riboni (uriboni) on 2013-08-26
Changed in hud:
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed
Antti Kaijanmäki (kaijanmaki) wrote :

For some reason there is an oudated version of hud on the touch images. For now simply apt-get update && apt-get upgrade will fix the HUD issues.

Changed in hud:
status: Fix Committed → Fix Released
Ugo Riboni (uriboni) wrote :

Antti I am following your advice, but the upgrade didn't pull up any new version of the HUD.
The version I have now in today's image (saucy-49) is 13.10.1+13.10.20130822.4-0ubuntu1, and the hud still has the same problem as I mentioned before.

Bill Filler (bfiller) wrote :

I'm reopening this bug as it's not working in the touch image

Changed in hud:
status: Fix Released → Confirmed
Changed in hud (Ubuntu):
status: Fix Released → Confirmed
Antti Kaijanmäki (kaijanmaki) wrote :

the new branch fixes the issue with initial search results.

Changed in hud:
status: Confirmed → In Progress
Changed in hud (Ubuntu):
status: Confirmed → In Progress
Changed in hud:
assignee: Pete Woods (pete-woods) → Antti Kaijanmäki (kaijanmaki)
Changed in hud (Ubuntu):
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:hud at revision 319, scheduled for release in hud, milestone Unknown

Changed in hud:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hud - 13.10.1+13.10.20130918-0ubuntu1

---------------
hud (13.10.1+13.10.20130918-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * Handle searches that result in no tokens as NULL searches. (LP:
    #1193700)

  [ Antti Kaijanmäki ]
  * Fix search results when application starts and also include
    ALL_WINDOWS context on different searches. (LP: #1205097). (LP:
    #1205097)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 320
 -- Ubuntu daily release <email address hidden> Wed, 18 Sep 2013 07:10:50 +0000

Changed in hud (Ubuntu):
status: In Progress → Fix Released
Ted Gould (ted) on 2013-10-08
Changed in hud:
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2017-03-13
affects: unity8 → unity8 (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers