unity8 session doesn't necessarily have the proper QPA plugin set

Bug #1675437 reported by Ken VanDine on 2017-03-23
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Michał Sawicz
unity8-desktop-session (Ubuntu)
Critical
Michael Terry

Bug Description

In the new world of systemd, we don't always have the proper QPA plugin selected. We need to ensure QT_QPA_PLATFORM=ubuntumirclient in the unity8 desktop session.

Related branches

Michał Sawicz (saviq) on 2017-03-23
Changed in unity8-desktop-session (Ubuntu):
status: New → In Progress
assignee: nobody → Michał Sawicz (saviq)
assignee: Michał Sawicz (saviq) → Michael Terry (mterry)
importance: Undecided → Critical
Changed in canonical-devices-system-image:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Michał Sawicz (saviq)
milestone: none → u8c-z
tags: added: unity8-desktop
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8-desktop-session - 1.0.13+17.04.20170324-0ubuntu1

---------------
unity8-desktop-session (1.0.13+17.04.20170324-0ubuntu1) zesty; urgency=medium

  [ Michael Terry ]
  * Copy our upstart environment into dbus and systemd, making sure that
    activated services have the correct environment. (LP: #1675437)

 -- Ken VanDine <email address hidden> Fri, 24 Mar 2017 14:21:15 +0000

Changed in unity8-desktop-session (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2017-03-31
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers