Unity8/Mir: Bottom right area of touchpad no longer treated as right click

Bug #1603183 reported by fcole90 on 2016-07-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Low
Unassigned
Mir
Triaged
Low
Unassigned
gsettings-ubuntu-touch-schemas (Ubuntu)
Undecided
Lukáš Tinkl
libinput (Ubuntu)
Medium
Unassigned
mir (Ubuntu)
Low
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned
unity8-desktop-session (Ubuntu)
Medium
Unassigned
webbrowser-app (Ubuntu)
Undecided
Unassigned

Bug Description

Using the touchpad I was not able to trigger any right click (with a single finger in the bottom right area), and I tought it was a problem of how unity8 handled the right clicks. Instead I just tried with a mouse and right click trigger different actions from left clicks.

In the end the problem is that my touchpad right click is considered a left click by the system. This does not happen with an usb mouse.

Related branches

Stephen M. Webb (bregma) on 2016-07-14
Changed in unity8-desktop-session (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Daniel van Vugt (vanvugt) wrote :

Right click on Unity8 desktop -> duplicate of bug 1539957

Right click on webbrowser-app -> Works for me... In Ubuntu 16.10 I get a menu and can open links in a new page.

So let this bug be about the second issue. Seems to be invalid and/or fixed already.

Changed in webbrowser-app (Ubuntu):
status: New → Invalid
Changed in unity8 (Ubuntu):
status: New → Invalid
Changed in webbrowser-app (Ubuntu):
status: Invalid → Incomplete
Changed in unity8-desktop-session (Ubuntu):
status: Triaged → Incomplete
kevin gunn (kgunn72) on 2016-07-15
tags: added: unity8-desktop
Stephen M. Webb (bregma) wrote :

I do not get anything when I right-click in the webbrowser-app.

fcole90 (fcole90) wrote :

Neither do I, trying it on 16.10

fcole90 (fcole90) wrote :

Sorry, I don't think it's a duplicate of 1539957. I can't even right click on the launcher to pin apps for example.

OK, confirmed by comment #2. Although right click works fine for me (Unity8 in Ubuntu 16.10 desktop).

Changed in unity8-desktop-session (Ubuntu):
status: Incomplete → Confirmed
Changed in webbrowser-app (Ubuntu):
status: Incomplete → Confirmed
summary: - Right button doesn't trigger contextual menus
+ Right click in webbrowser-app doesn't do anything
fcole90 (fcole90) wrote :

When I do right click it is considered as a left click for me. This happens in the webbrowser-app too. If I right click a link, the browser follows the link. If I right click on the close button (in the window decoration) of an app, it gets closed. I'm definitely reporting a different bug. Should I open a different one?

Daniel van Vugt (vanvugt) wrote :

For a moment I hit the same bug. Then I realised it was user error:

Right click in webbrowser-app only works on links and text selections. Right clicking elsewhere on a page is apparently not meant to do anything (and on some pages like news.google.com will act like a left click).

fcole90 (fcole90) wrote :

It always work as a left click for me, even outside of the browser. Is there any scenario where a right click does a different action from left click, under unity8, that I can try to test if that's an input problem or just the way the system reacts to right clicks?

fcole90 (fcole90) wrote :

I just tryed again with a mouse connected and the right click actually works, so the problem happens only with the touchpad's right click.

summary: - Right click in webbrowser-app doesn't do anything
+ Right click from touchpad is handled as a left click
fcole90 (fcole90) on 2016-07-19
description: updated
tags: added: input
Olivier Tilloy (osomon) on 2016-07-19
Changed in webbrowser-app (Ubuntu):
status: Confirmed → Invalid

Just tried on the touchpad of my Dell XPS L502x (2012 model).

Its touchpad has physical left and right buttons. They work fine with the webbrowser app. The touchpad right click over a link opens a dialog, just like with the mouse.

Maybe it's a hardware-specific issue.

Daniel d'Andrada (dandrader) wrote :

From discussing with a colleague I assume you have a clickpad (no separate buttons, the whole touchpad is a single physical button). Updating title accordingly

summary: - Right click from touchpad is handled as a left click
+ Right click from clickpad is handled as a left click

Yes, it has no physical button

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mir (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

I've been testing right clicking in Unity8 and other Mir servers today and it works.

I'm using an Apple Magic Trackpad and of course using two fingers for a right click. Are you using two fingers or expecting the bottom right corner of your clickpad to do it with one finger?

Changed in mir (Ubuntu):
status: Confirmed → Incomplete
Changed in mir:
status: New → Incomplete
Changed in unity8-desktop-session (Ubuntu):
status: Confirmed → Incomplete
Lukáš Tinkl (lukas-kde) wrote :

I am expecting the bottom right corner of my clickpad to work since that always used to work until a few weeks ago.

fcole90 (fcole90) wrote :

I tried with the bottom right corner too.

summary: - Right click from clickpad is handled as a left click
+ Bottom right area of touchpad no longer treated as right click
Changed in mir:
status: Incomplete → Triaged
importance: Undecided → Medium
Changed in mir (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in unity8-desktop-session (Ubuntu):
status: Incomplete → Invalid
description: updated

I think this should be Low actually...

Like other modern platforms we should move to only using and expecting right click via two fingers, rather than designating the bottom right area (which only exists as paint, not in the electronics).

If you're using a modern clickpad it's really annoying in Unity7 that clicking in the wrong area on the clickpad does something different. Unity8/Mir should behave like macOS and ChromeOS in that you can only right click with two fingers by default.

Make it an option to use the bottom-right by all means (so keep this bug open), but I think we've got the default setting right...

Lukáš Tinkl (lukas-kde) wrote :

... except it never works unless you enable "Tap to click" in System Settings (which is off by default)

Changed in gsettings-ubuntu-touch-schemas (Ubuntu):
assignee: nobody → Lukáš Tinkl (lukas-kde)
status: New → In Progress
Changed in mir:
importance: Medium → Low
Changed in mir (Ubuntu):
importance: Medium → Low
Changed in canonical-devices-system-image:
status: New → Fix Committed
milestone: none → 13
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gsettings-ubuntu-touch-schemas - 0.0.7+16.10.20160730-0ubuntu1

---------------
gsettings-ubuntu-touch-schemas (0.0.7+16.10.20160730-0ubuntu1) yakkety; urgency=medium

  * Enable TouchpadTwoFingerScroll and TouchpadTapToClick by default
    (LP: #1603183, #1604032)

 -- Lukáš Tinkl <email address hidden> Sat, 30 Jul 2016 21:17:59 +0000

Changed in gsettings-ubuntu-touch-schemas (Ubuntu):
status: In Progress → Fix Released
Daniel van Vugt (vanvugt) wrote :

Weird. Another bug marked Fix Released or Committed when the actual code change hasn't landed yet(!?)

Changed in canonical-devices-system-image:
status: Fix Committed → In Progress
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Triaged, thanks to comment #18.

Upstream bug:
https://bugs.freedesktop.org/show_bug.cgi?id=105446

Changed in libinput (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in libinput:
importance: Unknown → Medium
status: Unknown → Confirmed
Daniel van Vugt (vanvugt) wrote :

Incomplete for libinput. I misread comment 18.

Is there still a bug at all?

no longer affects: libinput
Changed in libinput (Ubuntu):
status: Triaged → Incomplete

@vanvugt I think this is still a big problem lots of 16.04 -> 18.04 upgraders will run into.

This one blew my mind after installing 18.04 today. If this is going to be the new default, we need to warn users, because those of us not using Apple/ChromeOS hardware *expect* clickpads to work like they have for a decade now so it feels like an Ubuntu regression / issue.

The easier solution may be to do a little bit of hardware detection before Ubuntu configures this one for the users, and set the relevant hardware accordingly (Apple/ChromeOs->"fingers"; Dell/Lenovo/Etc->"areas").

Currently (18.04), the easy fix for this is to set:

    $ gsettings set org.gnome.desktop.peripherals.touchpad click-method areas

My bug 1767383 is almost certainly a dupe of this one (sorry, I was originally searching for it against the old driver), but I'll let someone else decide that.

Daniel van Vugt (vanvugt) wrote :

Libinput does not related to this bug.

Maybe see bug 1759300 instead.

Changed in libinput (Ubuntu):
status: Incomplete → Invalid
Daniel van Vugt (vanvugt) wrote :

This bug relates to Unity8 and Mir only.

Gnome Shell users please see bug 1759300 instead.

summary: - Bottom right area of touchpad no longer treated as right click
+ Unity8/Mir: Bottom right area of touchpad no longer treated as right
+ click
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.