Unity 8 Desktop Preview System Settings do not work on nouveau [ASSERT: "eglSwapBuffers(mEglDisplay, eglSurface) == EGL_TRUE" in file ../../../src/ubuntumirclient/glcontext.cpp, line 239]

Bug #1595238 reported by Hannie Dumoleyn on 2016-06-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
qtubuntu (Ubuntu)
Undecided
Unassigned
unity8-desktop-session (Ubuntu)
High
Unassigned

Bug Description

When I try to open System Settings, the Ubuntu logo keeps turning and nothing happens.
I installed unity8-desktop-session-mir on my Xenial 16.04.1 Desktop where I use NVIDIA driver GF108[GeForce GT 530]. I also created a new user account with English (US) language settings, because Unity 8 does not work well when I use my own account with my language settings.

Troubleshooting (what I did to find a solution):
Crash report:
Go to var/crash
var/crash/_usr_bin_unity8-dash.1000.crash
Title: unity8-dash crashed with SIGSEGV in QOpenGLContext::shareGroup()
UnreportableReason:
There are some older package versions installed on your system. Upgrade the following packages and see if the problem is still there:
 libglib2.0-0, libglib2.0-bin, libglib2.0-data
UpgradeStatus: No upgrade log present (probably fresh install)
_MarkForUpload: True

I installed these missing packages, but I still have the same problems:
System Settings do not work (ubuntu logo keeps spinning infinitely)
Browser does not work (I disabled my wired connexion and used wifi instead, but I cannot open Browser)
Terminal does not work (Control Alt T, or typing Terminal in Dash: nothing happens)

I tried NVIDIA GeForce GT 530 driver: result: lightdm freezes.
Using X.org X server - Nouveau works fine, at least I can open Unity 8 and see Indicators and Launcher.

I have written a log, I could publish it through Pastebin if it is any use to you. I would be grateful if someone can help me making Unity 8 work because I plan to write documentation for the Ubuntu docs.

Stephen M. Webb (bregma) wrote :

Thanks for trying the Unity 8 desktop session and reporting problems. This is an invaluable service.

The proprietary nVidia video driver does not yet support the Mir display server, so you will need to use the free nouveau video driver with nVidia hardware at this time. We hop to have the video support problem resolved in the near future.

For the Systems Settings problem, it would help if you could attach the file ~/.cache/upstart/application-legacy-ubuntu-system-settings-.log to this bug after experiencing the problem. That log file should contain the output from the Systems Settings application, including any diagnostics it might emit.

For the Browser problem, the log file is ~/.cache/upstart/application-legacy-webbrowser-app-.log and can also be attached to this bug.

For a terminal, a Unity8-compatible terminal is not installed by default and from what I can see, is only available for ARM architectures.

Changed in unity8-desktop-session (Ubuntu):
status: New → Triaged
importance: Undecided → High

Hmmm. In ~/.cache/upstart there are lots of files with .log.gz extension, but no application-legacy-ubuntu-system-settings-.log.gz or application-legacy-webbrowser-app-.log.gz. With beginning letter "a" I only see this: ~/.cache/upstart/at-spi2-registryd.log.gz
What I do have is /var/crash/_usr_bin_unity8-dash.1000.crash, _usr_bin_unity8-dash.1000.upload, _usr_bin_unity8-dash.1000.uploaded, _usr_lib_ibus__ibus-ui-gtk3.1000.crash, _usr_lib_x86_64-linux-gnu_bamf_bamfdaemon.1000.crash and _usr_share_apport_apport-gtk.1001.crash.
Do you want me to attach any of these? I used the unity8-dash.1000.crash in my troubleshooting comment above.
In my troubleshooting comment I mentioned that NVIDIA driver causes a lightDM freeze, and that X.org nouveau works well. Graphically (Mir?) I encounter no problems. It is very, very fast indeed.
The spinning Ubuntu logo when trying to open System Settings or Web Browser: in my view this means the program is looking for certain files which it cannot find. Unfortunately, I cannot find the right .log file.
As for the Terminal: I tried to install one, but in the Ubuntu Store I keep getting the message: Download or install error.
Does Unity 8 (network manager) not support a wired connection? I disable my wired connection when starting Unity 8.

Would the attached log files help? I added the Stable Phone Overlay PPA to my resources, but I still have no working System Settings or Browser (Ubuntu logo keeps spinning).

Stephen M. Webb (bregma) wrote :

Hmm, Unity 8 run, I see an attempt to start the apps i the log, but no log file... possibly a confinement issue.

There was an issue with the cgroup manager process not starting before 16.04 was initially released. Try installing the package libpam-cgfs and logging out and back in (which is required to get in to Unity 8 anyway) and see if that resolves the problem.

System Settings work after reinstall Unity8, but webbrowser-app causes serious crash.
From crash report 1:
webbrowser-app 0.23+16.04.20160701.1-0ubuntu1 [origin: unknown]
webbrowser-app crashed with SIGABRT in __assert_fail_base(). This is not an official Ubuntu package.
crash report 2:
webbrowser-app crashed with SIGSEGV in nouveau_pushbuf_kick(). SegvReason: reading NULL VMA.

I attach a screenshot of part of the crash report which was sent to Ubuntu (Apport). If you want more screenshots, let me know.

Daniel van Vugt (vanvugt) wrote :

bregma: Note comment #7 and in previous comments, it sounds more like nouveau is in use. If the Nvidia proprietary driver was in use you would not ever even get to opening System Settings in Unity8 :)

Yes, I use nouveau: Using X.Org X server - Nouveau display driver from xserver-xorg-video-nouveau (open source). Sorry for the confusion in the description of this bug report.

Now that I have reinstalled Unity8, I noticed that the log file you mentioned earlier is present in ~/.cache. I pasted log.2 and log.3 in log.1, see attached file.

Daniel van Vugt (vanvugt) wrote :

Not triaged. Comment #2 was mistaken.

Changed in unity8-desktop-session (Ubuntu):
status: Triaged → New
summary: - Unity 8 Desktop Preview System Settings do not work
+ Unity 8 Desktop Preview System Settings do not work on nouveau [ASSERT:
+ "eglSwapBuffers(mEglDisplay, eglSurface) == EGL_TRUE" in file
+ ../../../src/ubuntumirclient/glcontext.cpp, line 239]
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtubuntu (Ubuntu):
status: New → Confirmed
Changed in unity8-desktop-session (Ubuntu):
status: New → Confirmed
tags: added: unity8-desktop
tags: added: nouveau

After having upgraded to 16.10 (from Xenial), I get an internal error: /usr/lib/packagekit/packagekitd, crashed on SIGSEGVin_dynamic_cast(), packagekit 0.8.17-4ubuntu6~gcc5.4ubuntu1.1.
Since I am fed up with all these problems I am going to reinstall Xenial, and maybe Yakkety after that. I would have liked Unity8 to work on my PC, so that I could test it before writing documentation for ubuntu-docs.

I have reinstalled Xenial and then upgraded to Yakkety. The (web) browser causes a serious crash after opening it in Unity8. I cannot even use ctrl-alt-del and I have to do a cold start. On top of that, in Unity7 this corrupted (web) browser has replaced my standard web browser Firefox. I will send in a separate bug report for Unity8 in Yakkety because this thread is about other problems in Xenial.

Daniel van Vugt (vanvugt) wrote :

Actually comment #7 suggests you're experiencing the same nouveau instability as other people; see bug 1553328. So I'll make this a duplicate of that.

If you continue to experience other issues like "ASSERT: eglSwapBuffers..." then please un-duplicate this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers