Keyboard layout is not respected in some places

Bug #1583802 reported by Guillaume F on 2016-05-19
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mir (Ubuntu)
unity8 (Ubuntu)
unity8-desktop-session (Ubuntu)

Bug Description

I'm trying Unity8 on my desktop (and reporting bugs from there, cool!), I've followed Michael Hall's how to, so I have the same PPAs on my system.

The keyboard layout is not the same everywhere in the OS. I switched to French and it works in most places, but in some others, an English keyboard persists. These other places include the greeter and the Online Accounts (the rest of the System Settings app seems fine). I'm not sure where else but I'll keep searching.

I have to say, it has its advantages, since alt-gr does not work and I have to copy/paste things like "@"!

Thanks for your great work, it's really exciting to see the progress!

Daniel van Vugt (vanvugt) wrote :

Thanks for your bug report. I suspect we already have two open bugs covering the issues you describe:

1. Xmir apps don't respect the keyboard layout -> bug 1566487

2. AltGr does not work -> bug 1565236

Is that everything?

Changed in unity8-desktop-session (Ubuntu):
status: New → Incomplete
Guillaume F (marsguo) wrote :

No, I don't think those are the same bugs, since (as far as I know) the greeter and the online accounts are not Xmir apps. I haven't tried libertine on the desktop yet. And altgr sure doesn't work, but I already saw that on my tablet and on launchpad.

So far I've only encountered this behaviour in the greeter and the online accounts (google, ubuntu one, haven't tried the others).

Daniel van Vugt (vanvugt) wrote :

Bug 1565236 applies to Mir and Unity8-everything. Not Xmir :)

Are you saying you're experiencing problems without using AltGr?

Guillaume F (marsguo) wrote :

Yes, maybe my bug report wasn't very clear…

I use the French (AZERTY) layout, and it works fine most everywhere. However, when I type my password in the greeter or my email address for registering my Ubuntu/Google online account in System Settings, the keyboard goes back to QWERTY. I've just tried it on my tablet and I can't reproduce it, so it seems to be desktop-specific…

Actually, I only mentioned the AltGr problem because I can't write "@" in AZERTY because of it, which is problematic, but since the layout seems to be different in online accounts, I was able to do it anyway since "@" is more accessible on the QWERTY layout!

Guillaume F (marsguo) wrote :

Should this bug still be considered as a duplicate? This has nothing to do with AltGr.

summary: - Keyboard layout is not respected is some places
+ Keyboard layout is not respected in some places
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mir (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Guillaume F (marsguo) wrote :

I've just realised that this is extremely problematic on the tablet: when you set a password to unlock, it will seem to not work in the greeter because the greeter is stuck in QWERTY...

Guillaume F (marsguo) wrote :

Well, I seem to be alone with this problem, but today I found that the password prompt for connecting to a WiFi source is also affected and stuck in QWERTY. Strangely enough, it is not the case with the whole "hidden network" form: there, I can type my password in AZERTY quite normally. (I was forced to cheat and connect to my network with the "hidden network" feature, since the regular password prompt didn't work. Probably another bug though).

Changed in mir:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers