No longer need to reference "Mir" in the session name since it is implied

Bug #1376715 reported by Christopher Townsend on 2014-10-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity8-desktop-session
Low
Stephen M. Webb
unity8 (Ubuntu)
Low
Stephen M. Webb
unity8-desktop-session (Ubuntu)
Low
Stephen M. Webb

Bug Description

In packaging unity8-lxc, Robert Ancell made a strong suggestion that any references to Mir in the session name should be removed since it is implied. He made that change in lp:unity8-preview-lxc and we should do that for this project to be consistent.

Instead of it saying "Unity8-Mir", it should say "Unity 8".

Also related, the unity8-desktop-session-mir package should be named unity8-desktop-session.

Related branches

description: updated
Changed in unity8-desktop-session:
importance: Undecided → Low
Changed in unity8-desktop-session (Ubuntu):
importance: Undecided → Low
Changed in unity8-desktop-session:
status: New → Confirmed
Changed in unity8-desktop-session (Ubuntu):
status: New → Confirmed
Stephen M. Webb (bregma) on 2016-02-08
Changed in unity8-desktop-session:
assignee: nobody → Stephen M. Webb (bregma)
status: Confirmed → In Progress
Changed in unity8-desktop-session (Ubuntu):
assignee: nobody → Stephen M. Webb (bregma)
status: Confirmed → In Progress
description: updated
Changed in unity8 (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Stephen M. Webb (bregma)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.12+16.10.20160617-0ubuntu1

---------------
unity8 (8.12+16.10.20160617-0ubuntu1) yakkety; urgency=medium

  [ Michael Terry ]
  * Do not create Label/Icon if we don't need it
  * Fix Z-ordering of prompt surfaces (LP: #1586219)
  * Drop bottom edge tutorials completely and small fixes for other
    edges. (LP: #1565103)
  * Redo visuals for greeter prompt box. (LP: #1435923)
  * Make tutorial qmltests more robust. (LP: #1590810)
  * Stop showing an extra lockscreen in desktop unity8 sessions. (LP:
    #1582987)

  [ Albert Astals Cid ]
  * Improve dash plugin mock
  * Stabilize PreviewExpandableTest::test_all_widgets_height
  * Workaround QTBUG-53460
  * Split artShape code for cardTool card and regular card
  * Simplify the code since fixedArtSize code is mandatory for regular
    cards
  * Desktop stage: Support rotatesWindowContents (LP: #1547481)
  * Turn if if else into if elseif else
  * Fix leaks in QInputDeviceManagerPrivate::addDevice
  * Do not call |= on uninitialized sigterm.sa_flags
  * initialize udevMonitor
  * Make notifier and notifierFd function local variables
  * Fix crash if a component that is not an Item is given to
    sectionDelegate
  * Tests: Do not use dynamic_cast if we're not going to test it anyway
  * Minor coverity fixes
  * Fix warning about anchors.fill in ProportionalShape (LP: #1590963)
  * Make wait in cleanup() wait for snapTo animation to have finished

  [ Alexandros Frantzis ]
  * Improve the way notifications interact with power management (LP:
    #1570922)

  [ Andrea Cimitan ]
  * Correctly refresh cardcreator cache on artshapestyle changes (LP:
    #1588335)
  * Same tweaks we have for click scope now for libertine
  * add a timer to pull to refresh to work on small windows (LP:
    #1589060)

  [ Daniel d'Andrada ]
  * Clean up debug leftovers
  * Ensure mouse and window movement are pixel-aligned (LP: #1510382)
  * Fix SpreadDelegate rotation animations
  * No point in version-controlling files that are automatically
    generated
  * Center cursor on screen when it's first shown
  * Custom cursor name just have to start with "custom"
  * Work around AnimatedSprite infinite loop bug (LP: #1588929)

  [ Josh Arenson ]
  * Disable showDash when it is already shown. (LP: #1506708)
  * Add a timestamp to the dash log (LP: #1580074)
  * Add timestamp to unity8 log (LP: #1498169)

  [ Lukáš Tinkl ]
  * Implement keyboard shortcuts info panel
  * Implement window controls overlay activatable with 3 fingers tap
    (LP: #1489020)
  * Select correct Chinese input method for OSK in the wizard (LP:
    #1588633)

  [ Michael Zanetti ]
  * Add support for the launcher surface pips displaying the correct
    number of surfaces
  * Add support for the persistent alert state. (LP: #1575147, #1584348,
    #1586621)
  * send a Alt-release event on alt+tab instead of delaying it
    completely and invoking it later (LP: #1565236)

  [ Stephen M. Webb ]
  * added a new upstart $SESSION for unity8-desktop-session (LP:
    #1376715)

 -- Michael Terry <email address hidden> Fri, 17 Jun 2016 01:22:57 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2016-06-18
Changed in unity8-desktop-session:
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8-desktop-session - 1.0.13+16.10.20160610-0ubuntu1

---------------
unity8-desktop-session (1.0.13+16.10.20160610-0ubuntu1) yakkety; urgency=medium

  [ Stephen M. Webb ]
  * Removed the now-redundant -mir for package and asset names.
  * renamed package to remove the redundant '-mir' in the name (LP:
    #1376715)

 -- Christopher Townsend <email address hidden> Fri, 10 Jun 2016 15:17:29 +0000

Changed in unity8-desktop-session (Ubuntu):
status: In Progress → Fix Released
Changed in unity8-desktop-session:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2016-07-30
Changed in unity8-desktop-session:
milestone: none → 1.0.12
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers