Keyboard input focus sometimes wrong in unity8-desktop-session-mir

Bug #1322116 reported by Michael Vogt on 2014-05-22
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
qtmir (Ubuntu)
High
Josh Arenson
unity8 (Ubuntu)
Undecided
Unassigned
unity8-desktop-session (Ubuntu)
Undecided
Unassigned

Bug Description

I use the unity8-desktop-session-mir with my regular desktop and noticed that for some apps the keyboard input focus is wrong.

I can reproduce this with the following steps:
- use click to install "Uberbag" and "Light Off"
- start "Light Off" first, it goes into the right side corner of the screen as a "side app" (sorry, don't know the correct term)
- start "Uberbag" it has a (web?) based input to login
- click on the "Username or email" field of the app and start typing
- watch that no input arrives in the "uberbag" window
- move the "side-panel" away (to the right corner so that it vanishes)
- now the keyboard input enters the "uberbag" application

tags: added: ubuntu-desktop-next
tags: removed: ubuntu-desktop-next
Sebastien Bacher (seb128) wrote :

The "sometimes" seems to specific to the right-side-bar use, when a phone application is running on the side the main context is not able the get the input

Michał Sawicz (saviq) wrote :

I imagine this is definitely related to the side stage, 'cause only one of them can has keyboard focus, and we're probably not refocusing the main stage app when you click on it ('cause it doesn't matter for touch input).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-mir (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in unity8-desktop-session (Ubuntu):
status: New → Confirmed
kevin gunn (kgunn72) wrote :
no longer affects: unity-mir (Ubuntu)
kevin gunn (kgunn72) wrote :

@josh - feel free to dup 1354564 with this one, when you start looking into it

Changed in qtmir:
assignee: nobody → Josh Arenson (josharenson)
status: New → Triaged
importance: Undecided → High
Changed in unity8 (Ubuntu):
status: Confirmed → Opinion
Changed in qtmir:
status: Triaged → In Progress
tags: added: unity8-desktop
Josh Arenson (josharenson) wrote :

With latest devel-propsed branch (with shell rotation enabled on a nex7) I can't reproduce this. An unrelated issue is that the keyboard is so large in landscape mode, that I can't see what I'm typing into the Uberbag app until I close it though.

Changed in qtmir:
status: In Progress → Invalid
Josh Arenson (josharenson) wrote :

I realized that this is desktop session, and since I can't actually get these apps to download at the moment, I'll keep investigating.

Changed in qtmir:
status: Invalid → In Progress
Michał Sawicz (saviq) on 2017-03-13
affects: qtmir → qtmir (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers