Mir cursor is missing/invisible until the client sets it multiple times

Bug #1308133 reported by DonnieD on 2014-04-15
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Alan Griffiths
mir (Ubuntu)
High
Unassigned
unity8-desktop-session (Ubuntu)
Medium
Unassigned

Bug Description

Mir cursor is missing/invisible until the client sets it multiple times

Related branches

DonnieD (donnied) on 2014-04-16
tags: added: trusty
Stephen M. Webb (bregma) on 2014-04-16
summary: - Hardware cursor not shown
+ Unity 8 Desktop Preview: Hardware cursor not shown
Changed in unity8-desktop-session (Ubuntu):
status: New → Triaged
importance: Undecided → Medium

If any Log data is needed just ask :]

Daniel van Vugt (vanvugt) wrote :

This is possibly going to be a duplicate of bug 1216515. We should perhaps look into that first.

tags: added: cursor
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mir (Ubuntu):
status: New → Confirmed

Confirmed in Xmir. I've even gone to the trouble of printing the cursor in ASCII as it is sent to Mir, but Mir (demo servers) displays no cursor.

summary: - Unity 8 Desktop Preview: Hardware cursor not shown
+ Mir cursor is missing/invisible despite definitely being set by the
+ client
Changed in mir:
status: New → Confirmed
tags: added: xmir
description: updated
Changed in mir:
importance: Undecided → High
Changed in mir (Ubuntu):
importance: Undecided → High
Alexandros Frantzis (afrantzis) wrote :

Perhaps this is related to https://bugs.launchpad.net/mir/+bug/1496849 "Mouse cursor disappears upon entering the surface area of a nested client"?

Daniel van Vugt (vanvugt) wrote :

It may be related but this one and bug 1418071 show the cursor goes missing even without using nesting.

Although a nested server is a client and will probably suffer from the same bug, I don't think the problem is specific to nesting.

Daniel van Vugt (vanvugt) wrote :

Found a workaround that solves the issue in Xmir: Just ask Mir to set the cursor three times. Then it will finally appear on screen.

summary: - Mir cursor is missing/invisible despite definitely being set by the
- client
+ Mir cursor is missing/invisible until the client sets it multiple times
description: updated
description: updated
Changed in mir (Ubuntu):
assignee: nobody → Alan Griffiths (alan-griffiths)
status: Confirmed → In Progress
status: In Progress → Confirmed
assignee: Alan Griffiths (alan-griffiths) → nobody
Changed in mir:
status: Confirmed → In Progress
assignee: nobody → Alan Griffiths (alan-griffiths)
Changed in mir:
milestone: none → 0.17.0
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.17.0

Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
status: Fix Committed → Fix Released
Changed in mir (Ubuntu):
status: Confirmed → Fix Released
no longer affects: unity-system-compositor
Changed in mir (Ubuntu):
status: Fix Released → Triaged
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package mir - 0.17.0+15.10.20151008.2-0ubuntu1

---------------
mir (0.17.0+15.10.20151008.2-0ubuntu1) wily; urgency=medium

  [ Alexandros Frantzis ]
  * New upstream release 0.17.0 (https://launchpad.net/mir/+milestone/0.17.0)
    - ABI summary: Only servers and graphics drivers need rebuilding;
      . Mirclient ABI unchanged at 9
      . Mirserver ABI bumped to 35
      . Mircommon ABI unchanged at 5
      . Mirplatform ABI bumped to 11
      . Mirprotobuf ABI bumped to 3
      . Mirplatformgraphics ABI bumped to 6
      . Mirclientplatform ABI unchanged at 3
    - Enhancements:
      . Introduce libmircookie, a simple mechanism for a group of cooperating
        processes to hand out and verify difficult-to-forge timestamps to
        untrusted 3rd parties.
      . More refactorings to support renderers other than GL.
      . Add MirBlob to the client API - a tool for serializing and
        deserializing data.
      . Introduce a libinput based input platform, not yet used by default.
      . Provide a mechanism for the shell to send events on surface
        construction.
      . Provide mir::shell::DisplayConfigurationController allowing shells
        to correctly change the display configuration, notifying clients
        as appropriate.
      . New DSO versioning guide.
      . Send events pertaining to the output a surface is currently on (dpi,
        form factor, scale) to clients.
    - Bug fixes:
      . [enhancement] XMir specific documentation should live in its own
        subsection (LP: #1200114)
      . Nested servers need cursor support (LP: #1289072)
      . Mir cursor is missing/invisible until the client sets it multiple
        times (LP: #1308133)
      . [regression] Fullscreen software surfaces (like Xmir -sw) can crash
        the Mir server (LP: #1493721)
      . [usc] Mir gives up and shuts down due to input with multimonitor qtmir
        (std::exception::what: Failure sending input event) (LP: #1496069)
      . Mouse cursor disappears upon entering the surface area of a nested
        client (LP: #1496849)
      . [android] input is not dispatched when attaching an external monitor
        (LP: #1498045)
      . [android] input coordinates are scaled incorrectly when an external
        display is connected (LP: #1498540)
      . [android] std::exception::what: error during hwc set() when unplugging
        external monitor (LP: #1498550)
      . tests do not compile without precompiled headers (LP: #1498829)
      . [android] std::exception::what: Failed to monitor fd: Operation not
        permitted when unplugging external display in a nested configuration
        (LP: #1499042)
      . Mir suddenly no longer builds since 'mesa (11.0.0-1ubuntu1) wily':
        /usr/include/EGL/eglplatform.h:100:35: fatal error:
        android/native_window.h: No such file or directory (LP: #1499134)
      . [android] various crashes when unplugging external display on a
        nested configuration (LP: #1501927)
      . Cursor becomes visible by itself when an external monitor is connected
        (LP: #1502200)
      . mesa FTBFS due to missing Requires in mirclient (LP: #1503450)

  [ CI Trai...

Read more...

Changed in mir (Ubuntu):
status: Triaged → Fix Released
Changed in unity8-desktop-session (Ubuntu):
status: Triaged → Fix Released
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers