No launcher icon or Alt+Tab entry for Scribus windows

Bug #999171 reported by Paddy Launch on 2012-05-14
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Marco Trevisan (Treviño)
5.0
Fix Released
Undecided
Marco Trevisan (Treviño)
unity (Ubuntu)
Undecided
Marco Trevisan (Treviño)

Bug Description

I have tested this with a Guest account using the standard Unity settings.

Steps to reproduce:

1. Start Scribus from the Dash
2. Click OK on the Scribus Dialog.
3. Maximize the Scribus window.
4. Close Scribus.
5. Restart Scribus from the Dash & OK the Dialog.
6. Close Scribus.
7. Restart Scribus from the Dash & OK the Dialog.
8. Now Scribus icon appears in Unity launcher then immediately disappears, and will never appear again, no matter how often the application is relaunched.

Expected behaviour - Scribus icon visible in Unity launcher.

Actual behaviour - Scribus icon fails to appear in Unity launcher, and Scribus application thus appears to be completely divorced from the Unity desktop (e.g. cannot be reached even by Alt-Tabbing)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.12-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,compiztoolbox,regex,resize,imgpng,move,grid,snap,unitymtgrabhandles,animation,mousepoll,place,vpswitch,gnomecompat,wall,session,workarounds,expo,fade,ezoom,scale,unityshell]
Date: Mon May 14 15:40:39 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Paddy Launch (paddylaunch) wrote :
Paddy Launch (paddylaunch) wrote :

Locking the Scribus icon to the launcher is a workaround.

description: updated
summary: - scribus becomes divorced from unity launcher
+ running application (scribus) disappears from unity launcher
summary: - running application (scribus) disappears from unity launcher
+ No launcher icon or Alt+Tab entry for Scribus windows
Daniel van Vugt (vanvugt) wrote :

See also:
Bug 995916: No launcher icon or Alt+Tab entry for Gimp windows
Bug 999171: No launcher icon or Alt+Tab entry for Scribus windows
Bug 762193: No launcher icon or Alt+Tab entry for xchat/xchat-gnome windows
Bug 951929: Unity launcher and Alt-Tab switcher missing entry for gnome-terminal

I hope they're all the same bug, but we won't really know until a fix is proposed.

Changed in unity:
milestone: none → 5.14.0

Same problem with me with a normal account.
No launcher icon or Alt+Tab entry for Gimp windows
&
No launcher icon or Alt+Tab entry for Scribus windows

(screen capture in attachment)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: New → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Triaged
milestone: 5.14.0 → 6.0
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-07-10
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers