Dual monitor sticky edges are still enabled when turned off in display manager and Launcher placement is "All Displays"

Bug #990032 reported by takamarou on 2012-04-27
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Fix Released
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

See also: bug 987787

Release: Ubuntu 12.04 LTS
Unity Version: 5.10.0-0ubuntu6
Expected: Sticky edges turns off when the switch is set to Off
Actual: Sticky edges remains on regardless of switch position

I've got two dual monitors running as an extended desktop. By default the Launcher placement property is set to "All Displays" and sticky edges is set to "On".

I like having the launcher on both desktops, but sticky edges is driving me nuts. So, naturally, I turned off sticky edges and left the launcher on all displays. Unfortunately, it seems that the On/Off switch for sticky edges serves no purpose when Launcher Placement is set to "All Displays".

The option to disable sticky edges in this scenario should be allowed, or at the very least the On/Off switch should be disabled and forced to "On" as to not confuse the user.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.10.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
ApportVersion: 2.0.1-0ubuntu6
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,imgpng,move,unitymtgrabhandles,snap,regex,resize,gnomecompat,animation,place,session,vpswitch,workarounds,grid,mousepoll,expo,wall,ezoom,fade,scale,unityshell]
Date: Fri Apr 27 14:07:34 2012
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-04-27 (0 days ago)

takamarou (takamarou) wrote :
Daniel van Vugt (vanvugt) wrote :

It looks like this should have been fixed in unity 5.10 (bug 961285).

Sebastien Bacher (seb128) wrote :

Thanks, in fact that's how it has been designed I think, launchers are always sticky, the option only impact on the screen barrier if you cross a border which has no launcher

Changed in unity (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Changed in unity:
status: New → Incomplete
importance: Undecided → Low
Daniel van Vugt (vanvugt) wrote :

Hmm, feels almost like a regression of bug 961285 to me.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in unity:
importance: Low → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
description: updated
Daniel van Vugt (vanvugt) wrote :

See also: bug 987787

John Lea (johnlea) wrote :

I have re-tested, and am pretty sure this bug is fixed, so marking fix released.

Changed in ayatana-design:
status: New → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Unfortunately, this is still a bug using the latest lp:unity code for me.

Changed in unity:
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Brandon Bertelsen (bbertelsen) wrote :

I'm not sure if this is a bug, rather than a setting being set too high by default. The intuitive behaviour would be for the user to move across from screen to screen. Setting the default stop velocity at 65 is fairly high. Something in the 10-20 range seems to feel more in line with natural expectation.

There's a preference that you can edit to "adjust" (notice I didn't say fix) this in gconf-editor, via: http://askubuntu.com/a/109744

Jakob Runge (jakobrunge) wrote :

I have the same problem on 12.04.1 LTS. I have an Laptop screen and external monitor with Launcher Placement to Laptop and the sticky edged button on/off has no effect. Then I temporarely changed Launcher Placement to All Displays and then back again to Laptop and now the edges are finally not sticky anymore...

Seems like a bug to me!

John Lea (johnlea) wrote :

@jakobrunge; do you have the Launcher locked out or set to autohide? I just retested with 12.04, and when the Launcher is locked out and sticky edges set to off, there are no sticky edges.

However if the Launcher is set to autohide, setting sticky edges to off switches off all the sticky edges with the one exception of catching the pointer when it travels from right to left across monitors in order to reveal the auto-hidden Launcher (otherwise it would be impossible to reveal the Launcher). This is the correct behaviour.

Are you seeing either of the two behaviours described above or something else?

I am closing this bug for now, but will re-open if it turns out there is a bug with this behaviour.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released

I had the same problem as @jakobrunge, and solved it by setting All Settings > Displays > Launcher placement to "Laptop" (the edge which is not between both displays).

So I confirm that either it's not a bug but a feature, either it is a real bug which can be easily avoided.

@johnlea: well, there is one problematic case: if the launcher is set to autohide and it's placed only on one screen, edges shouldn't be sticky.

For example, i have autohidden launcher on the left edge of my laptop screen (with an external display positioned to the right of the laptop, see attached). There should be no sticky edges in this situation, but for me the edge is sticky when travelling leftwards - and it's driving me nuts!!

msp3k (peek-nimbios) wrote :

This bug has resurfaced for me in 16.04.1 LTS. However, I cannot confirm that restricting the launcher to a single screen prevents the stickiness, as changing the launcher placement has no effect. This is another bug that I will file separately.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers