Comment 66 for bug 988079

Thanks Daniel, that's very helpful. We would love to test it once you have
the backported patches ready. Is it planned to backport all the bugfixes
mentioned in the changelog, or only some of them? (If only some, is there a
list available of which are targeted?)

On Mon, Jul 16, 2012 at 6:48 PM, Daniel van Vugt <
<email address hidden>> wrote:

> Thomas: We plan to backport the changes to Unity 5.x for precise in the
> coming weeks, after no further related issues are found by Unity 6.0
> users.
>
> This means the change will definitely hit precise by 12.04.2, possibly
> in time for 12.04.1. However I'll publish a PPA for precise testing
> before then.
>
> --
> You received this bug notification because you are a member of Goobuntu
> Team, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/988079
>
> Title:
> Much slower OpenGL frame rates with unityshell loaded, than plain
> compiz
>
> Status in Unity:
> Fix Released
> Status in unity 5.0 series:
> Triaged
> Status in “unity” package in Ubuntu:
> Fix Released
> Status in “unity” source package in Precise:
> Confirmed
>
> Bug description:
> The main problem is that OpenGL apps run slower with unityshell
> compared to plain compiz (Gnome Classic).
>
> In extreme cases, running glmark2 under Unity only achieves 0-3 FPS.
> Yet on the same machine reports frame rates of several hundred FPS in
> Gnome Classic. See comments #28-#30.
>
> In other cases, game performance is OK but still visibly worse under
> Unity. ioquake3 drops in frame rate by around 20% in Unity compared to
> plain Compiz in Gnome Classic (see duplicate bug 1005074).
>
> ORIGINAL DESCRIPTION:
> On my Z600, with a fresh Precise installation, after installing the
> NVIDIA driver 295.40 (same version as in gPrecise), glxgears runs extremely
> slowly full-screen. When running on Precise, Chrome's GPU accelerated
> rendering path produces correct results, albeit extremely slowly.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/988079/+subscriptions
>