massive memory leak in unity-panel-service and hud-service when invoking the hud on Firefox profiles with large amounts of bookmarks LTS 12.04 14.04

Bug #987060 reported by Roland (Rolandixor) Taylor on 2012-04-23
648
This bug affects 139 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Confirmed
High
Unassigned
Unity
Won't Fix
High
Andrea Azzarone
Unity HUD
Confirmed
Critical
Unassigned
firefox (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
hud (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
unity (Ubuntu)
Critical
Unassigned
Xenial
Critical
Unassigned

Bug Description

unity-panel-service and hud-service quickly racks up memory and CPU usage until I kill it when invoking the HUD on Firefox. It's taking anywhere from a few minutes to half an hour, but it sometimes makes the system completely unusable.

1. run Firefox 12.0 in the foreground
2. hit Alt to bring up HUD
3. type any text
4. select one proposal from HUD
5. wait for unity-panel-service and hud-service to fill up the remaining RAM and swap space.

This is due to a high number of bookmarks in a user profile (hundreds).

Tags: hud Edit Tag help
Thomas Richter (tomri2012) wrote :

Same problem here. hud-service and unity-panel-service reach several hundred megs of RAM within hours.
Particularly so if I'm actually using the HUD. A couple of times is enough and I'm at 700meg.

I'm on a fresh install of 12.04.

Tried #unity --reset.

Have System Load Indicator applet running.

Tom

P.S. How can Ubuntu release such a crap? Do they think people prefer eye candy and tracking software over stability and usability???

Thomas Richter (tomri2012) wrote :

Did some more testing; problem is reproducibel as follows:
1. run Firefox 12.0 in the foreground
2. hit Alt to bring up HUD
3. type any text
4. select one proposal from HUD
-repeat as needed

Observation: Firefox takes long to execute selected command. Both a.m. services jump up in memory usage by several hundred megs.

Thomas Richter (tomri2012) wrote :

Some more information:
Problem occurs only with Firefox and only with *my* profile.
I created a new empty profile and the problem was gone.
After migrating all bookmarks and user.js to the new profile, problem is there again.
Disabling all extensions in FF does not help. So it must be one of my settings (maybe in user.js) that is causing the problem.

In any case, the dash/hud should not be so fragile that memory leaks are caused by specific application settings.
Such tight coupling between applications and OS or desktop seems to be problematic.
If you can't control it, better skip the eye candy and stick with simpler solutions....

Tom

I have another user account on my desktop which has no problem with unity. After she uses the hud it's only a matter of time until hud-service and unity-panel-service tries to fill up all 8 gigs of RAM. Firefox is what's used when it happens.

summary: - memory leak in unity-panel-service
+ memory leak in unity-panel-service and hud-service
Changed in unity:
status: New → Confirmed
summary: - memory leak in unity-panel-service and hud-service
+ massive memory leak in unity-panel-service and hud-service on certain
+ Firefox Profiles
summary: - massive memory leak in unity-panel-service and hud-service on certain
- Firefox Profiles
+ massive memory leak in unity-panel-service and hud-service when invoking
+ the hud oncertain Firefox Profiles
affects: unity → unity (Ubuntu)
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
status: New → Confirmed
summary: massive memory leak in unity-panel-service and hud-service when invoking
- the hud oncertain Firefox Profiles
+ the hud on certain Firefox Profiles
description: updated
description: updated

Gah, I meant to say that my profile normally has no problem with the hud. I have set up another account for someone to use and she's having the issue on her profile (it's a bit old).

Also, the repeated summary changes are because of launchpad's irritating bug where the text input box doesn't expand as the title becomes multi-line so I have to blindly guess what I'm editing. Apologies for the noise.

Changed in unity (Ubuntu):
status: Confirmed → Triaged
Omer Akram (om26er) wrote :

Could you remove indicator-multiload seems it unity doesnt play good with it. Also right now I am trying to create the memleak but seems things work quite fine for me.

Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in unity:
importance: Undecided → High
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Triaged → Incomplete

I do not use indicator-multiload.

In terms of using valgrind, would the following be appropriate?

G_SLICE=always-malloc G_DEBUG=gc-friendly valgrind -v --tool=memcheck --leak-check=full --num-callers=40 --log-file=valgrind.log compiz --replace

Daniel van Vugt (vanvugt) wrote :

This sounds directly related to bug 1005174.

Omer Akram (om26er) on 2012-05-29
tags: added: hud

Sorry for the late reply. I do have indicator-multiload, so I think that
might add to my issue.

Part of the reason I have not replied faster is that Firefox Nightly and
Thunderbird Nightly have had a nasty memory leak themselves (yeah sucks) -
so I had trouble getting my mail while I tried to get that sorted.

Confirmed by duplicates.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
peter (peter-beetlebolt) wrote :

I was also seeing really high cpu usage for firefox and hud-service for certain firefox profiles. I found disabling firefox's global menubar extension aleviated the issue. I'm suspicious it's a conflict between firefox extensions (addons).

for me, my firefox 14.0 simply crashes when I open it, go to HUD, and type text. Selecting anything isnt needed either.

But that might be because I have just 100MB of free ram, and as soon as it bloats and starts swapping, the firefox crashes.

Colin Law (colin-law) wrote :

Bhaavan have you got firebug installed in firefox? If so you are seeing a different bug #1025011. But it could also be the RAM issue. If you have firebug then disable it.

Hi, it appears (based on duplicate comments) that this is dealing with huge amounts of bookmarks - Are any people using the stumbleupon addon? Apparently it has a 'feature' where it will auto-bookmark any thumbs-upped item. In addition to being a massively stupid design decision, it also plonks a mouth-opening amount of bookmarks on the user's profile.

If you do not have a large amount of bookmarks, please open a new report as this one specifically targets this problem type.

summary: massive memory leak in unity-panel-service and hud-service when invoking
- the hud on certain Firefox Profiles
+ the hud on Firefox profiles with large amounts of bookmarks
description: updated
Changed in unity (Ubuntu):
status: Confirmed → Triaged

Hi,

I'm not using StumbleUpon and I don't even think I've a lot of bookmarks
(probably 300), so a lot of people are affected by this bug.

Em 27-08-2012 20:04, Chauncellor escreveu:
> Hi, it appears (based on duplicate comments) that this is dealing with
> huge amounts of bookmarks - Are any people using the stumbleupon addon?
> Apparently it has a 'feature' where it will auto-bookmark any thumbs-
> upped item. In addition to being a massively stupid design decision, it
> also plonks a mouth-opening amount of bookmarks on the user's profile.
>
> If you do not have a large amount of bookmarks, please open a new report
> as this one specifically targets this problem type.
>
> ** Summary changed:
>
> - massive memory leak in unity-panel-service and hud-service when invoking the hud on certain Firefox Profiles
> + massive memory leak in unity-panel-service and hud-service when invoking the hud on Firefox profiles with large amounts of bookmarks
>
> ** Description changed:
>
> - unity-panel-service and hud-service quickly racks up memory until I kill
> - it when invoking the HUD on Firefox. It's taking anywhere from a few
> - minutes to half an hour, but it sometimes makes the system unusable.
> + unity-panel-service and hud-service quickly racks up memory and CPU
> + usage until I kill it when invoking the HUD on Firefox. It's taking
> + anywhere from a few minutes to half an hour, but it sometimes makes the
> + system completely unusable.
>
> 1. run Firefox 12.0 in the foreground
> 2. hit Alt to bring up HUD
> 3. type any text
> 4. select one proposal from HUD
> + 5. wait for unity-panel-service and hud-service to fill up the remaining RAM and swap space.
>
> - Creating and using a new profile presents no memory leaks.
> + This is due to a high number of bookmarks in a user profile (hundreds).
>
> ** Changed in: unity (Ubuntu)
> Status: Confirmed => Triaged
>

Okay, stumbleupon was just one idea. This is definitely a bookmarks issue. Thanks for the replies!

Omer Akram (om26er) on 2012-08-29
Changed in unity (Ubuntu):
status: Triaged → Confirmed

Omer, is that not enough information for the developer to look at it?

Omer Akram (om26er) on 2012-08-30
Changed in indicator-appmenu:
importance: Undecided → High
status: New → Confirmed
M8R-6ct62c (m8r-6ct62c) wrote :

Same problem here. Firefox stops responding for 30 seconds or so. I have a bunch of bookmarks.

WORKAROUND:
-Go into the 'privacy' settings of ubuntu and
-disable tracking for websites
-and add firefox as an app to ignore
-log out/in

That seems to have solved it for me.

LA (radiobuzzer) wrote :

I tried the solution that was suggested above, but it didn't work for me. CPU load explodes even after enabling the Global Menu addon, and Firefox becomes irresponsive for a couple of minutes. This repeats whenever I type some command in HUD. My only solution was to disable the Global Menu addon, I am missing the feature, but at least I can keep browsing the internet...

Marcos Roriz (marcosrorizinf) wrote :

Any updates?

Same behaviour here and as described at Bug 1005174. Ubuntu 12.04 x86, hundreds of bookmarks, using a private Firefox Sync server.

Changed in unity:
milestone: none → 7.0.0
Torben Seebach (yeah) wrote :

I can confirm the workaround provided by M8R-6ct62c solved the issue where unity-panel-service and hud-service used enormous amounts of memory and menus took forever to appear.

Scott Weldon (501st-alpha1) wrote :

I can confirm this also affects me. I have a large number of bookmarks, and generally have several hundred open tabs (not sure if the latter adds to the problem). Disabling the Global Menu Bar integration addon fixes the problem.

Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Ivo Anjo (knuckles) wrote :

Same here, although I only have the issue when I mistakenly hit alt for the hud.
I think I have 2000+ bookmarks.

Enough people are me, too-ing it that I'm marking this as critical - Firefox and the HUD are defaults and it renders the system practically destroyed once it fills up the RAM.

Changed in unity (Ubuntu):
importance: High → Critical
Changed in unity:
status: Confirmed → Won't Fix
Changed in unity (Ubuntu):
status: Confirmed → Invalid

Care to share?

przekop (przekop) wrote :

Ubuntu 13.04 64bit
I have about 900 bookmarks and same problem? Does only solution is to remove Unity menubar integration?

Mike (sheenm) wrote :

I don't know why but on 13.10 unity-panel-service is buggy and leaks much RAM in some cases. Sometimes I cant even shut down my computer and need to restart this service

screenshot in attachments

I confirm that disabling unity addons in firefox and restarting unity-panel-service and hud-service greatly reduced their memory usage.

David Turner (dwt) wrote :

Gimp seems to be causing lots of problems. Right now unity-panel-service is sitting at around 343 MB (it was in the 200s a few minutes ago after running gimp for a little while, but re-opening it increased the memory by about 100MB). It seems whenever the menu is accessed it increases memory usage slightly. I should also point out that the menu has started to behave very sluggish, and using up 100% of one of my cores.

Gedit also seems to do this while editing either lots, or very large files.

John Kuang (xiphosurus) on 2014-03-11
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Guus Geluk (onsitecd) wrote :

Using 13.10. I have thousands of bookmarks in firefox 28.0. I disabled the unity extensions in Firefox. Most of the times it works okay, and I did not have the problem on earlier versions of Ubuntu. But lately Hud-service and unity-panel-service reach gigabytes of ram, totally stalling my computer. I do not understand what triggers it. It even happens if I did not use the HUD. Unity Panel service now is more than 1 gig and I cannot end the process anymore in system monitor.

In privacy settings I disbabled:
- use of file and app usage
- internet search results
- I excluded the firefox webbrowser

So why is it still collection browser information?

Guus Geluk (onsitecd) wrote :

Ubuntu 13.10, FF 28.0. Did some more testing. Problem indeed starts when you press ALT en type something. Due to my huge bookmark collection hud-service takes 1.3 GB and unity-panel-service 900MB (FF 800MB after start) and for some reason it stalls FF eventhough CPU usage is only 3%. After ending the services FF becomes responsive again.

Tobias Bradtke (webwurst) wrote :

Same symptoms for me like Guus Geluk, but on Ubuntu 14.04.

Sam_ (and-sam) on 2014-04-29
summary: massive memory leak in unity-panel-service and hud-service when invoking
- the hud on Firefox profiles with large amounts of bookmarks
+ the hud on Firefox profiles with large amounts of bookmarks LTS 12.04
+ 14.04
Kenan Gutić (kenan-gutic) wrote :

Ubuntu 14.04 LTS with Firefox 29 - same problem

Stephen M. Webb (bregma) on 2014-05-07
Changed in unity:
milestone: 7.0.1 → none
Changed in hud:
status: New → Confirmed
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hud (Ubuntu):
status: New → Confirmed
Otus (jan-varho) wrote :

I'm seeing hud-service taking hundreds of MB in 14.04, but I don't use Firefox (I use Chromium). Is this only for the Firefox issue, should I file another bug, or is there some master bug about current HUD memory leaks I can subscribe to?

Is this the cause of "init --user" having memory spikes?

http://about.me/rolandixor/

On Sun, May 11, 2014 at 3:59 PM, Otus <email address hidden> wrote:

> I'm seeing hud-service taking hundreds of MB in 14.04, but I don't use
> Firefox (I use Chromium). Is this only for the Firefox issue, should I
> file another bug, or is there some master bug about current HUD memory
> leaks I can subscribe to?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/987060
>
> Title:
> massive memory leak in unity-panel-service and hud-service when
> invoking the hud on Firefox profiles with large amounts of bookmarks
> LTS 12.04 14.04
>
> Status in Unity HUD:
> Confirmed
> Status in The Application Menu:
> Confirmed
> Status in Unity:
> Won't Fix
> Status in “hud” package in Ubuntu:
> Confirmed
> Status in “unity” package in Ubuntu:
> Invalid
>
> Bug description:
> unity-panel-service and hud-service quickly racks up memory and CPU
> usage until I kill it when invoking the HUD on Firefox. It's taking
> anywhere from a few minutes to half an hour, but it sometimes makes
> the system completely unusable.
>
> 1. run Firefox 12.0 in the foreground
> 2. hit Alt to bring up HUD
> 3. type any text
> 4. select one proposal from HUD
> 5. wait for unity-panel-service and hud-service to fill up the remaining
> RAM and swap space.
>
> This is due to a high number of bookmarks in a user profile
> (hundreds).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hud/+bug/987060/+subscriptions
>

LA (radiobuzzer) wrote :

In Ubuntu 12.04-12.10 I had solved this problem by moving the bookmarks from the toolbar and the menu, to "Unsorted Bookmarks". Back then, bookmarks which were not in the menu, did not get tracked by hud and therefore did not create an issue any more.

After having upgraded to 13.10, the issue is back. I haven't confirmed that unsorted bookmarks get tracked again, but I start assuming that this is the case.

Benjamin Schmid (benbuntu) wrote :

Joining the "me too" section here as freshly new baked 14.04 user. Came here as the hud process currently eats 2,454g and system checking processes (zfswatcher) are failing due to out of memory issues. And yes, I'm a heavy user of Firefox toolbar bookmarks, too. Trying the workaround of disabling the Firefox integration now.

me too. ubuntu 14.04

 PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 2527 jundurr+ 20 0 20.442g 0.019t 27836 R 100.4 62.5 1268:32 hud-service

hud-service is using 100% of single processor and 62.5 of my 32 gb of ram...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Rick Simmons (riktor75) wrote :

Same issue here. If I close Chrome, CPU on hud-service drops, but memory doesn't reclaim.
  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 3706 ricks 20 0 18.172g 0.017t 2500 R 97.1 55.5 249:42.52 hud-service

Benjamin Kerensa (bkerensa) wrote :

Other commenters have indicated this happens in other browsers to and the OP specifically pointed out the leak is in Unity not Firefox as such marking this incomplete for Firefox unless someone can substantiate that this is really a Firefox bug which is unlikely.

Changed in firefox (Ubuntu):
status: Confirmed → Incomplete
darko (darko) wrote :

Yes. Thanks!
darko

Taihsiang Ho (taihsiangho) wrote :

my case with updated trusty:

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 3342 tai2718+ 20 0 1115404 13620 5244 R 11.1 0.4 58:42.54 nautilus
 3018 tai2718+ 20 0 5605484 2.938g 3340 D 7.4 82.5 353:41.47 hud-service

I only launched the updater to update the system and leave the machine there after the updating installation.

Valentin Crone (va-crone) wrote :

Hello,
This bug affects me, hud-service take 3% of my CPU and more than 1.1GB of RAM !
I'm using Ubuntu 14.04 LTS with Linux 3.13.0-24-generic

Hi guys.

This bug affects my laptop as well, hud-service took a whole 2.2 GiB and 1 full core of cpu power, although i already removed many bookmarks in Firefox (or are 30-40 still too much ...).

I'll look if i find something using valgrind, it's time to get this bug fixed, it is already 3 years old.

I don't know why Ubuntu needs a web and bookmark search in its menu whatsoever ... The only thing I (and possibly 99.998427631 % of other people) use the search for is to start a program that I don't have in my left bar.

Don't do it if you cannot do it right!

Greetings!

ndstate (ndstate) wrote :

This bug just started killing my laptop. Often hud uses over 2.4 gigs of ram and slams by cpu.

Laxman (laxman-prabhu) wrote :

 3041 test 20 0 18.012g 0.013t 3404 R 101.4 84.6 105:35.95 hud-service
 3238 test 20 0 2915036 1.034g 24080 R 94.1 6.6 44:38.41 nautilus

Just consumed 18 GB of my memory and started swapping my disk :(

03-Ubuntu SMP Fri Aug 14 21:42:59 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Ubuntu 14.04 LTS (Server Edition)

Valentin Crone (va-crone) wrote :

I have personnaly disabled the execution of hud-service (chmod 000) because my computer use always 6GB of ram including 3GB by hud-service.

And the last time hud service was running it take 18.7GB of RAM for 16GB available.
Please fix this bug, on computer with only 4GB of ram it's a huge problem...
And sometimes it takes 100% of one I5 core, it provide lag and freezes...

Changed in hud:
importance: Undecided → Critical
tags: added: rls-w-incoming
Andrea Azzarone (azzar1) wrote :

Can you please try on 15.04? Please notice that some time the leak is not real, it's just the way the kernel manages the memory (but 18.7GB is for nor not normal at all)

Valentin Crone (va-crone) wrote :

I have the same bug since Ubuntu 12.04 LTS.

Colin Law (colin-law) wrote :

@va_crone you have not told us which version you are using now.

Valentin Crone (va-crone) wrote :

Ubuntu 14.04 LTS with Linux 3.13.0-65-generic

I have just tested the Ubuntu 15.10 but not for all day use. (The Next Release I will use for all day use will be the 16.04 LTS if it's the same or better than 14.04 LTS)

Dave Barker (kzar) wrote :

I'm also finding that the hud-service process has started leaking memory + CPU recently. It was never a problem for me before.

As I speak it's using 100% of one CPU core and 5.5gig of RAM! I'm finding it like that each morning and having to reboot before I start work for the day.

- Ubuntu 15.04
- Linux stoa 3.19.0-30-generic #34-Ubuntu SMP Fri Oct 2 22:08:41 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
- Thinkpad T450 i7 with 16gigs of ram

I don't really use Firefox, although I occasionally start it to test things. I have few/no bookmarks in Firefox.

If someone can explain how I can obtain the debug symbols for hud-service I'll have a go at running it under Valgrind.

Dave Barker (kzar) wrote :

The problem for me seemed to have been caused by having a single very large PDF on my Desktop. Even after stopping hud-service from executing I noticed that nautilus was consistently using 15% of one CPU core, but as soon as I moved that PDF somewhere else the problem went away. I've now allowed hud-service to run again, rebooted, and things appear to be working nicely again.

Observations:

 - Why is generating the preview icon for a large PDF so costly? Surely only the first page should be read and used for that purpose?
 - Surely these preview icons should be cached?
 - I think even if generating the preview icon is expected to be costly, there is a bug here as there is definitely a memory leak + the CPU usage stayed consistently high for hours. Surely the process should finish and then the CPU usage should drop away again?

> The problem for me seemed to have been caused by having a single very
> large PDF on my Desktop.

This is weird, since we don't check the inner of docs, but just the
menus. Maybe it was exporting many bookmarks?

However can you provide a sample of PDF that is causing this, and
steps how to reproduce?

Dave Barker (kzar) wrote :

The document is a compressed PDF of about 4 megabytes, it's mostly text but with some images. It's about 240 pages long, but you're right it has a detailed index. I can't share it here though unfortunately, it's a commercial ebook. (Drop me an email at <email address hidden> , I'll share it with you for purposes of reproducing this issue if you promise not to share it and delete it afterwards.)

Steps to reproduce? Just leave the file on your desktop!

tags: added: rls-x-incoming
removed: rls-w-incoming
Will Cooke (willcooke) on 2015-11-23
Changed in unity:
assignee: nobody → Andrea Azzarone (azzar1)
tags: removed: rls-x-incoming

Just now have `unity-panel-service` consuming 9.7 GB of RAM on Ubuntu 16.10. Do you want another report or an `apport-collect`?

Ben (ben-mueller1998) wrote :

16.10 have unity-panel-service taking up 3.5 GB of RAM. I've mainly noticed it after resume, as Firefox randomly begins to crash/freeze before the entire system becomes unstable.

Phil Boutros (philb61) wrote :

Also see https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1199877 This appears to be my issue since upgrading to 16.10 (tl;dr: Try killing Owncloud to see if that solves it)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers