compiz crashed with SIGSEGV in ends_with_iter_select<__gnu_cxx::__normal_iterator<char const*, std::basic_string<char> >, char const*, boost::algorithm::is_iequal>() from unity::ui::PointerBarrierWrapper::EmitCurrentData()

Bug #983268 reported by JW on 2012-04-16
244
This bug affects 54 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone
Precise
High
Andrea Azzarone

Bug Description

SRU testcase

1. install unity from precise-proposed
2 make sure unity does not crash and works fine.

This error happened soon after I connected the HDMI cable which connects my laptop to my TV screen.

Unity and compiz crashed: the top bar and side bar of unity disappeared, and all open applications which were spread over multiple workspaces were put on one workspace. However, everything also restarted and I lost no work.

I've connected the HDMI cable before, and never had this error happen before (although I've only been using 12.04 for three weeks).

I don't know if this is related, but at the exact moment the problem occurred, I was moving my mouse over the indicators, trying to change the volume settings.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity 5.10.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
ApportVersion: 2.0.1-0ubuntu3
Architecture: i386
CheckboxSubmission: 60a1cbca22e9e051c51fe9ef4512b4a7
CheckboxSystem: 2954e74ba17fb0e37fc942cd1d9fab4e
Date: Mon Apr 16 19:21:55 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120328)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=nl_BE:nl
 PATH=(custom, user)
 LANG=nl_BE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb45fbf9e <_ZN5unity2ui21EdgeBarrierController4Impl21OnPointerBarrierEventEPNS0_21PointerBarrierWrapperESt10shared_ptrINS0_12BarrierEventEE+78>: mov (%edx),%eax
 PC (0xb45fbf9e) ok
 source "(%edx)" (0x03000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent(unity::ui::PointerBarrierWrapper*, std::shared_ptr<unity::ui::BarrierEvent>) () from /usr/lib/compiz/libunityshell.so
 sigc::internal::slot_call2<sigc::bound_mem_functor2<void, unity::ui::EdgeBarrierController::Impl, unity::ui::PointerBarrierWrapper*, std::shared_ptr<unity::ui::BarrierEvent> >, void, unity::ui::PointerBarrierWrapper*, std::shared_ptr<unity::ui::BarrierEvent> >::call_it(sigc::internal::slot_rep*, unity::ui::PointerBarrierWrapper* const&, std::shared_ptr<unity::ui::BarrierEvent> const&) () from /usr/lib/compiz/libunityshell.so
 unity::ui::PointerBarrierWrapper::EmitCurrentData() () from /usr/lib/compiz/libunityshell.so
 ?? () from /usr/lib/compiz/libunityshell.so
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: compiz crashed with SIGSEGV in unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

JW (jw-00000) wrote :
JW (jw-00000) on 2012-04-16
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed

StacktraceTop:
 ends_with_iter_select<__gnu_cxx::__normal_iterator<char const*, std::basic_string<char> >, char const*, boost::algorithm::is_iequal> (SubEnd=<optimized out>, End=<optimized out>, Comp=<optimized out>, SubBegin=<optimized out>, Begin=<optimized out>) at /usr/include/boost/algorithm/string/detail/predicate.hpp:37
 ends_with<std::basic_string<char>, char [5], boost::algorithm::is_iequal> (Comp=<optimized out>, Test=<optimized out>, Input=<optimized out>) at /usr/include/boost/algorithm/string/predicate.hpp:159
 iends_with<std::basic_string<char>, char [5]> (Loc=<optimized out>, Test=<optimized out>, Input=<optimized out>) at /usr/include/boost/algorithm/string/predicate.hpp:194
 unity::IconLoader::Impl::ProcessGIconTask (this=0x96e5858, task=0xb03b788) at /build/buildd/unity-5.10.0/plugins/unityshell/src/IconLoader.cpp:428
 ?? ()

Changed in unity (Ubuntu):
importance: Undecided → Medium
summary: compiz crashed with SIGSEGV in
- unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
+ ends_with_iter_select<__gnu_cxx::__normal_iterator<char const*,
+ std::basic_string<char> >, char const*, boost::algorithm::is_iequal>()
tags: removed: need-i386-retrace
summary: compiz crashed with SIGSEGV in
ends_with_iter_select<__gnu_cxx::__normal_iterator<char const*,
std::basic_string<char> >, char const*, boost::algorithm::is_iequal>()
+ from unity::ui::PointerBarrierWrapper::EmitCurrentData()
Changed in unity:
status: New → Confirmed
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity:
milestone: none → 5.12.0
Andrea Azzarone (azzar1) on 2012-04-17
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Andrea Azzarone (azzar1) on 2012-04-18
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Aidamir Lovpache (aidamatrix) wrote :

I cannot decide it is exactly same bug as https://bugs.launchpad.net/ubuntu/+source/unity/+bug/984711, look's like the that. I see there is fixes commited already, but it just happend to me.

Andrea Azzarone (azzar1) wrote :

@Aidamir The fix has not yet been released.

Bruce Pieterse (octoquad) wrote :

I had my laptop resume from suspend mode and connected the external monitor with an SVGA cable to my laptop. I then moved sublime-text-2 to the external monitor where the window snapped to the top, making the application fullscreen. Once placed on the external monitor, the orange tint that normally fades away, stopped at about 50% before the crash occurred. Compiz reloaded, reloaded and I was prompted to report the bug.

Omer Akram (om26er) on 2012-04-26
description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released

Hello JW, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
JW (jw-00000) wrote :

Using the new version of unity, this bug does not occur anymore for me.

However, because originally the bug occurred only once out of the many times I connected the HDMI cable, I cannot know whether this means the bug is fixed, or that I now just had the luck not to run into this bug again...

Anthony Borrow (arborrow) wrote :

Thanks Martin - I'm not sure what all was covered with the patch. compiz is still crashing for me when using two monitors (NVidia 295.40) but it mentioned something about edgedetection so it may be a separate issue. Peace - Anthony

Didier Roche (didrocks) on 2012-04-30
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.12-0ubuntu1

---------------
unity (5.12-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher, Alt-Tab - clicking on launcher item or selecting a app in Alt-
      Tab raises all app windows, not just most recently focused (LP: #959339)
    - [heap corruption?] compiz crashed with SIGSEGV in _int_malloc() from
      g_realloc() from ... from g_dbus_connection_send_message_with_reply()
      from g_object_unref() from unity::dash::HomeLens::Impl::~Impl() from
      unity::dash::HomeLens::~HomeLens() (LP: #931201)
    - compiz crashed with SIGSEGV in _int_malloc() from __libc_calloc() from
      XOpenDisplay() from nux::WindowThread::ThreadCtor() (LP: #947844)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Window management - unity doesn't realise when applications bring their
      windows to the front (LP: #802816)
    - Dash - Clicking on the desktop dash border should do nothing, *NOT*
      close the dash (LP: #839472)
    - [FFe, UIFe] HUD - The HUD does not respect launcher icon size settings
      in autohide mode (LP: #921506)
    - compiz crashed with SIGSEGV in g_volume_get_mount() (LP: #918548)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - Panel is transparent when Dash is open; no blur no average BG color
      (LP: #965323)
    - Unity crashes with SIGSEGV when hitting debug DBus interface hard
      (LP: #979429)
    - compiz crashed with SIGSEGV in _int_malloc() from g_object_unref() from
      unity::dash::Model<unity::dash::FilterAdaptor>::~Model() (LP: #941750)
    - indicators menu are sometimes cut off at screen edge (LP: #883317)
    - the shortcut keys in workspace section of the shortcut overlay aren't
      translated (LP: #980828)
    - [regression] Dash keeps repainting unnecessarily (LP: #980924)
    - compiz crashed with SIGSEGV in nux::NTextureData::ClearData() from
      nux::NTextureData::~NTextureData() from nux::Texture2D::~Texture2D()
      (LP: #952378)
    - compiz crashed with SIGSEGV in g_object_unref() from
      unity::dash::Settings::~Settings() from
      unity::UnityScreen::~UnityScreen() (LP: #981764)
    - compiz crashed with SIGSEGV in unity::dash::ResultView::~ResultView()
      from unity::dash::ResultViewGrid::~ResultViewGrid() from
      nux::Object::Destroy() from nux::Object::UnReference() (LP: #942286)
    - compiz crashed with SIGSEGV in
      ends_with_iter_select<__gnu_cxx::__normal_iterator<char const*,
      std::basic_string<char> >, char const*, boost::algorithm::is_iequal>()
      from unity::ui::PointerBarrierWrapper::EmitCurrentData() (LP: #983268)
    - Chinese can't be shown completely in dash filter (LP: #984583)
    - [Unity 5.10] compiz crashed with SIGSEGV in
      unity::hud::HudIconTextureSource::ColorForIcon() from
      unity::hud::Icon::Icon() from emit from unity::IconTexture::IconLoaded
      (LP: #983646)
    - [regression] Close button does not close the dash/HUD (LP: #986264)
    - compiz crashed with SIGSEGV in g_volume_eject_with_operation_finish()
      fro...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.