Program's icon stays in Launcher after removing the program

Bug #981488 reported by Michal Predotka on 2012-04-14
96
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
High
Unassigned
Unity Distro Priority
High
Unassigned
software-center (Ubuntu)
High
Gary Lasker
Precise
High
Unassigned
unity (Ubuntu)
High
Unassigned
Precise
Undecided
Unassigned

Bug Description

Ubuntu 12.04
USC 5.2

[TEST CASE]
1. Launch the current Ubuntu Software Center in Precise.
2. Click the "Installed" toolbar button to access the list of installed applications.
3. Choose an installed application to remove (choose one for which there is a corresponding icon in the Unity launcher).
4. Click the "More Info" button.
5. In the details view for the application, click the "Remove" button and enter the password for the remove if prompted.
6. The uninstall process begins and the progress bar moves in Software Center.
7. At the end of the install process, verify that the corresponding icon in the Unity launcher has *not" been removed.
8. Close Ubuntu Software Center.
9. Update to both the software-center *and* unity packages in precise-proposed.
10. Repeat steps 1 through 6.
11. This time, at the end of the install process, verify that the corresponding icon in the Unity launcher is *removed*.

[REGRESSION POTENTIAL]
Risk of regression is very low as this is fixed by the new add-to-launcher timing from Software Center, and the code in Unity is unchanged for this (see comment #4 for this bug). Just verifying that the correct icon is actually removed should be enough.

---

Steps to reproduce:
1. Start USC
2. Select a program to install
3. Click “Install”
(in this moment icon of the program flies to Launcher)
4. Enter your password to authenticate
5. After the program is installed click “Remove” to uninstall the program

What happen:
Icon stays in Launcher

Expected results:
Icon of the program disappears from Launcher

Short screencast attached

Related branches

Michal Predotka (mpredotka) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
importance: Undecided → High
Gary Lasker (gary-lasker) wrote :

This is a fairly recent regression in behavior as the automatic removal of the Unity launcher item after removal of the application has been working and in place in Unity for a couple of cycles now.

As there is no interaction with Software Center for this, I will change the target package for this one to Unity as the regression appears to have happened there.

Many thanks!

affects: software-center (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
milestone: none → ubuntu-12.04
Didier Roche (didrocks) on 2012-04-16
Changed in unity (Ubuntu):
milestone: ubuntu-12.04 → none
Changed in unity:
status: New → Confirmed
importance: Undecided → High
milestone: none → 5.12.0
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → High
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.12.0 → 5.14.0
Changed in software-center (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Gary Lasker (gary-lasker)
milestone: none → precise-updates
status: Triaged → In Progress
Gary Lasker (gary-lasker) wrote :

While working on a fix in Software Center for bug 925014, I discovered that the root cause of *this* bug appears to be bug 999427, that is, that the Unity launcher items are pointing incorrectly to the desktop files that are installed by app-install-data rather than to the actual installed desktop files. Please see bug 999427 for more details.

The attached branch, lp:~gary-lasker/software-center/unity-launcher-integration-fixes, changes the operation of Software Center to fire the Unity launcher dbus event at the end of the package install process, thereby allowing the values sent over dbus to include the actual installed desktop file path. With this, the launcher icons are now correctly removed when the corresponding package is removed.

description: updated
Gary Lasker (gary-lasker) wrote :

With the new add-to-launcher timing from Software Center, no fix is needed on the Unity side so I've set that task as invalid.

Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in unity:
status: Confirmed → Invalid
Changed in unity-distro-priority:
status: Fix Committed → Invalid
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Changed in software-center (Ubuntu Precise):
status: New → Fix Committed
importance: Undecided → High
milestone: none → precise-updates
Changed in unity (Ubuntu Precise):
status: New → Invalid
Stéphane Graber (stgraber) wrote :

Reverting the precise task to In Porogress, Fix Commited is for packages that are in the -proposed pocket, this package is still in the Unapproved queue.

Changed in software-center (Ubuntu Precise):
status: Fix Committed → In Progress
Changed in unity:
milestone: 5.14.0 → none

Hello mmiicc, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/software-center/5.2.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Gary Lasker (gary-lasker) wrote :

I have verified that software-center version 5.2.5 in precise-proposed fixes this bug per the test case given in the description.

Thanks!

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.5

---------------
software-center (5.2.5) precise-proposed; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/fix-lp1009039:
    - fix treeview selection background (LP: #1009039)
  * lp:~mvo/software-center/fix-lp1011522:
    - fix bug where clicking on "Reinstall previous purchases" twice
      shows endless spinner (LP: #1011522)
  * lp:~mvo/software-center/click_url:
    - adds support for a "click_url" from the exhibits banner to
      support banners for things like the humble-bundle where we
      don't have packages but URLs (LP: #1020205)
  * lp:~mvo/software-center/hopefully-fix-lp1008229:
    - fix crash that can happen if there is an error while
      opening a deb file (LP: #1008229)
  * lp:~mvo/software-center/lp1026494:
    - typo fix in the hw description code (LP: #1026494)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/unity-launcher-integration-fixes:
    - fix bug where for-purchase items are not being added to the Unity
      launcher (LP: #925014)
    - fix bug where the Unity launcher item for an application incorrectly
      points to its app-install-data desktop file rather than its installed
      desktop file (LP: #999427)
    - fix bug where an application's icon remains in the Unity launcher after
      the corresponding application has been uninstalled (LP: #981488)
    - fix bug where the Unity launcher fails to auto-hide after installation
      of a for-purchase item (LP: #1002440)
    - fix bug where items in the "Independent" section are not being added
      to the Unity launcher (LP: #1012877)
  * lp:~gary-lasker/software-center/tech-items-to-launcher-fix-lp1006483:
    - don't add an item to the launcher if its desktop file specifies
      NoDisplay=true (LP: #1006483)
  * lp:~gary-lasker/software-center/launcher-integration-unit-tests:
   - additional unit tests to round out the suite for the Unity
     launcher integration feature
  * lp:~gary-lasker/software-center/fix-lp969907-for-5.2:
    - fix race condition in _app_activated_cb() (LP: #969907)
 -- Michael Vogt <email address hidden> Mon, 23 Jul 2012 16:38:04 +0200

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
Gary Lasker (gary-lasker) wrote :

This was released into Quantal quite a while ago now...

Changed in software-center (Ubuntu):
milestone: precise-updates → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers