Unity crashes when many windows are opened (intel_do_flush_locked failed: No space left on device)

Bug #977804 reported by alexus on 2012-04-10
This bug affects 37 people
Affects Status Importance Assigned to Milestone
mesa (Fedora)
Won't Fix
mesa (Ubuntu)
unity (Ubuntu)

Bug Description

Unity 5.8.0 (Ubuntu 12.04 Beta) crashes (or hanged up) on Fujitsu-Siemens S7020 (Intel 915GM Express Chipset) very often during attempt to use Dash or switch between applications when many winsows are opened with following error:
intel_do_flush_locked failed: No space left on device

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic-pae 3.2.14
Uname: Linux 3.2.0-22-generic-pae i686

ApportVersion: 2.0-0ubuntu4
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Tue Apr 10 11:25:45 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120314)
 Socket 0:
   no product info available
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic-pae root=UUID=e6a4deb8-3e53-4afb-aed8-997537309262 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/16/2005
dmi.bios.vendor: FUJITSU // Phoenix Technologies Ltd.
dmi.bios.version: Version 1.07
dmi.board.name: FJNB19C
dmi.board.vendor: FUJITSU
dmi.board.version: CP234410-02
dmi.chassis.type: 10
dmi.chassis.vendor: FUJITSU SIEMENS
dmi.chassis.version: S7020
dmi.modalias: dmi:bvnFUJITSU//PhoenixTechnologiesLtd.:bvrVersion1.07:bd09/16/2005:svnFUJITSUSIEMENS:pnLIFEBOOKS7020:pvr:rvnFUJITSU:rnFJNB19C:rvrCP234410-02:cvnFUJITSUSIEMENS:ct10:cvrS7020:
dmi.product.name: LIFEBOOK S7020
dmi.sys.vendor: FUJITSU SIEMENS
version.compiz: compiz 1:
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

alexus (alexus-m) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Béné (bene-d) wrote :

Because of the bug unity 3D is unusable for me in dual monitor mode. (Crashes roughly every 10 mins.)
Single monitor mode is fine so far.

Im using todays daily with all updates installed on a Dell Inspiron E1505 with an Intel 945GM/GMS graphics card.

Béné (bene-d) wrote :

The bug also happens in single monitor mode - not as often however. It is often triggered by opening the dash or by calling the exposé-like overview of one application's opened windows.

Leandro (leandro-pangea) wrote :

This bug is really annoying. I confirm the behaviour on my Dell Latitude D430 (Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)).

It makes my laptop nearly unusable as it happens randomly and sometimes in periods of 10-30 minutes. The screen freezes and a restart is needed. Not sure if this is a unity bug or more an X issue (Intel driver) but it really makes this Ubuntu release unstable and unusable for anyone experiencing this bug.

The message is "intel_do_flush_locked failed: No space left on device" after the screen freeze.


This error ("intel_do_flush_locked failed: No space left on device") does also affect Gnome Shell users with said Intel Graphics. Gnome Shell dies upon this and no keystrokes are forwarded to applications, although mouse and application menus do work. This happens with on a single monitor with approx. 10 to 15 applications/windows open on multiple workspaces (usually 3 or 4).

Workarounds / Quickfix / Rescue:
* sudo gdm restart (from a TTY)
* gnome-shell --replace -d :0

The second workaround keeps the running applications.

Fwiffo (borgified) wrote :

unity --reset also gets you going again (control-alt-f1 first)
happens all the time, at least 5+ times a day

bojo42 (bojo42) wrote :

Same here with "intel_do_flush_locked failed: No space left on device" on up to date precise amd64 and a HP NC6400 with 945GM. The workaround for Unity is CTRL-ALT-F1 and "unity --replace". So at least X does not crash and our opened windows and unsaved data are still there, but it is so annoying and after all the destop is unstable.

Who has ideas for further debugging?

Enrico Battocchi (lopo) wrote :

Same here on a Asus Eee PC 100H sporting an Intel 945GSE (on lspci: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller).

Ben Bana (pm19034) wrote :

Same here on Dell D820
VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller

summary: - Unity crashes when many windows are opened
+ Unity crashes when many windows are opened (intel_do_flush_locked
+ failed: No space left on device)
Changed in unity:
status: New → Confirmed
description: updated
Henrik S. (henrik-hw0) wrote :

Tried to run the game Bastion and get the message:
"intel_do_flush_locked failed: No such file or directory"

uname reports:
Linux henrik-laptop 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

and lspci reports:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)

I guess it's the samme issue. and i run gnome 3 so clearly it's not an issue with unity. my guess is it's either an issue with the kernel driver or mesa. maintainers should check upstream for fixes.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
ossjunkie (ossjunkie) wrote :

Please test if the newest mesa update also fixes our issue:


Enrico Battocchi (lopo) wrote :

I've updated the mesa packages this morning as I found them in precise-updates, but still have the same problem.

Omer Akram (om26er) on 2012-06-05
Changed in mesa (Ubuntu):
importance: Undecided → High
ossjunkie (ossjunkie) wrote :

That's sad, altough i didn't have the issue with the update on the last 12 hours in single monitor mode. Further verifications by others would be nice.

As already said it seems to get triggered on dual monitor mode far more often. Could there be a link to 2048x2048 texture limitation that we have on 945 and maybe as well on 965 Intel graphics?

Did someone already test the options mentioned in "man intel"?

alexus (alexus-m) wrote :

  I still have the issue with "intel_do_flush_locked failed: No space left on device" (Unity 5.12.0, single monitor configuration, i915) in spite of all last available updates were installed.
  I've not tried to change any X.org/driver settings - everything has default values.

  I can try to collect new set of symptoms if required. Additionaly I would change settings if you advice me.

  I have seen message about 2048x2048 of HW limitation during attempt to use two monitor configuration in Unity. But there is no problem with Unity2D: nor with the topic neither with the limit of resolution. The only problem of Unity2D is low speed (at least for me)...

Steffen Goetz (steffengoetz) wrote :

I'm also getting this crash with the latest unity and all updates as of 2012-06-11.

I can force this crash by opening nautilus and pressing Control-N 20 times to open 20 nautilus windows. The next time I press Alt-Tab or Super-W I will get the crash.

By opening 20 nautilus windows I can also crash Gnome-Shell, so I think this is definitly a graphics driver issue :-(.

ossjunkie (ossjunkie) wrote :

I can reconfirm that opening a lot of nautilus windows and then clicking on it's switcher seems to trigger the bug quite well.

While i'm running a single display setup for the last week, i noticed that this bug seems clearly resolution dependent, as when i run 1280x800 on LVDS it's much less present than when running 1680x1050 on external VGA.

Steffen Goetz (steffengoetz) wrote :

I tried xserver-xorg-video-intel version 2:2.19.0-0ubuntu1~xup1 from the ubuntu-x-swat ppa, but the bug is still there.

ossjunkie (ossjunkie) wrote :

@Steffen: I think testing newer mesa versions and kernels might be more promissing, as the bug should be in the 3D stack.

Description of problem:
In Fedora 17, trying to run GNOME Shell on my second monitor (laptop's own screen disabled) works for a little while but then GNOME Shell suddenly disappears (windows are still there, but without a window manager). The following is printed to the terminal right before it disappears:
"intel_do_flush_locked failed: No space left on device"

My second monitor uses a resolution of:

The video card in my laptop is this:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Device 30b1
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at f4600000 (32-bit, non-prefetchable) [size=512K]
 I/O ports at 4000 [size=8]
 Memory at e0000000 (32-bit, prefetchable) [size=256M]
 Memory at f4680000 (32-bit, non-prefetchable) [size=256K]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: <access denied>
 Kernel driver in use: i915

I believe the problem is due to the amount of memory available, 256MB, and GNOME Shell's use of 3D acceleration.

If I try using GNOME Shell with both my laptop's screen and the second monitor (not mirrored, so 1024 + 1920 wide), everything is unusably slow with mouse clicks taking 10 seconds or more to respond. If I try to use metacity + GNOME Panel, it works fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. enable second monitor (disabling laptop's own screen)
2. use GNOME Shell
3. open some windows (say 10) and work for a little while

Actual results:
GNOME Shell disappears

Expected results:
GNOME Shell persists. (Ideally, it could work with 1024+1920 wide screens too (so including first monitor.)

Additional info:
I tried running gnome-shell under gdb but it exits normally after printing that error message. I don't think anything is actually crashing. I didn't see anything particularly relevant in /var/log/Xorg.0.log, but I could look again if something should be there.

I've added a link to a corresponding bug in Ubuntu that affects both gnome-shell and launchpad.

Also, I believe the bug is induced by a limitation in the driver discussed in bug 699705 comment 6:

Adam Jackson speculated that it might be fixed by F16 but it's F17 and still a problem, so I suppose no one has had the time ot tackle this yet.

Actually, maybe not, since I'm testing this with a single screen that only goes to 1920 wide.

However, I suppose I'd like to modify Expected Behaviour to:
* either GNOME Shell persists, or
* upon failure, a prompt offers to put me into fallback mode (GNOME Panel + metacity) or it just automatically does and gives me a message noting why.

Bryce Harrington (bryce) wrote :

I don't see anything in the newer mesa version that indicates it fixes this specific bug, but I've stuck a package of it into a PPA for you guys to test out:


If anyone finds this *does* fix the issue and can confirm it solves the crash, we may be able to get the fix rolled out in precise.

Changed in mesa (Ubuntu):
status: Confirmed → Incomplete
ossjunkie (ossjunkie) wrote :

@Bryce: I just tested the packages from your PPA, but as you have already guessed Mesa 8.0.3 doesn't fix the issue. What i meant was also rather new major versions.

But as you changed the status to incomplete what advices do you have on further debugging and testing? Or did you have the chance to reproduce the issue yourself like already explained?

BTW The issue should affect a rather large installation base with the relevant Intel generations also being in netbooks and chromebooks.

alexus (alexus-m) wrote :

  Additionally I have tested packages from
https://launchpad.net/~xorg-edgers/+archive/ppa :
mesa 8.1~git20120606.ec19bdd1-0ubuntu0sarvatt~precise ,
xserver-xorg-video-intel 2:2.19.0+git20120606.c433fb45-0ubuntu0sarvatt~precise -
No visible progress related to the issue.

Steffen Goetz (steffengoetz) wrote :

@Bryce: I have also tested your package (8.0.3-0ubuntu0~xup1~precise) but the crash is still there :-(

Changed in mesa (Ubuntu):
status: Incomplete → Confirmed
alexus (alexus-m) wrote :

The issue is confirmed also for other distrubutions e.g., Fedora 17:

Hi all,

I have the same issue affecting Ubuntu 12.04 (x86 desktop) on lenovo 3000 v100, which has an Intel Corporation Mobile 945GM/GMS/GME graphics card.

I used to restart compiz when this bug crashes my desktop, but I also noticed that changing the "window switcher" in unity works as a work around. I tested the following solution with opening 40 nautilus windows, and hitting alt-tab several times, as well as with the Workspace switcher, and there was no crash.

Anyway, all I did was:
- install ccsm (sudo apt-get install compizconfig-settings-manager)
- run ccsm (go to dash, type ccsm)
- Scroll down to Window Management - Enable Application Switcher (the top-left plugin right under Windows Management).
- It will tell you several key bindings are the same with Unity. Select the appropriate option to override these settings.
- That's all.

I wrote the above steps from my mind, so if someone can test & write a better guide that would be great.


Steffen Goetz (steffengoetz) wrote :

Hi batu,

I tried your workaround but it did not solve the underlying problem for me.
The Alt-Tab window switcher from ccsm works now with a lot of windows but Super-W still produces the crash with error message

intel_do_flush_locked failed: No space left on device

in the .xsession-errors file.

I have an Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02) on my machine and 20 windows are enough to produce the crash with Super-W.

alexus (alexus-m) wrote :

Hi, All!

I've installed an update of compiz up to version 1: via -proposed repository. The update has fixed some errors included
compiz (decor) - Warn: failed to bind pixmap to texture
I have made few tests of Unity (3D) in part of switcning between many opened windows (e.g., Nautilus and gnome-terminal) via Super+W, Alt+Tab, Alt+` with success (without crashed Unity due to the bug "intel_do_flush_locked failed: No space left on device").
The only thing is used "xorg-edgers" ppa. Will try to purge the ppa and test Unity behaviour once again.

ossjunkie (ossjunkie) wrote :

@alexus: sounds promissing, would be great if you could test it without xorg-edgers and just -proposed (and maybe also vice versa).

alexus (alexus-m) wrote :

Hi, All!

I have tested some currently available versions of the packages:
1) precise-proposed (mesa 8.0.2-0ubuntu3.1, compiz 1:, xserver-xorg-video-intel 2:2.17.0-1ubuntu4);
2) precise-proposed + PPAs ubuntu-x-swat/x-updates (mesa 8.0.2-0ubuntu3.1, compiz 1:, xserver-xorg-video-intel 2:2.19.0-0ubuntu1~xup1);
3) precise-proposed + PPAs ubuntu-x-swat/x-updates + bryce/mesa-803 (mesa 8.0.3-0ubuntu0~xup1~precise, compiz 1:, xserver-xorg-video-intel 2:2.19.0-0ubuntu1~xup1);
4) precise-proposed + PPAs ubuntu-x-swat/x-updates + xorg-edgers/ppa (mesa 8.1~git20120618.1692d3ad-0ubuntu0sarvatt~precise, compiz 1:, xserver-xorg-video-intel 2:2.19.0+git20120628.31caa43a-0ubuntu0sarvatt~precise).
In cases 1-3 my i915GM can manage about 15-20 windows (e.g., Nautilus) in Expo mode of windows overview.
In case of 4 - Expo mode handles up to 45-50 windows but not more.
As a result I would conclude that the issue is still there. Sad but true.

alexus (alexus-m) wrote :

I have to correct my previous calculations:
4) precise-proposed + PPAs ubuntu-x-swat/x-updates + xorg-edgers/ppa (mesa 8.1~git20120618.1692d3ad-0ubuntu0sarvatt~precise, compiz 1:, xserver-xorg-video-intel 2:2.19.0+git20120628.31caa43a-0ubuntu0sarvatt~precise).
In case of 4 - Expo mode handles up to 35-40 windows but not more.

It is still twice more than other variants (1-3) but less than I've posted early.

@Steffen Goetz: You are right, the bug is definitely still there. Actually today when I was working on the second monitor, I keep getting compiz crashes with the "intel_do_flush_locked failed: No space left on device" message, triggered with Alt+tab switching... I don't know if anything had changed (updates etc.) since I posted the message. Hope a solution can be found soon. I will try alexus' suggestion now.

asala (asala) wrote :

In my case, with a fully updated ubuntu 12.04 as of today, it happened to me twice... and "many" windows were actually just a couple of Nautilus, one Firefox, one Thunderbird... clicking on the top unity icon (trying to open a new application) froze everything once the dash was displayed, with four windows.
Dual display 1360x768 plus 1280 x 800... (1360x1568), seems that something gets "out of memory"...
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
This is a "production" machine, nothing "bleeding edge" installed.

DarkVenger (darkvenger) wrote :

As asala I too have a fully updated Ubuntu 12.04 (today there was even an update to compiz).

But the problem remains and I have like 7 to 9 windows opened...

Any time there is a freeze unity says
"intel_do_flush_locked failed: No space left on device"

and in dmesg I see
"[ 5932.613235] [drm:drm_mode_getfb] *ERROR* invalid framebuffer id
[ 6039.184478] [drm:drm_mode_getfb] *ERROR* invalid framebuffer id"

Don't know if is useful information but the errors seem to be linked.

I see this problem too on latest gnome-shell (3.5.5), intel driver (2.20.3) and mesa (8.1.0 git snapshot from 2nd August) and a 945GM on a single monitor. I'm not on Fedora so not going to comment too much, just want to watch the bug for a fix! Seems to happen very regularly when new windows are opened.

alexus (alexus-m) wrote :

Hi All!

  Are there any progress in the issue investigation? I just worry that if the problem will be still there in the next release of Ubuntu (12.10) it will be unavoidable for more users because of there is no planned "fallback" shell like Unity 2D.
  Can we speed investigation up?

alexus (alexus-m) wrote :

Hi All!

  Are there any progress in the issue investigation? I worry that if the problem will be still there in the upcoming release of Ubuntu (12.10) it will be unavoidable for many users because of absent Unity 2D.
  Can we speed the investigation up?

alexus (alexus-m) wrote :

I' found the similar bug reported in "KDE Bugtracking System":

Changed in debian:
status: Unknown → New
Henk Huitema (henk-huitema) wrote :

With my 1920x1200 resolution I hit this bug with only my primary laptop screen. It is still present in 12.10. It makes Ubuntu unusable, since unity-2d is not available anymore. I've ran into this bug consistently since a few years, never bothered to investigate, just switched to 2d. Now the best analysis I've found is by Adam Jackson:

Problem is present on my hardware as well (ThinkPad T43 with Intel GM915) under Ubuntu 12.10 and 13.04 Alpha.

This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we may not be able to fix it before Fedora 17 is end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged change the
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

hackerb9 (hackerb9) wrote :

Did this ever get fixed?

andi (andi001) wrote :

I am still experiencing this ennoying and quite important "every-day-use functionality" bug :-((((
(especially as a developer where you often have to switch between many windows and often only between two very often, e.g. browser, eclipse, ...)

lirel (m8r-lcodw5) wrote :

This also happens in debian GNOME Shell 3.4.2 on a Thinkpad T60.

Pokulo (pokulo) wrote :

Happens still to me an arch linux, with Intel Corporation Mobile 945GM, and Gnome-Shell 3.12.2. Has is ever been fixed?

Guillermo Lo Coco (glococo) wrote :

Happens to me, every time I launch bricscad in 3D mode

intel_do_flush_locked failed: No such file or directory

[ Ubuntu 14.10, PPA Olaf ] [ HP G62: VGA Intel i915 with hybrid muxless Radeon HD54xx ]

Elvis Stansvik (elvstone) wrote :

Just like Guillermo, I'm trying to run BricsCAD on my X220 laptop and get this error/crash. Anyone know if it has been reported upstream and if there's a fix in sight?

To Guillermo: Did you ever find any workaround to getting BricsCAD to run? I tried setting LIBGL_DISABLE_DRI3 in the environment since I saw that tip here: https://bugs.freedesktop.org/show_bug.cgi?id=71759 , but it didn't work :(

Rodrigo (rodhos-hp) wrote :

Can anyone confirm the bug is still present in Ubuntu 15.10?
Can you reproduce the bug in any desktop or just Unity 7 and Gnome-Shell 3.12.2?

PabloAB (pabloab777) wrote :

This happen to me on Ubuntu 16.04.1, on Firefox 50.1.0, running it on CLI randomly (couldn't find any pattern) crashes with "intel_do_flush_locked failed: No such file or directory".
Asus UX303UB
uname -sir: Linux 4.4.0-59-generic x86_64
product: HD Graphics 520
vendor: Intel Corporation
configuration: driver=i915_bpo latency=0

Changed in mesa (Fedora):
importance: Unknown → Undecided
status: Unknown → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.