Starting Unity fails with a segmentation fault

Bug #967252 reported by papukaija on 2012-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
High
Unassigned

Bug Description

After logging in, Unity doesn'start, the panel doesn't appear, only the pointer, the background and the icons on the desktop are visible. I can open the terminal by hitting Ctrl+Alt+T but Unity related shortcuts don't work. I tried restarting the system but it didn't help.

Running unity --reset fails while loading the expo plugin:

unity-panel-service: ei prosesseja (no processes)
Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend : gconf
Integration : true
Profile : default
Adding plugins

[...]

compiz (expo) - Warn: failed to bind image to texture
Initializing expo options...done
Initializing ezoom options...done
Setting Update "open_effects"
Setting Update "close_effects"
Setting Update "minimize_effects"
Setting Update "shade_effects"
Setting Update "focus_effects"
Segmentation fault (core dumped)

The window borders became visible after running the above command. The Unity hasn't worked very well until yesterday because of bug 963093 but now it's not working at all. Please let me know if you need any further debugging information.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic i686
ApportVersion: 1.95-0ubuntu1
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Wed Mar 28 16:28:50 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386 (20091028.4)
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-03-02 (25 days ago)

papukaija (papukaija) wrote :
papukaija (papukaija) wrote :

Further debugging:

I opened ccsm as suggested in https://bugs.launchpad.net/unity/+bug/963093/comments/56 and I noticed the Unity plugin was disabled. I was able to enable but it complained about two keybindings, not sure which ones as the error message and the labels weren't visible, but I allowed it to change them to the default ones. Unity is now fully working and this bug hasn't occurred since 3 restarts.

Should this bug be closed as invalid because I don't know what disabled the Unity plugin or even marked as a duplicate of 963093 (since the above mentioned comment suggests that this bug could occur as a result of that bug)?

Daniel van Vugt (vanvugt) wrote :

papukaija, it sounds like you have encountered multiple different bugs which are being worked on at present.

However since you can't reproduce any bug now, I will leave it as Incomplete and the bug will expire in a few months if no more comments are added.

Thanks for your report.

Changed in unity (Ubuntu):
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

Now open your file manager, navigate to your /var/crash directory and open the crash report you wish to submit.
If this fails you will have to open a terminal and file your report with 'ubuntu-bug /var/crash/_my_crash_report.crash' where _my_crash_report.crash is the crash you would like to report. If you get an error that you aren't allowed to access this report you will have to file it with 'sudo ubuntu-bug /var/crash/_my_crash_report.crash'.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in unity (Ubuntu):
importance: Undecided → High
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers