Launcher tooltip says "Waiting to install" when application is actually installing

Bug #966189 reported by Matthew Paul Thomas on 2012-03-27
66
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
Unity
Fix Released
Low
Christopher Townsend
5.0
Triaged
Low
Unassigned
6.0
Won't Fix
Low
Unassigned
unity (Ubuntu)
Low
Christopher Townsend

Bug Description

unity 5.8.0-0ubuntu2, Ubuntu Pangolin

1. In Ubuntu Software Center, choose an application and choose "Install".
2. While it is still installing, mouse over the launcher tile.

What happens: A tooltip appears saying "Waiting to install". This tooltip remains even after the package installation has completed.

What's wrong with this: It's not waiting to install, it's installing.

What should happen: Either there is no tooltip at all, or it says "Installing".

-------------------------------
Desired resolution:

- When installation is in progress, the tooltip should say "Installing..."

Related branches

Matthew Paul Thomas (mpt) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-06-13
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
description: updated
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
status: Confirmed → In Progress
assignee: nobody → Bilal Akhtar (bilalakhtar)
kchris (kochkal) wrote :

I specifically created this account to report the same error. This is very annoying and confusing. I would also recommend the option of having the launcher on the bottom as well. I cannot believe launcher cannot bemoved around.
Thank you

Since we can't break i18n for unity 5.0 we need different fixes... It's ok to change the string on 6.0, but not on 5.0

Changed in unity:
status: In Progress → Confirmed
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Changed in unity:
milestone: none → 6.2

To make more sense to probably solve this bug, I'd change "Waiting to Install" to "Installation in progress..." or something of that nature.

Here is a different one, The only thing I do not know the Variables for %AppName%

The attachment "launcher.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Matthew Paul Thomas (mpt) wrote :

installshield_freak, thanks for that work. But as you note in a code comment, it's still not accurate: it would say "Installation in Progress..." when it's actually still waiting to install. And I'm not sure if I'm reading it correctly, but a test asserting that the text does not equal "Installation in Progress" without ellipsis isn't useful if the text is never that, but sometimes "Installation in Progress..." with Ascii dots.

Beyond that, though, it doesn't look right to me that text like "Installation in Progress..." would be embedded into the Unity code at all. I think Unity should be getting the status text for the operation directly from Aptdaemon. <https://wiki.ubuntu.com/SoftwarePackageOperations#operations> So if Aptdaemon says the status is "Waiting to install", the tooltip says "Waiting to install". If Aptdaemon says the status is "Downloading… (4.7 MB of 5.3 MB)", the tooltip says "Downloading… (4.7 MB of 5.3 MB)". If Aptdaemon says the status is "Installing…", the tooltip says "Installing…". And so on.

Only once the operation completes should Unity either change the tooltip to the application name (if it was a successful installation) or remove the item altogether (if it was a removal or an unsuccessful installation).

Didier Roche (didrocks) on 2012-08-10
Changed in unity:
milestone: 6.2 → 6.4
Changed in unity:
milestone: 6.4 → 6.6
Changed in unity:
milestone: 6.6 → 7.0
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Stephen M. Webb (bregma) on 2013-04-25
Changed in unity:
milestone: 7.0.1 → 7.1.0
Christopher Townsend (townsend) wrote :

I don't think Bilal is working on this anymore. Unassigning this bug.

Changed in unity:
assignee: Bilal Akhtar (bilalakhtar) → nobody
Changed in unity (Ubuntu):
assignee: Bilal Akhtar (bilalakhtar) → nobody

The tooltip and progress bar are not shown on Raring and Saucy. I'm not sure if this is by design or a bug. If this is by design, then this particular bug is no longer relevant.

Ok, so the icon with the tooltip and progress bar only show when installing something using the Dash, not using Software Center.

Changed in unity:
assignee: nobody → Christopher Townsend (townsend)
status: Triaged → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)

I'm going to ask Design what exactly they want the tooltip to display when the app is installing.

tags: added: needs-design
John Lea (johnlea) on 2013-07-17
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Low
status: New → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.0

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package unity - 7.0.2+13.10.20130723.1-0ubuntu1

---------------
unity (7.0.2+13.10.20130723.1-0ubuntu1) saucy; urgency=low

  [ Marco Trevisan (Treviño) ]
  * debian/control:
    - build-depend on xserver-xorg-video-dummy and libgl1-mesa-dri
    - build-depend on libnux-4.0-dev (>= 4.0.2+13.10.20130718.1)

  [ Michal Hruby ]
  * When requesting a channel from scopes, use the DIFF flag, which will
    cause scopes machinery to do a diff between the old and new model
    states, so results that didn't change will stay in the model -
    previously they would be removed and re-added.
  * Reset the connected property when scope disappears.
  * Added getter for content-type property to Category class.
  * Manually merged lp:~mhr3/unity/fix-ap-preview-tests
  * Preload results after removal, as they might got moved into a
    visible position.
  * Fix scope-related tests. (LP: #1199961)

  [ Brandon Schaefer ]
  * Correctly set back the filter scroll views state when
    leaving/entering the scope view. (LP: #1175666)
  * Don't calculate the velocity if dtime is 0. This way we don't get a
    huge velocity on the initial barrier hit. (LP: #1199050)
  * Show desktop now only works for individual workspaces. Also if any
    new windows are opened, or one is restored on that workspace then
    the next Show desktop will minimize those. The only time windows are
    restored are when no new windows have been mapped, and no windows
    have been restored for that workspace only. (LP: #966030)

  [ Marco Trevisan (Treviño) ]
  * CMake: re-enable DBus Tests, excluding TestScope* This exclusion is
    due to lp:1199961 to be fixed ASAP. (LP: #1199961, #1199962)
  * TestGtest: Addedd TestPanelService and new tests to
    TestStaticCairoText, removed test-unit Improved the u-p-s stability
    and refactored a little its initialization to allow testing with
    only mock indicators. (LP: #1200748)
  * GLibDBusServer: set the proper destroy function when resetting the
    InterfaceInfo ptr.

  [ Didier Roche ]
  * Adjust CMake setup to account for new GMock version. . (LP:
    #1185265)

  [ Chris Townsend ]
  * Modify the Launcher icon of an installing app to display
    "Installing..." instead of always saying "Waiting to install". (LP:
    #966189)

  [ Thomas Voß ]
  * Adjust CMake setup to account for new GMock version. . (LP:
    #1185265)

  [ Nick Dedekind ]
  * Removed the legal link and icon from the dash. .
  * Reverted r3415 "remove legal link" -
  * Removed the legal icon, again.

  [ Manuel de la Pena ]
  * Fix the introspection so that QA can work with autopilot. (LP:
    #1185486)

  [ Charles Kerr ]
  * in panel-service.c's load_indicators_from_indicator_files(), plug a
    GDir leak.

  [ Pawel Stolowski ]
  * Activate (installed) applications on single left-click in Home and
    Applications scopes view. (LP: #1189088)

  [ Andrea Azzarone ]
  * Define/Init UnityWindow::cWindow. (LP: #1203129)

  [ Jeremy Bicha ]
  * Drop unnecessary python-gconf dependency.

  [ Łukasz 'sil2100' Zemczak ]
  * Disable the TestAnimationOpacity test, as it's failing on powerpc.

  [ Ubuntu daily release ]
  * Automatic snapshot from ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.1.0.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Bug attachments